-   Slackware (
-   -   KDE DCOPServer Problems with Slackware 10.1 (

Saith 08-23-2005 05:01 PM

KDE DCOPServer Problems with Slackware 10.1
Hey all.

Some background into my problem:

I started out installing Slackware 10.1 on my old HP Pavilion I got 3 years ago. I chose KDE as my default GUI to start, but my graphics card (NVidia GeForce 5500 AGP) had no driver support after the install. After typing startx at the command prompt my computer would freeze and I would have to do a hard shutdown-reboot.

I then tried installing the NVidia drivers, except they wouldn't load on the 2.4.29 kernel. I fixed this by upgrading my kernel to 2.6.10. After successfully installing the driver, now KDE starts, but it gives me an error about DCOPServer not initializing.

I've researched the problem on here and on google, but everyone else who gets that same error message doesn't seem to have the same problem as I have. The solution is generally to change permissions of the /home/<user> directory or to delete some hidden files (.ICEsomethingorother and .DCOPServer.) I've tried changing the permissions and when I type ls -al in the /home/<user> directory the hidden directories I'm supposed to delete just aren't there.

I talked to my friend who has used linux since the 1980's and he suggested upgrading my x windows files so they are compatible with the upgraded kernel.

I also read a lot of posts saying that most of the time problems in linux are due to configuration errors. I figured while I'm figuring out the x windows problems I could get some feedback on here regarding alternative fixes in case reinstalling X doesn't work.

flebber 08-24-2005 02:16 AM

I had a DCOP error that stated


I solved it with this info from the vectorlinux board from the everwise JohnB

"DCOP" stands for KDE's interprocess communication (IPC)/remote procedure call (RPC) technology. You might want to try deleting all of the .DCOP files in your home directory to resolve the problem (they'll be regenerated the next time you start KDE). First, get out of KDE altogether (no reboot necessary) and login to the console as yourself. Once you're logged in to the console as yourself, you should be at the top level of your home directory. Type the following at the prompt:

rm -f .DCOP*

This will force removal of all hidden DCOP files at the top level of your home directory. Once you've done this, type startkde at the prompt. Hopefully the DCOPserver errors will go away.
I am currently using slack 10.1 but vector is slack based and all his notes should still apply.

Saith 08-24-2005 09:02 AM

Yeah, sorry if I wasn't clear in my original post, but KDE doesn't generate any .DCOP files in my home directory. It's frustrating because everywhere I look the solution is to delete those files, or change ownership of them, but I simply don't have them.

Thanks for the advice, though.

tobyl 08-24-2005 03:15 PM

try this, delete any of the files below that exist.

~/.DCOPserver-* (there are usually two of these, one is a symlink to the other)


~/.kde/tmp-hostname which is normally a symlink to the next file:


~/.kde/socket-hostname which is also normally a symlink to:


also make sure /tmp/.ICE-unix is read/writable by your user.

if still no joy, repeat above after renaming ~/.kde to something else to force a new kde config...

Saith 08-24-2005 09:42 PM

I'm officially a :newbie:

Thanks tobyl, when I did my original install I did a

chmod -R a-w /

thinking how clever I was making all my system files read-only. I guess I didn't suspect that any of these files would need to be written to :rolleyes:

I did chmod -R a+w / and KDE started up like a charm. Looks like I'll be doing a reinstall to return the correct permissions to all my files, which are beyond recoverable by now

Oh well, at least I have my config file for the 2.6.10 kernel still around.

picobyte 10-13-2007 07:46 AM

You don't have to delete these directories. Changing ownership and mode is enough. You can put lines below somewhere in the top of your startkde script, and the error won't return.


for d in /tmp/.{{X11,ICE,font}-unix,X11-pipe}; do
        mkdir -p $d
        chown root.root $d
        chmod a+rwxt $d

All times are GMT -5. The time now is 12:11 AM.