LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-08-2011, 09:23 PM   #1
mscole
Member
 
Registered: Nov 2004
Location: Florida
Distribution: Slackware 14.1
Posts: 119

Rep: Reputation: 23
KDE crashes in Slackware 13.37


I just installed Slackware 13.37 on an old IBM Netvista and when I try to start KDE it gets through most of the splash screen and then crashes with the following error messages:

Segmentation fault at address 0x4

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
kded4: Fatal IO error: client killed
xinit: connection to X server lost
kwin: Fatal IO error: client killed
kglobalaccel: Fatal IO error: client killed
klauncher: Exiting on signal 1
Hangup
Qt-subapplication: Fatal IO error: client killed
GOT SIGHUP
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
root@michael:~# kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.
Could not connect to D-Bus server: org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /tmp/dbus-8X3F6Kkbxc: Connection refused
startkde: Shutting down...
kdeinit4_wrapper: Warning: connect(/root/.kde/socket-michael/kdeinit4__0) failed: : No such file or directory
Error: Can not contact kdeinit4!
startkde: Running shutdown scripts...
xprop: unable to open display ':0'
xprop: unable to open display ':0'
startkde: Done.
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.

lspci shows I have an Nvidia chip: NV6 Vanta/Vanta LT rev 15
Other GUIs, such as Fluxbox, do not crash, so I think the problem may be with KDE, but I am at a loss. Has anyone seen or solved such a problem? I have not posted /var/log/Xorg.0.log because the KDE error message above seems more detailed.
Mike.
 
Old 06-08-2011, 09:58 PM   #2
colorpurple21859
LQ Veteran
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora ,Xubuntu, others
Posts: 5,770

Rep: Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118
Try using the 2.6.38 kernel from testing. The 2.6.37 kernel doesn't play well with some nvidia cards and kde.
 
Old 06-08-2011, 10:22 PM   #3
zoran119
Member
 
Registered: Dec 2007
Posts: 217

Rep: Reputation: 18
i had a similar situation a while back. removing .kde/ helped...
 
Old 06-08-2011, 10:40 PM   #4
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 224Reputation: 224Reputation: 224
Try this from http://slackware.osuosl.org/slackwar..._AND_HINTS.TXT
Quote:
Regardless of your chipset (though it seems more common with intel), if KDE
crashes on startup, try disabling the Composite extension (which will also
disable all of the fancy desktop effects). Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection
 
1 members found this post helpful.
Old 06-08-2011, 11:48 PM   #5
mscole
Member
 
Registered: Nov 2004
Location: Florida
Distribution: Slackware 14.1
Posts: 119

Original Poster
Rep: Reputation: 23
I tried the 2.6.38 kernel but that didn't work. Deleting .kde did not help.
 
Old 06-09-2011, 12:06 AM   #6
mscole
Member
 
Registered: Nov 2004
Location: Florida
Distribution: Slackware 14.1
Posts: 119

Original Poster
Rep: Reputation: 23
I disabled the Composite extension and now KDE works, but I wonder what features I have disabled. Mike.
 
Old 06-09-2011, 07:47 AM   #7
WhiteWolf1776
Member
 
Registered: Oct 2010
Location: Bowling Green, KY
Distribution: Slackware
Posts: 278

Rep: Reputation: 91
Is this an upgrade or a clean install. If it was an upgrade to 13.37 please give a brief walkthrough of your upgrade path, i.e. what did you do?
 
Old 06-09-2011, 09:34 AM   #8
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,217

Rep: Reputation: 214Reputation: 214Reputation: 214
Quote:
Originally Posted by mscole View Post
I disabled the Composite extension and now KDE works, but I wonder what features I have disabled. Mike.
You disabled the ability for your video card to use 3-D effects. It's safe to do so. I'm not sure why KDE enables desktop effects by default.
 
Old 06-09-2011, 10:13 AM   #9
mscole
Member
 
Registered: Nov 2004
Location: Florida
Distribution: Slackware 14.1
Posts: 119

Original Poster
Rep: Reputation: 23
Thanks to everyone for your replies. It was a clean install. Mike.
 
Old 06-09-2011, 11:07 AM   #10
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware = Main OpSys
Posts: 3,934

Rep: Reputation: 3738Reputation: 3738Reputation: 3738Reputation: 3738Reputation: 3738Reputation: 3738Reputation: 3738Reputation: 3738Reputation: 3738Reputation: 3738Reputation: 3738
Driver?

Greetz
IIRC the Vanta series of video chip is very old, like TNT2 or even TNT old. These do NOT use the latest nVidia drivers and are incapable of most if not all desktop effects since they are lucky if they even have 32MB of VRAM. My main box is getting a bit long in the tooth and my video card was a mid-level when I bought it, an 8800GT. For reference sake, it has over ten times 32MB VRAM. Most decent cards today have over 1G VRAM.

I realize that if this is a laptop that you can't do anything about the hardware. The only reason I bring it up is to stress how different more modern video cards are and how important it is to get the right driver. Actually, I didn't see where you posted what driver you are using. The FOSS driver may not support a card that old but I don't know that since I have used the proprietary nVidia drivers ever since they first became available for Linux. You might need to use the "VESA" driver to get into X even if just to help you locate the proper nVidia driver.

Hope this helps, but please post results and what current driver you use.
 
Old 09-19-2011, 11:00 PM   #11
Amun-Ra
LQ Newbie
 
Registered: Sep 2011
Posts: 2

Rep: Reputation: Disabled
Don't mean to revive this old thread but I wanted to say thank you to the poster who resolved this. Making the file to disable the composite extension worked! I'm still very new to Linux and installed this on my Vbox. So I'm happy to work KDE in.

Thanks again!
 
Old 09-19-2011, 11:17 PM   #12
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-Current
Posts: 6,460
Blog Entries: 15

Rep: Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040Reputation: 2040
All Legacy Nvidia cards, RIVA128 ~ GeForce3, are still supported by this driver from Nvidia if you are still curious about this (this driver still updated BTW):

32-bit: http://www.nvidia.com/object/linux-d...15-driver.html

64-bit: http://www.nvidia.com/object/linux-d...15-driver.html

I'm not completely certain this is necessary but you MAY want to blacklist nouveau from attempting to load.
 
1 members found this post helpful.
Old 09-19-2011, 11:30 PM   #13
Amun-Ra
LQ Newbie
 
Registered: Sep 2011
Posts: 2

Rep: Reputation: Disabled
Thanks for the reply. Although I don't think that'll work with my VirtualBox graphics driver, it's good to know. It's weird. It's only allowing 800x600 (I believe this is clearly because of a generic driver being loaded). So I'll troubleshoot that. Should I have any issues, I'll be researching this forum. Glad I joined!
 
Old 10-16-2011, 12:05 PM   #14
xrlt
LQ Newbie
 
Registered: Oct 2011
Posts: 2

Rep: Reputation: Disabled
Sorry to be an absolute newb, but this is my first time attempting Linux, and I've had the exact same problem as described above.

How, exactly, do you:
Place the following content in
a file at /etc/X11/xorg.conf.d/disable-composite.conf:
Section "Extensions"
Option "Composite" "Disable"
EndSection

I can seemingly create the .conf, and type out the Section "Extensions" etc, but then I can't save the .conf or close it or anything and I'm stuck. >
 
Old 10-16-2011, 12:22 PM   #15
Cultist
Member
 
Registered: Feb 2010
Location: Georgia
Distribution: Slackware64 14.2
Posts: 779

Rep: Reputation: 107Reputation: 107
1. open a terminal (command line thing)

2. type in
Code:
su
and enter your root password

3. type
Code:
nano /etc/X11/xorg.conf.d/disable-composite.conf
4. enter that information

5. hit ctrl+x and choose yes to save


I just checked though, this file doesn't exist by default. You'll be creating a new file by doing this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 13.37 KDE crashes when watching video full screen with Firefox 4 mjbudd77 Linux - Software 1 07-04-2011 06:05 PM
Slackware 13.37 64bit vmware install crashes kde jocef Slackware 10 05-15-2011 03:32 PM
KDE 4 in slackware 13 isn't stable. Random Crashes akschu Slackware 2 09-06-2009 03:24 AM
KDE desktop crashes on mepis over slackware JoeFisher57 Linux - Software 5 08-27-2006 09:10 PM
Crashes on Slackware 10 after upgrading to KDE 3.3 ambayah Slackware 9 08-31-2004 02:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration