-   Slackware (
-   -   KDE crashes after splash screen, screen goes black (

juju 02-22-2013 12:50 AM

KDE crashes after splash screen, screen goes black
Greetings. I'm not a newbie, but haven't worked on Slackware in some time. I successfully installed Slackware 14 today. I booted and logged in as root. I entered startx and the KDE "splash screen" appeared. It goes through the 4 machine-type icons and just before it shows the desktop, the screen goes black, except for the mouse pointer.

I've tried using ctrl-alt-backspace and then hitting startx again, but I get the same result. I tried switching to Xfce and it seems to work fine.

I'm using an nVidia GeForce FX 5200. Not sure if this matters, but according to lsci, I'm using the 'nouveau' kernel driver.

01micko 02-22-2013 01:06 AM

fx5200 cards don't play nice with nouveau. You could try this as root:


echo 'options nouveau noaccel=1' > /etc/modprobe.d/nouveau.conf
and reboot. This disables acceleration for nouveau.

But, I don't think that would help much with KDE as it would need graphics acceleration. You will likely need the proprietary nvidia-legacy driver (173).

I could only see a SlackBuild for this for 13.37. Anyone see one for 14.0?

juju 02-22-2013 03:07 PM

So, it seems I've found a solution. I went to nVidia to get the driver. I got the right one for my video card, after making some selections on this page:

nVidia is fairly helpful. They have a page with simple install instructions. I followed them and launched the installer. It returned an error saying there was a conflict with the nouveau kernel driver. It said I had to remove this driver and then try to install.

I've no experience removing such drivers, so I did a search and found this most helpful page on the O'Reilly site:

I followed the instructions, for Slackware, on this page and now I'm able to to run KDE.

Many thanks...

Bazzaah 02-22-2013 03:33 PM

Here's some more info on the Nvidia drivers.

All times are GMT -5. The time now is 11:42 AM.