-   Slackware (
-   -   KDE 4.8.1 Wicd configuration and 'unnamed' bug (

Electromaniac 03-11-2012 10:11 AM

KDE 4.8.1 Wicd configuration and 'unnamed' bug
I have installed AlienBOB's KDE 4.8.1 packages on laptop Sony Vaio PCG-K35 with 512 MB RAM. It works very fast. Only problem is setting a wireless connection and unnamed bug, where instead of Desktop stands 'unnamed'. Wlan is recognized and led is on. When I go to wicd options, Wireless is grayed out. I can select wlan0 for wireless and eth0 and then after applying and opening wicd configuration again, interfaces are deselected. I also added wicd to tray. Applet says that wicd daemon is not running. What should I do? Maybe try networkmanager from testing folder? I use WEP encryption to connect to home network, so wpa_supplicant is not a problem.
Second problem is that instead of Desktop in upper right corner there is a button unnamed. It acts ok, I can add widgets, panels etc. But it is annoying. How to fix it?
About wlan adapter: I think it is Atheros card, it is integrated in laptop. I tried Ubuntu, it worked out of box, also for other distros, so I think that additional drivers are not needed.
Thanks in advance.

cwizardone 03-11-2012 10:26 AM

Try NetworkManager. I can't give you specifics, but I did recently try them both, going back and forth between the two, over a couple of days, and NetworkManager just does a better job. It sees more networks in the area and has less trouble making the connection. There have been times when Wicd reported there are no networks available, including the one I use, and I know for a fact that just wasn't true. At any given time there are 15 to 20 or more networks up and running 24 hours a day in my immediate area.

repo 03-11-2012 10:43 AM


Applet says that wicd daemon is not running. What should I do?
Start wicd daemon?

But it is annoying. How to fix it?
What is annoying?
What do you want to fix?

Kind regards

zasavage 03-11-2012 12:01 PM

you have to make rc.wicd executable
chmod +x rc.wicd ( in /etc/rc.d/ )
Sorry typing from my phone

Electromaniac 03-11-2012 12:03 PM

@repo where it should be located? I found rc.networkmanager in rc.d but there is no file named wicd.
Annoying is my second problem. Default activity Desktop is titled as unnamed, so I want to rename this. I solved a problem by creating an empty activity.

repo 03-11-2012 12:09 PM

It should be in etc/rc.d/
How did you install wicd?
Did it worked before?

Kind regards

Buumi 03-11-2012 02:02 PM

That might be a silly question but did you actually install Wicd?
Alienbob's KDE 4.8.1 has an applet for controlling Wicd but you need to install Wicd first from Slackware's /extra directory.

Electromaniac 03-11-2012 05:06 PM

Thanks for reply. I played around a little and added rc.networkmanager to rc.local. Now I have everything set up. Wicd was freezing and then it kills my wireless radio until I restart. Also networkmanager finds networks excellent, better works than wicd. Thanks everyone for replies.

All times are GMT -5. The time now is 04:44 PM.