LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   KDE 4.5.3 / X Server / Nvidia Card Issue (High CPU load of X) (https://www.linuxquestions.org/questions/slackware-14/kde-4-5-3-x-server-nvidia-card-issue-high-cpu-load-of-x-847594/)

Jack128 11-30-2010 11:31 PM

KDE 4.5.3 / X Server / Nvidia Card Issue (High CPU load of X)
 
Hello,
I've a problem since a couple of weeks.
After working on my machine, with firefox
or gimp etc, or just idle for a few hours
the X process is taking about 25% CPU usage.
But only this process (X). I enabled/disabled
Desktop Effects, used nvidia-proprietary and
the open nouveau driver. No difference.

If I go to Xfce4, with the same X config, all
is snappy and after working/idling it runs fast
as on startup.

My System:
Slackware64-Current
Kernel 2.6.37-rc3 (With ~200 Line patch)
Multilib is installed
KDE 4.5.3 from alien

8,8Ghz AMD Quad Core
6GB RAM
7600GS Nvidia

Thanks for any kind of help. =)
Regards, Jack.
Cheers

ponce 12-01-2010 12:24 AM

does it behaves the same with the standard 2.6.35.7 kernel of -current?

Ramurd 12-01-2010 03:02 AM

I experienced something akin and as far as I could determine something's wrong with the screensaver, causing quite big load on the system (also claimed pretty much memory at that) Could that be the case?

SavoTU 12-01-2010 03:11 AM

I have the same issue and no screensaver and stock kernel.

Jack128 12-01-2010 08:15 AM

Jep, on stock kernel the same and I disabled screensaver.

Regards, Jack.
Cheers

Laurens73 12-01-2010 08:23 AM

Some versions of KDE 4 also have a memory leak causing the system to become slow and overloaded. This has to do with a bug in the nepomuk server if it is the same case in your machine. Check the memory / cpu use with KSysguard to ensure wich application is causing the overload.

Sometimes it helps switching your login session manager to login with an empty session (right-click on the logout button applet >> configure session manager) and if this works after re-login, and if you wish to startup some apps, switch the session manager to manual saved sessions and save the session (button is in the classic KDE menu).

majoraccent 12-01-2010 08:48 AM

I get the same problem from time to time on my laptop using a Quadro. I had no problems when I was running the old kde 3.5 packages, but any version of 4.5 I've tried gives me these sporadic cpu spikes that cause the entire system to lag. The most interesting thing is that when this problem shows up, there are web pages in firefox that will trigger the spike, but only when visible on-screen (as in switching to another tab will hide the problem). Scrolling through a document in openoffice (or libreoffice) will cause the same cpu spike. The CPU spike is always in the X process, not in whatever application is triggering the issue.

Similar thread on nvnews: http://www.nvnews.net/vbulletin/showthread.php?t=156757

I've tried disabling kwin effects, but then I get tons of rendering artifacts and weird behavior. The best settings I've found so far:

Desktop Effects settings -> Advanced Tab ->
Compositing Type: OpenGL
Disable functionality checks: off
OpenGL mode: Shared Memory
Texture Filter: Nearest (fastest)
Enable Direct rendering: on
Use Vsync: off

I don't get the outright cpu spikes now, but still occasionally get kwin lags of a half second or so when switching windows (but usually ok).

OFF TOPIC: for all the people asking what kde 4 is missing compared to 3.5... it completely lacks any sense of robustness. Kwin, the window manager, can't manage windows unless you have the same hardware and eye-candy setup as the devs. I CAN'T get it to "just work" with any combination of settings. 4.5 has gotten to the point where it's usually usable enough, but I'm hoping that 4.6 or 4.7 will finally reach a "great" level of usability (although all the talk about new OpenGL rendering makes me wonder if there has been any effort on non-eyecandy rendering...)


All times are GMT -5. The time now is 05:23 PM.