-   Slackware (
-   -   kde 4.2 from -current plasma crash (

hemp4fuel 03-15-2009 10:30 AM

kde 4.2 from -current plasma crash
I tried to check out the new kde 4.2 in -current but when I try to login it starts to load then the screen goes black and a box pops up that says "A Fatal Error Occurred The application Plasma Workspace(plasma) crashed and caused the signal 11 (SIGSEGV)." It goes on to say it is unable to create a valid backtrace because debugging isn't built into the package.

When this happened after an upgrade I decided to try starting it as a new user in case something in my ~/ was messing it up. I got the same results. I then decided to do a fresh install of -current to see if there was just something with my particular install that was causing it. I still get the same result.

I haven't seen any other reports of such a problem. Does anybody have any tips on how I might get this to work, or on steps to take to debug it.


Didier Spaier 03-15-2009 11:34 AM

I don't have this problem (fresh -current in a VM is Slackware 12.2). Anything interesting in /var/log/messages ? /var/log/Xorg.0.log ? find ~/.kde -name "*log" ?

I would try reinstall all kde packages, just in case.

hemp4fuel 03-15-2009 11:50 AM

There is nothing interesting in /var/log/Xorg.0.log but in /var/log/messages there is a lot of:


Mar 15 10:58:01 pod1 dbus-daemon: Rejected send message, 1 matched rules; type="method_call", sender=":1.12" (uid=1000 pid=3336 comm="kdeinit4: kio_trash [kdeinit] trash local:/tmp/kso") interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply=0 destination="org.freedesktop.Hal" (uid=0 pid=2794 comm="/usr/sbin/hald --daemon=yes "))
I don't know if that is related.

grissiom 03-15-2009 06:06 PM

Maybe you should make sure to have all your configuration files up-to-date. Run "slackpkg new-config" will do all the tricks for you. If it does not work, try "rm -rf ~/.kde" and start up kde again, maybe you would like to backup ~/.kde/share/config/plasma-applets.

hemp4fuel 03-15-2009 06:14 PM

Thanks for the tips, I did a fresh install of the latest -current so all my conf files should be good. I have tried removing ~/.kde for my normal user as well as with a new user with a blank ~/ and still get the same results. I tried re-installing all the kde packages from a different mirror and that didn't work either. It really has me scratching my head. I am going to try it on another computer and see what kind of results I get there.

disturbed1 03-15-2009 11:18 PM

Which video card and Xorg driver are you using? If your card has issues with 3d rendering this can cause issues with Plasma. I had issues starting KDE 4 in Virtual Box until I installed the VBox video driver from guest additions.

neeza 03-15-2009 11:53 PM

try to install -current in directory l/, i try this and solved

hemp4fuel 03-16-2009 12:07 AM

My card is an ATI HD3850 with fglrx, I also tried radeonhd with the same results. I haven't had any trouble out of the card otherwise. I am not sure what is meant by installing -current in directory l/. Thanks again for everyone's help.

tomcik 03-17-2009 03:03 AM

I have a similar problem. I upgraded my Slackware to the current version and I encountered problems with dbus as well. In my case dbus can't connect to dbus-server. I received message:

Could not connect to D-Bus server: org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /tmp/dbus-ZsYjdqRJIg: Connection refuse.

When I try to start dbus manually I can reproduce this error:

First I start dbus-launcher:

eval `dbus-launch --sh-syntax --exit-with-session`

Then I try to invoke qdbus command and I'm receiving the same error: Could not connect to D-Bus server...

Does anyone know what can be wrong with dbus? I upgraded all packages from all directories in slackware-current.

Thanks for help in advance...

Franklin 03-18-2009 07:44 PM

Hi - running a fresh install (today) of -current on a Dell E1505 with a Radeon X1400 video card. I'm using radeonhd and an xorg.conf created by xorgsetup.

Things seem to be running smooth now, but I did have some d-bus related issues at first. I don't know how you are starting KDE, but I found that running as a non-root user and starting from KDM (as opposed to issuing a startx command from the CLI) seemed to clear up the d-bus related errors. These were not the same errors you're seeing, but still d-bus errors.

Reminded me of how freerock gnome would behave if you didn't start it from GDM - error messages about d-bus/messagebus and no icons on the desktop.

Totally guessing of course.


mbvo 03-18-2009 08:42 PM

I got the same error when i downloaded from slackware-current on its running fine now that i redownloaded everything from

hemp4fuel 03-19-2009 09:26 AM

Thanks for the tips. I tried starting from KDM and it did get further along before it crashed, but it crashed just the same. I did try installing the kde packages from a different mirror than I originally got them from but I got the same results. I talked with someone else with the same issue as me after upgrading to -current, so I believe there to be a problem with certain setups.

davidsrsb 03-30-2009 07:21 AM

I have the same plasma signal 11 with no backtrace. My machine has VIA Chrome on board graphics

davidsrsb 04-02-2009 07:33 AM

I managed to get the following from messages:
Apr 2 20:22:01 slackbox kernel: agpgart-via 0000:00:00.0: AGP 3.5 bridge
Apr 2 20:22:01 slackbox kernel: agpgart-via 0000:00:00.0: bridge is in legacy mode, falling back to 2.x
Apr 2 20:22:01 slackbox kernel: agpgart-via 0000:00:00.0: putting AGP V2 device into 4x mode
Apr 2 20:22:01 slackbox kernel: pci 0000:01:00.0: putting AGP V2 device into 4x mode
Apr 2 20:22:24 slackbox kernel: plasma[8886]: segfault at 18 ip a9dc64c4 sp a9975840 error 6 in[a9db8000+23000]

davidsrsb 04-09-2009 07:44 AM

Still breaks in the same way with KDE4.2.2 updates

All times are GMT -5. The time now is 12:59 PM.