LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-09-2007, 05:29 PM   #16
cwizardone
LQ Veteran
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 6,483

Original Poster
Blog Entries: 1

Rep: Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820

Quote:
Originally Posted by BCarey View Post
Mine just shows the Title, not the Chapters.
So when you click on the DVD icon (copy), does it prompt you for a location/filename?
Brian
Yes, it does, so I enter a name and hit the enter key and then another box tops up that would indicate it has started the process, but it doesn't do anything from there.
Thx.
 
Old 10-09-2007, 05:40 PM   #17
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,639

Rep: Reputation: Disabled
did you try the mplayer command I suggested?

Brian
 
Old 10-09-2007, 06:13 PM   #18
cwizardone
LQ Veteran
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 6,483

Original Poster
Blog Entries: 1

Rep: Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820
Quote:
Originally Posted by BCarey View Post
did you try the mplayer command I suggested? Brian
Yes, it is running now in the background. Here is the message it issued before starting to play the video:
*****************8
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 3.00GHz (Family: 15, Model: 4, Stepping: 9)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

Playing dvd://1.
There are 1 titles on this DVD.
There are 20 chapters in this DVD title.
There are 1 angles in this DVD title.
audio stream: 0 format: mpeg1 (stereo) language: unknown aid: 0.
number of audio channels on disk: 1.
number of subtitles on disk: 0
MPEG-PS file format detected.
VIDEO: MPEG2 720x576 (aspect 2) 25.000 fps 8000.0 kbps (1000.0 kbyte/s)
It seems there is no Xvideo support for your video card available.
Run 'xvinfo' to verify its Xv support and read DOCS/HTML/en/video.html#xv!
See 'mplayer -vo help' for other (non-xv) video out drivers. Try -vo x11
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [x11] 720x576 => 768x576 Planar YV12
SwScaler: using unscaled yuv420p -> rgb32 special converter
*************
Maybe I should use the generic radeon driver afterall?

For -chapter, I put 16 17 18, but it copied everything from and including 16, to the end of the disk. What format should I use to make sure it only copies the chapters I want it to copy?
Many Thanks.

Last edited by cwizardone; 10-09-2007 at 06:46 PM.
 
Old 10-09-2007, 09:07 PM   #19
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,639

Rep: Reputation: Disabled
try -chapter 16-18
 
Old 10-09-2007, 09:29 PM   #20
cwizardone
LQ Veteran
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 6,483

Original Poster
Blog Entries: 1

Rep: Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820Reputation: 3820
Quote:
Originally Posted by BCarey View Post
try -chapter 16-18
Yes, thank you, I found it in the Mplayer docs.
MPlayer ripped the chapters very quickly. It was so fast I didn't believe it until I played the file.
I un-installed the ATi proprietary driver and went back to the xorg generic radeon driver and all the error messages that popped up when starting mplayer, as you suggested, went away.
Thanks for all your help.
 
Old 10-11-2007, 12:30 PM   #21
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,639

Rep: Reputation: Disabled
Great, I'm glad you've got a solution. I still wonder why your k9copy doesn't work. (The only thing I use it for is to easily shrink double-layer dvds to single-layer.)

mplayer/mencoder is a truly awesome program, and can do just about anything audio/video related.

Brian
 
Old 07-28-2009, 05:51 PM   #22
linuxpokernut
Member
 
Registered: Jul 2007
Distribution: Slackware 14
Posts: 237
Blog Entries: 8

Rep: Reputation: 59
Code:
[Thread debugging using libthread_db enabled]
[New Thread 0xb58d3730 (LWP 28899)]
[KCrash handler]
#5  0x00000000 in ?? ()
#6  0x080af8a9 in k9DVDRead::openDevice ()
#7  0x080a7655 in k9DVD::scandvd ()
#8  0x0806c5c5 in k9Main::Open (this=0x88eb0e0) at k9main.cpp:527
#9  0x08086051 in k9Copy::qt_invoke (this=0x8890090, _id=158, _o=0xbfd6ad54)
    at k9copy.moc.cpp:120
#10 0xb7150a7d in QObject::activate_signal ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#11 0xb71515fd in QObject::activate_signal ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#12 0xb799e149 in KAction::activated () from /usr/lib/libkdeui.so.4
#13 0xb799e1a2 in KAction::slotActivated () from /usr/lib/libkdeui.so.4
#14 0xb79a0f7d in KAction::slotPopupActivated () from /usr/lib/libkdeui.so.4
#15 0xb79a1263 in KAction::qt_invoke () from /usr/lib/libkdeui.so.4
#16 0xb7150a7d in QObject::activate_signal ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#17 0xb745cfae in QSignal::signal () from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#18 0xb716c3d7 in QSignal::activate ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#19 0xb7252c2a in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#20 0xb798e152 in KPopupMenu::mouseReleaseEvent () from /usr/lib/libkdeui.so.4
#21 0xb71875c4 in QWidget::event () from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#22 0xb70f315a in QApplication::internalNotify ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#23 0xb70f3e7a in QApplication::notify ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#24 0xb7706672 in KApplication::notify () from /usr/lib/libkdecore.so.4
#25 0xb70958c8 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#26 0xb7093c23 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#27 0xb70a425d in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#28 0xb7109720 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#29 0xb71095b6 in QEventLoop::exec () from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#30 0xb70f2bbf in QApplication::exec ()
   from /usr/lib/qt-3.3.8b/lib/libqt-mt.so.3
#31 0x08060646 in main (argc=) at main.cpp:164
I've tried several versions including slackbuilds and souorce, and they all give me this error when I try to open a DVD.
 
Old 07-29-2009, 12:38 AM   #23
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,044

Rep: Reputation: Disabled
have you tried alienbob version? (the version linked is for slack 12.2)
just launched now succesfully alienbob's slackware 64 version.
 
Old 07-30-2009, 03:53 PM   #24
linuxpokernut
Member
 
Registered: Jul 2007
Distribution: Slackware 14
Posts: 237
Blog Entries: 8

Rep: Reputation: 59
There are 3 files in that link, one of them looks like dependencies? but only one has a package extension, do i just install the one file? a bit confused, thanks.
 
Old 07-30-2009, 04:45 PM   #25
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Arch, Gentoo
Posts: 6,939

Rep: Reputation: 129Reputation: 129
There are 6 files in that link.
Code:
k9copy-1.2.4-i486-1alien.dep
k9copy-1.2.4-i486-1alien.meta
k9copy-1.2.4-i486-1alien.tgz
k9copy-1.2.4-i486-1alien.tgz.asc
k9copy-1.2.4-i486-1alien.tgz.md5
k9copy-1.2.4-i486-1alien.txt
k9copy-1.2.4-i486-1alien.dep tells you k9copy's dependencies:
Code:
dvdauthor
ffmpeg
MPlayer
You can also get them from Alien Bob's repository.

k9copy-1.2.4-i486-1alien.meta is the meta data -- it tells you other
information about k9copy and Alien Bob's package of it.

k9copy-1.2.4-i486-1alien.tgz is the Slackware package that you install.

k9copy-1.2.4-i486-1alien.tgz.asc is the GnuPG signed key file for k9copy,
with which one can verify the signature of k9copy-1.2.4-i486-1alien.tgz.

k9copy-1.2.4-i486-1alien.tgz.md5 is the md5sum of k9copy-1.2.4-i486-1alien.tgz,
with which one can verify the md5sum of the package.

k9copy-1.2.4-i486-1alien.txt is the text file with information about the
package from it's slack-desc file.

To install the Slackware package open a terminal, su to root, and issue:
Code:
installpkg k9copy-1.2.4-i486-1alien.tgz
Download and do the same for those three dependencies, also reading to
see if they have dependencies.
 
Old 08-03-2009, 07:10 PM   #26
linuxpokernut
Member
 
Registered: Jul 2007
Distribution: Slackware 14
Posts: 237
Blog Entries: 8

Rep: Reputation: 59
Thank you so much, it worked. I had already downloaded the dependencies when I was installing DeVeDe. All I had to do was install the package and it worked.
 
  


Reply

Tags
k9copy


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
K9copy help ElJollyRancher Linux - Software 3 07-18-2006 08:13 AM
k9copy thebiggiantmouse Linux - Software 8 07-16-2006 05:20 PM
k9copy & too big output iso: how to solve that? albatros_la Linux - Software 0 02-06-2006 06:12 AM
AOL UK && BT Voyager 100 && Slackware 10.2 && RP-PPPoE pitt0071 Linux - Networking 3 01-17-2006 06:10 AM
(FreeBSD && Fedora Core 4 && Slackware 10.0) Filesystem Support taylor_venable *BSD 1 07-14-2005 02:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration