LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   K8VSE Deluxe - No Sound - No USB Storage (https://www.linuxquestions.org/questions/slackware-14/k8vse-deluxe-no-sound-no-usb-storage-206905/)

mijenks 07-19-2004 09:26 AM

K8VSE Deluxe - No Sound - No USB Storage
 
Freshly built system (my first one, and it worked!):

Asus K8VSE Deluxe - no update
Athlon64 3200+
Onboard Sound
Slack 9.1 (also tried Knoppix 3.3)

1.
Sound works in Windows, with the included ASUS drivers.
alsaconf recognized onboard sound, found a driver.
alsamixer settings are OK.
lsmod shows sound modules loaded.
xine shows CD playing (cd-rom connected directly to mobo).

2.
USB memory stick (Sandisk Cruzer Mini 128 MB)
USB support/controllers enabled/loaded
usb-storage module loaded
/etc/fstab:
/dev/sda1 /mnt/usb vfat noauto,user,rw

'mount /dev/sda1' returns 'sda1 is not a valid block device'
above setup worked on laptop with Slack 9.1

Box is at home, no internet connection, I'm at work. Thanks for the help.

netmask 07-19-2004 11:08 AM

For your sound problem.. if you say all the necessary channels are unmuted in alsamixer, try rm /etc/asound.state and re-configuring with alsamixer.

I had the same problem : everything was loaded, channels unmuted and xmms "playing" music without sound.

As for your USB, you could check if it is really detected: unplug your usb stick, run tail -f /var/log/messages and plug your usb stick. If it gets detected, you should see a message appear on your screen with the device name and other information

mijenks 07-19-2004 12:53 PM

i'll try rm the file, reconfig it.

i have tailed varlogmessages - only line of interest is that usb-storage is not found. however i know it is loaded. lsmod has it loaded plus i do a modprobe usb-storage no prob. i'll keep working on it.

here is the plan: i have 2.6.7 bz2 on the usb stick. i'll save the file to the windows partition, mount the windows partition (wait . . . does 2.4.22 have support for ntfs reads?) and save the file to the slack partition, then make the new kernel. i was running the 2.6.7 kernel on my laptop and it worked really well, until i somehow nuked my /boot. oh well. live, learn.

mijenks 07-20-2004 11:22 AM

No luck on asound.state.

I think I will have to do a reinstall of Slack. The first time I ran alsaconf, my onboard sound was detected. When I ran it again a few days later, no such luck. Maybe because ALSA is running already? For some reason, on boot, the module snd-82xx or whatever it is cannot be found. Maybe I'll try a Gentoo install. The compiles are supposed to be pretty fast on the 64.

mijenks 07-21-2004 10:40 AM

Half a solution
 
Hopefully found a solution:

VIA produces a tar.gz audio driver for linux systems on their site: www.viaarena.com.

I just got it at work today, and I'll try it when I go home.

Still no luck with USB, though. When I insert the USB drive, /var/log/messages recognizes it just fine and assigns it sda1. However, one of the last messages is for the modprobe of usb-storage, where it then reports that usb-storage was not found. This is strange, because I know I have usb-storage compiled as a module, and I can even modprobe it myself. Huh? Anyways, when I try to mount, I get an error (can't remember exactly what it says). If I try to mount again, I get "sda1 is not a valid block device" which I think I've gotten before. I'll work on it again tonight.

mijenks 07-22-2004 09:27 AM

Slackware USB Solution
 
Go to tldp.org, and find the USB How-To. Apparently 2.4.22 and above (what ships with Slack 9.1) have NTFS read support (DON'T WRITE!!), so I was able to save the 2.6.7 bz2 to Windows and mount Windows HDD under Slack. Compiled the kernel with all the USB support/modules required (as in the tldp How-To). USB worked.

As regards the sound problems, the VIA audio driver modules are in src.rpm format, which is totally crappy. There is a lot of information on the VIA chipsets on www.alsa-project.org, so that is worth a look. I have seen many solutions listed on the forum for the VIA chipsets.

If worse comes to worse, I may just install the SoundBlaster Live card that I bought. Though I have been holding out, since the K8VSE Deluxe onboard is pretty decent, with 6 channel support.

One final note: as I said before, I don't have internet at home, so I have to transfer stuff via USB drive from work comp to home comp. Slack 9.1 ships with alsa-utils-0.9.1 and Slack current is alsa-utils-1.0 or something higher. The newer ALSA package may have support for the newer VIA chipsets.

Hopefully this will help resolve some others' problems.

mijenks 07-26-2004 11:09 AM

SOUND PROBLEM SOLVED
 
If you are using the K8VSE Deluxe Mobo with VIA VT8237 southbridge, this post is for you.

Here's how I did it:

Get a recent kernel (I used 2.6.7)
Compile sound support directly into the kernel (soundcore module may work, too).
Compile VIA support as a module (snd-via82xx)
I did NOT compile OSS support
Load your new kernel
Modprobe snd-via82xx (I believe hotplugging loads all necessary sound modules for snd-via82xx)
Unmute any necessary channels in alsamixer
Chmod /dev/cdrom and /dev/hdc (or whatever your /dev is)

If you don't want to modprobe and alsamixer every time, set your mixer settings the way you like them, type 'alsactl store' then put the following commands in your sound startup script:

modprobe snd-via82xx
alsactl restore

Be sure that you put those commands outside of any if-checks, so you will be sure that they are executed. It worked for me with this setup:

ASUS K8VSE Deluxe Mobo (VIA VT8237 southbridge)
Slackware 9.1
Kernel 2.6.7
Speaker wire plugged into Line-OUT (didn't have the mix-up that others did).

Hope this helps some folks!!


All times are GMT -5. The time now is 02:10 PM.