-   Slackware (
-   -   k3b and bluray burning (

enine 01-04-2012 06:44 PM

k3b and bluray burning
Tried to burn my first bluray today and k3b will let me add files but then keeps telling me to insert empty or appendable medium. I've burned dvd's fine with the same drive so I know my drive works.
The diskinfo in k3b says its an empty BD-R so it looks like it should work.
I thought maybe a root folder limit so I made a new folder and put everything in it but no go.

em21701 01-05-2012 11:17 AM

I've never been able to make anything but frisbess with k3b. I use cdrecord from the command line.

salemboot 01-08-2012 01:34 PM

Try getting the latest version. Maybe their beta.
Not to deter you but Nero would probably be a better idea.

from their website:
Nero Linux 4 is the only application to offer blue laser data burning support, including support for Blu-ray Disc.

They usually give you 30 days or so.

Carl.Spackler 01-20-2012 07:34 PM

I had the same problem. Downloaded Nero Linux and problem solved. Works very well. Only $20 to buy after the trial is up.

Thanks salemboot.

cwizardone 01-21-2012 07:18 PM

From the K3b Handbook:


Chapter 1. Introduction

If you have used a burning program such as Nero under Windows, K3b will feel
quite familiar.

Featuring a simple, yet powerful graphical interface, K3b provides various options
for burning a CD, DVD, or BD (Blu-ray disc). Various types of optical projects are
supported including (but not limited to) audio and data, video projects for DVD and
VCD, as well as multi-session and mixed-mode discs. K3b also has the ability to
erase re-writeable media and can perform more complicated tasks such as
audiovisual encoding and decoding.

enine 01-23-2012 08:09 PM

Slack came with the latest 2.0.2 and it sees the drive and blank BDR but then asks for an empty medium when it comes time to write.

MartinOC 01-29-2014 01:39 PM

I haven't used Slack in years but use other distros.

In Fedora k3b will write to blue-ray as a user if you reset the blank disk permission after insertion. For example:
sudo chmod -R 777 /dev/sr0

Mint and Ubuntu have similar work arounds for setting the right permissions for a user level burner to see a writeabe blank disk in k3b.


For a better work around. It is posted on an Ubuntu board but it worked on Fedora and should work on Slack.

The essence of the problem is cdrecord used by many open source burner programs under the hood was forked and the version distributed with most Distros has imperfect support for Blu-Ray. The thread presents a number of ways around this by obtaining or compiling the working version from source. I choose the latter solution and have much improved Blu-Ray support.

Jeebizz 01-29-2014 07:45 PM

There is another solution, install wine and download ImgBurn - freewware. I have used it and works just fine :)

JamesGT 01-29-2014 09:48 PM

This is what I do to burn BD-R. All command line.


dd if=/dev/zero of=file.iso bs=1M count=18900
mkudffs --vid=BDRTITLE file.iso
mkdir /mnt/loop
mount -o loop -t udf file.iso /mnt/loop
cp files_to_burn /mnt/loop
umount /mnt/loop
growisofs -speed 4 -Z /dev/dvd=file.iso

This works well for files over 4gb.

ReaperX7 01-29-2014 10:04 PM

Xfburn works fairly well. Not sure, but I think Robby has a build up in his repository.

K3b doesn't work all that well. I know it has a few problems with things like dual-layer disks.

willysr 01-29-2014 11:29 PM

never tested with dual layer dvds, but CD/DVD burning/copying works well here

irgunII 01-29-2014 11:58 PM

Burning anything on my Slackware 14.0 k3b works just fine...well, except that even though I have the settings at 2GB for manual burning, when I burn to BD-R usually at about 25% burned/full it's going at its best at ~35MB/second but suddenly starts to drain of the RAM until it gets to zero and starts to use the hardware RAM. Sometimes at around 70%-75% it will come back up and be fast again, most times it doesn't. It's still 'fast', but not as fast as when it's not using the hardware RAM (hopefully that all made sense).

All-in-all I can burn a BD-R of 23GB in about 20 minutes. All the other mediums work fine and have no problem with the drain of RAM (but don't burn anywhere near as fast as a BD-R either!).

JamesGT 01-31-2014 08:08 PM

I had good luck with k3b with Slackware64 13.0, 13.1 I had issues, 13.37 I had issues and with 14 I never tried. I just continued to burn BD-Rs, DVD-Rs with the command line, it's always worked.

pchristy 02-01-2014 12:26 PM

Not had any problems burning BD-R disks here, either under 13.37 or 14.0 (not upgraded to 14.1 yet). Have you set up K3b correctly? Let it reset the permissions for the other software it invokes. Since its only a front end for cdrecord et al, it shouldn't be any different from using the command line.

I currently have two BD capable drives - an LG in my main (Slackware) machine, and a Pioneer in another machine running Mageia 3. K3B burns anything fine in both. The only thing it doesn't seem to want to do is erase BD-RW disks. I don't know why.


All times are GMT -5. The time now is 07:10 AM.