-   Slackware (
-   -   Just reinstalled Slackware 11...sound doesn't work in KDE (

spaceballs 03-26-2007 11:23 PM

Just reinstalled Slackware 11...sound doesn't work in KDE
I just reinstalled Slackware 11. I had a problem earlier, and I just decided this was the best way to fix it. Now...I don't have sound. Amarok doesn't fire up, and it seems to lock up when I try and test the sound.

I am relatively unfamiliar with KDE. Can someone help me out?

EDIT: Sound works in GXine, and it worked from alsamixer and alsactl. So sound works. It just seems like amarok and none of the other media players want to work...

nadroj 03-26-2007 11:47 PM

ive never had the problem that your experiencing.

in amarok, go to Settings -> Configure Amarok -> Engine. play around with the 'Sound System' and the engine settings. or try playing with the Sound System settings in the KDE Control Center.

since sound works in other programs, it makes sense to guess that its a problem with amarok specifically, right?

hope it helps.

masonm 03-26-2007 11:50 PM

Did you put your user in the audio group?

spaceballs 03-26-2007 11:57 PM

When I try and run amarok I get the amarok banner, and then nothing... Then I try and run it from a term and I get this:

$ /opt/kde/bin/amarok
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.

None of the music players will start, and when I try and start the sound system from the control panel, it freezes up.

Right now, artsd is taking up 99.9% of my processor in top. Do I need to change the permissions on something?

Now, I had upgraded amarok on this same computer, before ruining something else and reinstalling from the vanilla 11 disk. Are there any configurations from amarok that I need to erase? Where are they?

spaceballs 03-26-2007 11:59 PM


Originally Posted by masonm
Did you put your user in the audio group?

I sure did...

$ groups
wheel floppy audio video cdrom users

nadroj 03-27-2007 12:05 AM

you said in your initial post that GXine sound works. later you said no music players will start. i know gxine is mostly for video, but it can play mp3s--are you able to do that?

spaceballs 03-27-2007 12:07 AM

OK...I got it figured out. There must have been some conflicting setting. I just searched for a folder named amarok in my .kde folder and deleted it. Problem solved!

H_TeXMeX_H 03-27-2007 12:23 AM

'.kde' is such a pain ... it causes so many problems ... what I would recommend is making cron or at delete it systematically ... you'll have a lot less problems :D

spaceballs 03-28-2007 08:46 PM

Another question...that I think is related. I keep getting this error message saying:

Error - artsmessage
Sound server fatal error:
cpu overload, aborting

Then, immediate afterwards, I get another message saying:

aRts had to restart!
How do I get rid of these? They come back even if I restart KDE. When I run top, I see that aRts is taking up something like 98% of my processor.

spaceballs 03-31-2007 06:41 PM

This is really slowing down my computer. Does anyone have any ideas on how to keep artsd from restarting?

All times are GMT -5. The time now is 02:48 AM.