LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Just installed ICEwm. It's WPA gui doesn't seem to be able to scan for available access points? (https://www.linuxquestions.org/questions/slackware-14/just-installed-icewm-its-wpa-gui-doesnt-seem-to-be-able-to-scan-for-available-access-points-4175656962/)

700 07-06-2019 07:08 AM

Just installed ICEwm. It's WPA gui doesn't seem to be able to scan for available access points?
 
Just installed ICEwm, and I couldn't establish an internet connection. I opened the WPA GUI client and told it to scan for available AP's but it turned up blank.
The status says it can't get a status from the wpa_supplicant.

I could connect to the internet in xfce. Am I using the wrong application to do configure these things?

philanc 07-06-2019 12:50 PM

I have been using IceWM for a long time. This is only a window manager --not an integrated desktop a la Xfce.

As far as I know, it only includes basic menu and panel functionality, with minimal cpu and net monitors. I don't think it includes any wireless connection manager.

If you run another network manager (what you call the WPA GUI client), I think it is a distinct application, and I don't see how IceWM would be involved.

What network manager do you use? maybe a knowledgeable user could help you with it.

business_kid 07-06-2019 12:54 PM

Are we using networkmanager? call that. Alternatively, in a terminal, try
Code:

sudo iwlist wlan0 scan

BW-userx 07-06-2019 07:01 PM

you can use this https://wiki.archlinux.org/index.php/IceWM and add networkmanager, nm-applet to a startup file, if they got a sys tray it should show up in there and you should be able to get your wifi/net connection.

I have not played with ICEwm in so long I forgot how it works.

700 07-08-2019 04:07 PM

Quote:

Originally Posted by business_kid (Post 6012567)
Are we using networkmanager? call that. Alternatively, in a terminal, try
Code:

sudo iwlist wlan0 scan

I opened xterm and input the command as you said but it kept telling me I got the password wrong. I tried my user password and my root password but neither worked. I know I entered them correctly, I've retried about 12 times now. any idea what's causing this?

edit: ok, re-logged in as root and tried it. It retured a ton of "IE:unknown:" 's and then gave me something called "Cell 12" followed by what looks like a MAC address? lists a channel of 1, a frequency, quality, encryption as on. Says the ESSID is "" and lists the bit rate and mode and the rest is pretty much gibberish to me.

I tried running NetworkManager in xterm but it just told me that it's already running.

Richard Cranium 07-08-2019 06:00 PM

Make sure network manager is turned on via the service /etc/rc.d/rc.networkmanager (you'll have to start that as root).

In an xterm, run the "nmtui" command, which will provide a menu driven interface .

BW-userx 07-08-2019 06:23 PM

I just installed it, opened a terminal.
Code:

nm-applet
got wifi make sure /etc/rc.d/rc.networkmanager is executable.

700 07-09-2019 10:07 AM

Quote:

Originally Posted by Richard Cranium (Post 6013227)
Make sure network manager is turned on via the service /etc/rc.d/rc.networkmanager (you'll have to start that as root).

In an xterm, run the "nmtui" command, which will provide a menu driven interface .

Ok, I've opened nmtui and under "edit connection", it only lists one connection, as opposed to the multiple it could detect in xfce. Now I tried selecting activate connection but it just gave me an empty list. It doesn't even list the only connection shown when I select "edit connection". How do i connect to it? and how do I scan for access points to see what connections I can connect to?

bassmadrigal 07-09-2019 07:11 PM

Quote:

Originally Posted by 700 (Post 6013205)
I opened xterm and input the command as you said but it kept telling me I got the password wrong. I tried my user password and my root password but neither worked. I know I entered them correctly, I've retried about 12 times now. any idea what's causing this?

This is because sudo isn't set up by default on Slackware (nor should it be). sudo is a way for you to run certain programs (or all programs, if desired) with elevated permissions without needing to switch to the root user. It is a security risk as that user will now have root access to those programs, and depending on what programs they're given access to, it may allow them to gain additional access or break something important. Also, if that user account is compromised, the attacker might have access to the system to do nefarious things. You can set sudo to either require the user's password or not require a password at all.

However, in at least the *buntu distros, sudo is setup by default for the main user as the primary way to run programs with elevated permissions, so many people will setup their users to be able to use sudo. The root user is not setup by default on this systems and so sudo is the only way to elevate permissions.

It's not wrong to set up your user to use sudo (and many do, including me), but if you do it, you should be aware of potential security implications.

As to your other issue with Network Manager, I would recommend resetting your networking and then select Network Manager to run your network. To reset everything, run netconfig as root and select loopback. This will reset everything back to defaults. Then run netconfig again and select Network Manager. You may need to reboot the system or manually start the Network Manager service to get it to run. You can manually start Network Manager by running the following:

Code:

/etc/rc.d/rc.networkmanager start
Then try nmtui on the console or nm-applet inside your DE/WM and see if it works.

BW-userx 07-09-2019 07:23 PM

yes, I installed it the other day as someone else? was having this very same issue.
as bassmadrigal said,
Code:

sudo chmod +x /etc/rc.d/rc.networkmanager
sudo /etc/rc.d/rc.networkmanager start (or restart)
#open a terminal, or use the one you already should have open then
#type:
nm-applet

Look down in your system tray, and you should see it.

bassmadrigal 07-09-2019 07:30 PM

Quote:

Originally Posted by BW-userx (Post 6013601)
yes, I installed it the other day as someone else? was having this very same issue.
as bassmadrigal said,
Code:

sudo chmod +x /etc/rc.d/rc.networkmanager
sudo /etc/rc.d/rc.networkmanager start (or restart)
#open a terminal, or use the one you already should have open then
#type:
nm-applet

Look down in your system tray, and you should see it.

This user does not have sudo set up, so your commands would fail on his system if he tries to run them as a normal user. OP should run su - before running chmod and rc.networkmanager (but they should exit the root shell before running nm-applet, since it wouldn't connect to the X session).

Also, just making Network Manager executable and starting it may still cause issues if the other network options are not reset using netconfig.

BW-userx 07-09-2019 09:38 PM

what do you mean he does not have sudo setup yet? what Kind of slack box is he running, :D - as well as su passwd then, and then exit and then run nm-applet , and I just seen your code block and that title, then remembered someone else (?) having this same issue, I don't remember the user OP name, but yeah, I didn't read everything you wrote before hand. so yeah, what you said. :D :hattip:

belay my last.

bassmadrigal 07-10-2019 12:49 AM

Quote:

Originally Posted by BW-userx (Post 6013628)
what do you mean he does not have sudo setup yet? what Kind of slack box is he running, :D

A stock one ;)

BW-userx 07-10-2019 06:59 AM

Sounds like he started turning the key before checking the oil.

Post Install
https://docs.slackware.com/slackware:beginners_guide

business_kid 07-10-2019 01:40 PM

He hasn't been in since post #8. Maybe we oughtn't to beat the guy up so much for a simple enough error.


All times are GMT -5. The time now is 02:00 AM.