-   Slackware (
-   -   java plugin, mozplugger and opera (

klee12 06-17-2013 05:45 PM

java plugin, mozplugger and opera

I just upgraded to Slackware 14.0 and find that my Chrome browser cannot open an important site because it says there is no java plugin. It doesn't work with Firefox either.

I tried to install the browser Opera, but I can't get the source from SlackBuild

I had tried to install mozplugger from Slackbuild, but I think there is something wrong with the source. It looks like it has been truncated.

I'm not that concerned about Opera and Slackbuild (though I think I would like to get them working), but would like to have the plugin. I've installed the jdk package from Slackbuild, and I thought the plugin came with it. I checked and Slackbuild says to the plugin is not installed by default. If I reinstall jdk, how do I install the plugin with the jdk package.

Thanks in advance for any help

cwizardone 06-17-2013 06:11 PM

Have you considered installing Alien BOB's OpenJDK package, along with the icetea-web plug-in?

neymac 06-17-2013 06:51 PM

The java plugins is just not enabled by default on the most recent version of the jdk.SlackBuild hosted on SBo. If you look in the actual jdk.SlackBuild, then you will see an option not mentioned in the README that allows the plugin to be installed. You can run the jdk.Slackbuild with the following optional parameter to get the plugin to work.
Try this, it worked for me:

# EXPLOIT_ME=YES ./jdk.SlackBuild

klee12 06-17-2013 10:34 PM

Thanks for all your replies.

I think I'll try to fiddle with EXPLOIT_ME variable. But, Neyac, does'nt a # mean what follows is a comment. Also, while it's a long time since I fooled with a makefile, I don't understand the

/.jdk.Sackbuild after the Yes.

Can I just put in


right before it is used?

Thanks in advance


Alien Bob 06-18-2013 02:53 AM

The command "EXPLOIT_ME=YES ./jdk.SlackBuild" is a single-line command to be executed as root. What it does is set the environment variable "EXPLOIT_ME" to "YES" just for the duration of this commandline, and then start the jdk.SlackBuild which will inherit this value for EXPLOIT_ME in its own environment.
This way you do not have to edit the jdk.SlackBuild to change the value for EXPLOIT_ME.


ruario 06-18-2013 03:53 AM

klee12: You can get a binary for Opera 12.15 stable from here:

tronayne 06-18-2013 07:55 AM

Optionally, the /extra directory on your distribution media (CD-ROM, DVD) contains a java directory with java.SlackBuiild.

You will need to download Java SE from I would suggest that you download the JDK package (JDK includes both the Java development software and the JRE run-time environment, used by many web sites). If you get JDK you get the Java compiler and tools in case you ever need them. The java.SlackBuild is the "standard" Slackware SlackBuild which used traditionally to build JDK and JRE Slackware packages -- the JDK packages installs both JDK and JRE.

The reason for all this is that Oracle, now the owner of Sun Microsystems (developer of Java in the first place), will not license redistribution of Java; essentially, Slackware cannot distribute Java anymore but can provide you the tools to install Java on your own (and neither can anybody else just give you Java already installed).

Now, about the Java plug-in.

There have been significant security problems with Java over the past months and it is recommended that the Java plug-in be disabled in browsers (all browsers) unless you must enable it for a particular -- trusted! -- site. As it happens, that's easy to do with Firefox and Seamonkey: click Tools, click Add-ons, click Plugins, then click the Disable button next to the Java Plug-in (or, to enable, click that -- the button changes color depending upon the state).

This is not paranoia -- you really, honestly do not want that Java plug-in enabled except for a specific trusted site that you must have it enabled for (then shut it back off when you're done). The Java plug-in has nothing whatsoever to do with JavaScript or anything but it has been shown to be a security hole and it's better to just shut it off unless you need it (and you usually don't need it for much of anything).

Hope this helps some.

neymac 06-18-2013 08:45 AM

@klee12: "#" in a command line code means "command as root" (and "$" commands as user), inside a script file "#" means that comments follow. (you don't need type the #, it's only to say that you must run the script as root). The "./" means run the file (script in this case)on present folder (directory), and "EXPLOIT_ME=YES" before the command to run the jdk.slackbuid script, means that the variable "EXPLOIT_ME" will be changed from "NO" to "YES", allowing the java plugin to be build.

klee12 06-20-2013 01:59 AM

T hanks all.

Unfortunately something came up and I have to leave tomorrow so I can't get to fixing 14.0 the way I want it I'll be back on Monday or Tuesday, and I'll work on it then. I'm pretty sure I'll be able to get it.


klee12 06-27-2013 07:19 PM

Hello everyone

I had to drop everything because I had to do other things. I'm back and trying to get Slack 14.0 running the way I want it to. I'm having problems with the jdk and opera.

I placed the line in neymac's response in the Build script at the top and built the jdk package again. I know it worked because a Warning message came up and when finished, I used removepkg to remove the old version and then install the new version. I tried to access the java plug first from Chrome, then with Firefox. Nothing happened. I rebooted. Still nothing happened. I looked in Firefox Tools, addons, and plugins. The java plugin was not listed. What did I do wrong?

Next I tried to install opera hoping to get better luck. I downloaded opera-12.15-i686-1ro.txz from Ruario's page and use the slackbuild script from the Slackbuild site on the net. The Slackbuild script complained about not having rpm files around and also was for version 11.01. I think Ruario's page had the rpm files, but I decided I shouldn't tempt fate.

All help appreciated.


qunying 06-27-2013 07:39 PM

#tronayne's method is better suite for you. And you don't need to do any special things. I don't think install new browser will solve your problem as plugin itself it not installed properly. Download the latest jre from here and run the java.SlackBuild against it, you will have an slackware package to install.

The file you download "opera-12.15-i686-1ro.txz" has already in Slackware package format, you could just installpkg/upgradepkg it. The slackbuild script is for building the slackware package from an rpm file.

klee12 07-08-2013 06:08 PM

Hello everyone. I got the java plugin working but after a lot of trouble.

1. One problem was that there is a slackbuild in the in the distribution in /extra/java. I'm pretty sure that's not the same as the slackbuild on the on the net. Some of the problems might be because I was not using the right slackbuild on the right source. I tried the jdk and jre so there and there were chances for errors.

I carefully used the slackbuild from with the jdk with EXPLOIT_ME=YES. It still didn't work. I looked at the script and noticed the critical difference between EXPLOIT_ME=YES or EXPLOIT_ME= NO was a line making a link into the mozilla/plugins directory. From the build script I figured the line

ln -sf /usr/lib/java/jre/lib/i386/ /usr/lib/mozilla/plugins

executed as root would do the trick and it did. I don't know why the Slackbuild didn't do that. Anyway Java works on my the Firefox and Chrome browsers.

I'm concerned about security. I'll make Firefox my primary browser and keep Java disabled. When I need it, I'll enable Java temporarily. I don't go the the sensitive site often and Java used to be resource hog. I don't see how I can disable java in Chrome but Chrome comes up with a strange message when I try to access that uses the java plug-in on my computer. I don't recall it giving that same message on other computers. I'm

I got Opera to work, but only as root. I looked at /usr/bin/opera but couldn't find anything wrong. I'm going to remove opera since 2 browsers are enough.

The source for mozplugger but it seems the source file is corrupt. It's not a biggie with me but everyone seems to rave about it so I thought it might be useful to have

I want to thank all of you who tried to help. You efforts are appreciated. It's amazing that the support here is better than support for the PC software that I've run across.


All times are GMT -5. The time now is 10:09 PM.