-   Slackware (
-   -   Java doesn't display i2p installer properly (

Stephen Morgan 04-01-2013 04:53 AM

Java doesn't display i2p installer properly
Slackware64-current, using the OpenJDK from AlienBob's repo (binary package). Version 7u17_b02.

I was installing the most recent i2p .jar from their website, and the programme displays in a very warped and unreadable manner. Unusable, in fact. Luckily there's an option to install through the console without the GUI, but still. I tried it in Crunchbang, and it installed fine on that, and I also tried in both E17 and KDE to make sure that wouldn't change it. Works on Crunchbang, doesn't on Slackware.

padeen 04-01-2013 07:21 PM

It may be unrelated, but just yesterday I installed IntelliJIDEA and they warn about running it under OpenJDK as, according to them, it can have corruption issues with the display. They recommend the Oracle JDK. IntelliJIDEA did run fine for me under OpenJDK, but you may try installing the Oracle JRE or JDK and see if that fixes your problem.

Stephen Morgan 04-02-2013 11:41 AM

The trouble is that it works fine on Crunchbang, which also uses:

java version "1.6.0_27"
OpenJDK Runtime Environment (IcedTea6 1.12.4) (6b27-1.12.4-1)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

All times are GMT -5. The time now is 11:26 AM.