-   Slackware (
-   -   Japanese display, fonts. (

Danodare 02-28-2004 10:13 AM

Japanese display, fonts.
Fresh install of slackware 9.1. I installed the i18n. Mozilla displays hex boxes instead of japanese characters. Searching here told me it is a font problem and that I need to install japanese fonts. But all the posts I found were at least six months old and were about other distros or slackware 9.

So, is there a "clean" way of displaying japanese fonts in slackware 9.1 ? Downloading fonts from Microsoft and putting them in linux seems unnatural. Also, japanese display worked perfectly by default in mandrake 8.2 (my previous distro), so it seems a bit odd that slack wouldn't have something equivalent.

Thanks in advance,

quatsch 02-28-2004 03:36 PM

have you checked the font settings in mozilla? sometimes, it is not set to display with the right font set. Also, make sure mozilla is detecting the right encoding (under View).

I'm pretty sure Slackware comes with some Japanese fonts, but I think now there are no freely available Japanese fonts b/c of copyright issues. the ones that used to come with distros are no longer available. Besides, the MS ones do look a lot better.

wapcaplet 02-28-2004 04:25 PM

No free Japanese fonts? (in Japanese) (also in Japanese)

quatsch 02-28-2004 04:47 PM

sorry, I was thinking of ttf fonts (and ones that include the whole kanji set, not just the phonetic characters). mnikachan's is the only one I know of and it's too cute for daily use...

newinlinux 02-28-2004 06:26 PM

i used to have the same problem with jpn, ch and kor characters, i only need chinese, but i hate seeing the boxes appeared on my web pages, so i wanna fix them all.

What i did is to copy from my WinXP fonts, eg batang, mingliu, etc to /usr/share/fonts(create yourself) and then reboot for fc-cache to update them(could be a more elegant way than a windowish reboot, but it get my problem solved...). Relaunch your Mozilla and you will see them all there. BTW, Netscape has no problem with these. It can show all Jpn, CHinse, Korean at default. But IMO, they looked aweful, so getting from MS is the best way out for me. Try it.

PS:no need to adjust any fonts setting/choice within Mozilla.

Danodare 02-29-2004 04:18 AM

For some reason it did not occur to me to try netscape. Indeed it worked under Netscape, by default. The font Netscape uses is jisx0213. It's not pretty, but it's readable :).

Copyright reasons explains why mandrake 8 had it but but not slackware.

Several options for me now, I'll first have a look at the links you posted, then I'll check windows 2000 pro(I don't own an xp yet). If I don't like any of the fonts there as a last resort I'll dust my mandrake machine and boot it one last time to copy the fonts from there :).

Thanks a lot,

Danodare 02-29-2004 07:56 AM
Not bad for 12 sized fonts, but a bit small.
Based on the shinonome fonts, see
Those are functional.
As one poster said, too cute for daily use :)
Unless I'm mistaken, the one Netscape uses.

Mozilla under Windows uses msmincho and msgothic. I found in my windows 2000 /winnt/fonts directory,


I just copy these files into "/usr/X11/lib/X11/fonts/TTF" and reboot ? The reason I ask is because this directory only contains .ttf files, not .ttc.

Thanks in advance,

newinlinux 02-29-2004 09:07 AM

These are the fonts I have copied:

arial.ttf cour.ttf micross.ttf per_____.ttf verdana.ttf
batang.ttc gulim.ttc mingliu.ttc simsun.ttc

I have never used /usr/X11/lib/X11/fonts/TTF, I always dumped them in /usr/share/fonts, works everytime except this time, i just realized Traditional Chinese fonts are corrupted, the characters are only patially visible. Simplified Chinese is nice, so do Korean & Jpn. Not sure why now.

Danodare 02-29-2004 11:47 AM

Actually, copying the files in "/usr/X11/lib/X11/fonts/TTF", logout from kde then startx and it worked, without even rebooting.

The fonts I used were not from my own windows, which is on another machine. It would have been troublesome to copy them to this machine. Rather than that, I preferred to just download them from this site :

Kde 3.1.4 automatically recognized the .ttc files and picked up all five fonts in each file, not just the first ones.

Anyway, now I need japanese input to work, going to cross fingers and try canna / kinput2 :)

Wish me luck,

All times are GMT -5. The time now is 05:25 AM.