LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   I've screwed up installing flash player (https://www.linuxquestions.org/questions/slackware-14/ive-screwed-up-installing-flash-player-4175433956/)

pottzie 10-24-2012 10:44 PM

I've screwed up installing flash player
 
First let me say that I installed Slackware 14 about a month ago. I also installed another hard drive,and in doing that, "lost' the Slackware HD for a while. I just found the command to get grub to list Slack as a choice when I boot, and now I've got it back.

When I first installed #14, I tried to get flash player running, and I'm pretty sure I used the slackpkg tarball. It's never worked, although thanks to Google et all, some videos play sometimes, but randomly. I was just reading another post where someone was trying to get flash working, and saw that I needed to check /usr/lib/mozilla/plugins for libflashplayer.so. When I looked at that file with the file manager, I somehow have kdm_adobe_flash player.so

I don't know if that's what I'm supposed to have or if I've somehow gotten a bad file and need to remove it and reinstall the right one. Any one know?

Nikosis 10-25-2012 12:52 AM

You suppose to have libflashplayer.so in that file

damgar 10-25-2012 01:06 AM

Get the flashplayer tar.gz file from adobe for your architecture. Extract it. Copy libflashplayer.so to the directory you mentioned. That's all you have to do.

kingbeowulf 10-25-2012 02:08 AM

On the other hand, on the Slackware 14 DVD (or mirror or wherever you got it from), look for the directory:
Code:

/extra/flashplayer-plugin
There's a nice build script that will download flash and build a nice slackware package that you can install with "installpkg" and, if you ever get tired of flash, cleanly uninstall with "removepkg"

Everyone makes fun of Slackware's package tools, but they are very useful and powerful. You should get used to using them.

Alien Bob 10-25-2012 03:48 AM

And if you don't want to edit a SlackBuild in order to change the version number and download a tarball from Adobe, I have ready-built packages for you which you can install directly using "installpkg":

http://slackware.com/~alien/slackbui...player-plugin/

Eric

allend 10-25-2012 07:03 AM

Other virtues of using the SlackBuild or Eric's packages are that you get:
1. /usr/bin/flash-player-properties - A program that can be used to configure flash-player settings and handle flash cookies.
2. Additional files to support the use of /usr/bin/flash-player-properties from within KDE System Settings.

pottzie 10-25-2012 12:25 PM

So...it took me a while to find out how to make the flash player file to "work" from the DVD. I installed Google Chrome from it, but I think there was a "read me" that explained it. I now know that all that's needed is to run "so" before the file name, but it throws me every time. As far as I know, I've only ever had to use that "so" command in Slackware, although I know I've used it before to get things working on previous Slackware installs.

I'm having problems with either Firefox or Slackware itself freezing. Slackware isn't the only OS I'm having this happen to, and that's partially why I'm trying Slackware again, now. It may be my computer, as I had Ubuntu on the hard drive I added to this computer, and spent a good weekend fracking with that before deciding to just say to hell with it, and Installed Mint LXDE, so I wouldn't have to deal with Gnome's issues. But Firefox froze after I had run the "sh flashplayer" command. I had read that it installs to tmp, and after rebooting I changed into tmp and ran an "ls" command to see what was there. Here's the output.
Code:

bash-4.2# cd /tmp
bash-4.2# ls
CRX_75DAF8CB7768                                          virt_1114
akonadi-larry.rpk9s8                                      virt_1115
akonadi-root.FJ2gfp                                      virt_1116
blueman-applet-1000                                      virt_1117
build                                                    virt_1118
google-chrome-22.0.1229.79-i386-1.txz                    virtuoso_hX2233.ini
google-chrome-stable_current_i386.deb                    virtuoso_hX2236.ini
google-chrome.SlackBuild                                  virtuoso_hX2240.ini
install_flash_player_11.2.202.236_linux.i386.tar.gz.FAIL  virtuoso_hX2242.ini
kde-larry                                                virtuoso_hX2245.ini
ksocket-larry                                            virtuoso_hX2250.ini
package-google-chrome                                    virtuoso_hX2256.ini
slackpkg.BuIHYe                                          virtuoso_hX2258.ini
slackpkg.bjBT0c                                          virtuoso_hX2260.ini
slackpkg.ccowhG                                          virtuoso_hX2275.ini
virt_1111                                                virtuoso_hX2279.ini
virt_1112                                                virtuoso_hX2304.ini
virt_1113                                                virtuoso_hX2482.ini
bash-4.2#

Looks like I've got a problem.

damgar 10-25-2012 01:50 PM

The package doesn't install to /tmp. When you run the script with
Code:

sh flashplayer-plugin.SlackBuild
a package is created in /tmp. If you read the flashplayer-plugin.Slackbuild script it tells you
Quote:

# Run 'sh flashplayer-plugin.SlackBuild' to build a Slackware package.
# The package (.txz) and .txt file as well as build logs are created in /tmp .
# Install it using 'installpkg'.
#
# ---------------------------------------------
In other words after you run the script, run the command
Code:

installpkg /tmp/flashplayer-plugin-11.2.202.243-i386-1alien.txz
if that is the actual version that you created It's probably easier to just hit tab after you have flashplayer typed. You can also just download Alien Bob's package as he mentioned (he's the guy that wrote the slackbuild script in the first place) and use installpkg the same way only replace "/tmp" with where ever you downloaded it to.

pottzie 10-25-2012 04:19 PM

I think I'm sorta on the same page as what you've said, I figured the package just got sent to tmp where it would be unpacked and installed where it belongs, probably /usr/.

But what I have is:
Code:

bash-4.2# installpkg /tmp/flashplayer-plugin-11.2.202.243-i386-1alien.txz
Cannot install /tmp/flashplayer-plugin-11.2.202.243-i386-1alien.txz:  file not found

I'm wondering if I should re-run 'sh flashplayer' from /extra/ again, since I had to reboot before I could do the installpkg the first time.

Wondering where the Slackbuild script is? I looked for a "read me," and didn't see one anywhere.

damgar 10-25-2012 05:43 PM

Either do that, or just download the package from alien bob. For the 32 bit it is here 64 bit is here. In the directory where you downloaded the file do
Code:

installpkg flashplayer-plugin-11.2.202.243-x86_64-1alien.txz

pottzie 10-25-2012 07:02 PM

Success! Thanks damgar. I was surprised that it worked without me having to download something from Adobe.

Now to see if I can make my computer run faster! It's so slow now that when I click on something, even a local file on my file system for instance, it takes well over a minute before something happens. Going to post something on that real quick, now.

Thanks again.

ottavio 10-28-2012 01:12 PM

Prompted by this thread I decided to get rid of the Adobe Flash plugin, restarted Firefox, pointed it to Youtube and I'm still able to watch videos (in HTML5).

adriv 10-28-2012 01:18 PM

If you only need flash for YouTube, then yeah, get rid of it.
But there are millions of other sites that require flash...

damgar 10-28-2012 03:12 PM

Personally I don't install the flash player. I install google-chrome which has it's own (no blue people) version of flash. It's not that big of deal I don't guess, but it is just one less thing I have to deal with.

cfdisk 10-28-2012 04:19 PM

@ottavio

Do you use any HTML5 Video Viewer?

Please be more specific about watching videos without dreaded Adobe Flash.

Thanks in advance.


All times are GMT -5. The time now is 01:49 AM.