LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-21-2015, 02:01 PM   #1
theactionindex
LQ Newbie
 
Registered: Aug 2015
Posts: 8

Rep: Reputation: Disabled
Issue with sound (only chrome and vlc gets sound)


So, I'm still setting up my system. If you saw my wifi post, I finally got that working stable but one thing I haven't gotten to be stable is audio.

I am using my monitors in built speakers until I can afford to get a better speaker setup, and it is connecting through HDMI via my graphics card. Now, I read the slackware docs and googled around a little bit and I am still having trouble. Essentially, the only 2 applications I can get sound to even work on are Google Chrome (note: not Chromium) and VLC media player. I have tried random other apps (example: FCEUX/higan, Chromium, Firefox) to check to see if it outputs any sound and none of them do.

I'm not exactly sure what to post, so I am going to do

aplay -l
Code:
bash-4.2$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC1150 Analog [ALC1150 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC1150 Digital [ALC1150 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
my .asoundrc
Code:
pcm.!default {
        type hw
        card 1
}

ctl.!default {
        type hw
        card 1
}
/etc/modprobe.d/snd-hda-intel.conf
Code:
options snd-hda-intel model=auto
/etc/asound.conf
Code:
pcm.!default {
  type hw
  card 1
  device 8
}

ctl.!default {
  type hw
  card 1
}

I have confirmed it is device 8 with using aplay -D plughw:1,8 Noise.wav

Also, another strange thing that has happened is I rebooted my computer once, and it changed from card 1 to card 0 and another reboot it went back to card 1. Is there a way to prevent that?

Thanks in advance for any help! If you need more information, I can provide it.
 
Old 08-21-2015, 09:17 PM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,629

Rep: Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529Reputation: 1529
Your .asoundrc does not specify the device.
Code:
pcm.!default {
        type hw
        card 1
        device 8 
}

ctl.!default {
        type hw
        card 1
        device 8
}
Another approach is to use the probe_mask option to the snd-hda-intel kernel module to restrict probing to the device that you want to use. This document is relevant, especially sections 7 and 12.10.2 ftp://download.nvidia.com/XFree86/gp...dmi-audio.html
For examples of usage see this post. http://www.linuxquestions.org/questi...2/#post4032980
You might still need the .asoundrc http://www.linuxquestions.org/questi...mt-4175535459/

Last edited by allend; 08-21-2015 at 09:42 PM. Reason: Corrected link
 
Old 08-24-2015, 09:24 PM   #3
theactionindex
LQ Newbie
 
Registered: Aug 2015
Posts: 8

Original Poster
Rep: Reputation: Disabled
Ok, so I kind of solved this on my own right now. The problem was I set up the config all wrong. I wanted it to go through pulseaudio. I had alsa-plugins installed, but didn't make the right config to go along with it I guess.

So, my /etc/asound.conf looks like
Code:
pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
Everything working now!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux and ALSA default sound card, two methods fail to set firefox/chrome sound. jon_k Linux - Hardware 2 10-03-2013 07:09 AM
vlc 2.7 mageia 3 no video only sound vlc win ok moshebagelfresser Mageia 5 07-21-2013 12:20 AM
VLC sound issue manox Linux - Software 3 08-29-2012 05:54 AM
sound settings issue when run VLC under root ciremai Linux - Software 4 06-13-2012 06:29 AM
No Sound with VLC on SB0220 sound card Tiepo Linux - Hardware 1 12-31-2006 06:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration