Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-18-2003, 04:08 PM   #1
Registered: Nov 2002
Distribution: Slackware
Posts: 155

Rep: Reputation: 30
Angry isolinux.cfg - can not have a prompt and timeout


I am working on a slackware auto install, I have altered some of the standard files to run some extra scripts, mount a NFS partition were the install scripts are kept.

This way once I get the CD image how I want it I will not have to reburn a CD everytime I make a change to the install process.

The CD image is done except for one small minor bug, in the isolinux/isolinux.cfg file, there is a "prompt 1" where the install waits for you to hit enter and enter a different kernel then bare.i , I want it to do this except timeout after 10 seconds or so. I have tried many different combos but can not get it to work.

prompt 1
timeout 1000

prompt 1
timeout = 1000

timeout 1000

timeout = 1000

default /kernels/bare.i/bzImage initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=6464 rw root=/dev/ram SLACK_KERNEL=bare.i
timeout = 500
display message.txt
F1 message.txt
F2 f2.txt
F3 f3.txt

Any help is greatly appreciated.
Old 02-18-2003, 08:56 PM   #2
Senior Member
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 46
This is from the syslinux.doc file. The isolinux.doc and the website both state to use the syslinux.doc for information regarding the config file.

PROMPT flag_val
If flag_val is 0, display the boot: prompt only if the Shift or Alt
key is pressed, or Caps Lock or Scroll lock is set (this is the
default). If flag_val is 1, always display the boot: prompt.

TIMEOUT timeout
Indicates how long to wait at the boot: prompt until booting
automatically, in units of 1/10 s. The timeout is cancelled as
soon as the user types anything on the keyboard, the assumption
being that the user will complete the command line already
begun. A timeout of zero will disable the timeout completely,
this is also the default.

NOTE: The maximum possible timeout value is 35996; corresponding to
just below one hour.

Download SysLinux from:
SysLinux web site:
Current version 2.02.

So to your question I would think you would want:

prompt 1
timeout 100
Old 02-20-2003, 03:58 AM   #3
Registered: Nov 2002
Distribution: Slackware
Posts: 155

Original Poster
Rep: Reputation: 30
Thanks, I was using the wrong timeout value. It is working great.
Old 09-28-2008, 06:34 AM   #4
Registered: Aug 2004
Distribution: Lubuntu Live OS
Posts: 432

Rep: Reputation: 30

in the isolinux.cfg file , howto add software image .gz file after the initrd.gz file?

LABEL auto
        kernel vmlinuz
        append auto=true priority=critical vga=normal initrd=initrd.gz


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
mkisofs: Error - boot image './isolinux/isolinux.bin' has not an allowable size. ogross74 Red Hat 3 05-05-2016 03:22 AM
Isolinux Brigit Linux - General 2 08-11-2005 05:04 PM
xf86 cfg ?? wrat Debian 7 05-11-2004 08:16 AM
isolinux dot_txt Linux - Laptop and Netbook 2 11-19-2003 08:46 PM
ISOLINUX 1.75 2002-06-14 isolinux failed to get sector size tihe Linux - General 13 12-16-2002 05:55 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:49 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration