-   Slackware (
-   -   Is Gnome broken in Slackware 10.1? (

yonatan1 02-15-2005 04:17 PM

Is Gnome broken in Slackware 10.1?
Hey there everybody,

Just wondering if anyone else has experienced problems with Gnome on Slackware 10.1? After a fresh install (on 2 different boxes) I'm getting complaints from Gnome when it tries to load the panel (something to due with sound and the mixer); On the other hand KDE (and sound in general) works without a hitch, and my old installation of Slackware 10.0 didn't have this problem.

If it's not a general problem, I'll try to post the exact error messages, but I'm led to believe that it is a general problem (While searching the various forums, I've gotten the impression that for whatever reasons, Gnome support in the official distro may not be entirely 100%.)


sh1ft 02-15-2005 05:46 PM

As far as I know gnome is not being maintained and packaged by Pat anymore. You should probably get dropline-gnome or find someone who has gnome 2.8.x packages made.

Franklin 02-15-2005 08:29 PM

There has been a problem for some time now regarding gnome when you attempt to login as root.

The gnome-settings-daemon fails after several attempts.
The basic no-brainer solution is to not login as root. Of course this does not explain the problem much.

I have seen one post elsewhere that indicated it may be due to an earlier upgrade of gstreamer. The "solution" was to compile the latest gsteamer from source, however there was not a great deal of confidence that this was indeed the problem/solution.

I know this is not a great deal of help but it might aid you in your search.

That is of course assuming that your difficulties are as I described.
I must add that logging in as a normal user to gnome works fine (for me and most others). If you are having problems as a normal user, then your issue may be a different one.

If you are big into Gnome, I suggest dropline. I should also point out that DL does not plan to upgrade the 10.1 installer until Gnome 2.10 is released (relatively soon I think). That is my understanding at any rate.


yonatan1 02-17-2005 03:10 AM

See this info about upgrading gstreamer:

Franklin 02-17-2005 06:21 AM

I had not seen the post from the 16th. Looks a little more definite. Let me know if this fix works for you.

K@rl` 02-17-2005 06:27 AM

I might give Dropline Gnome a try tonight.

What differences are there, and why is it so specific to Slackware ?

perfect_circle 02-17-2005 07:21 AM

As far as I know dropline Gnome is not yet tested in 10.1. Also Dropline gnome is not a simple Desktop Manager. It will alter a lot things in your system, like installing PAM which is something Pat dislikes and makes your system less "slackwarish". A simple Desktop Manager would not install a new Xorg either. I never tried dropline gnome, but they same it works fine. Personally I don't have a problem using gnome or KDE, so i prefer to use the window manager that is maintained better in my distro. I never use KDE in fedora, it's awful anyway, and I never use gnome in slackware. Actually, I did not install gnome in slackware at all. I just installed gftp which does not need any gnome libraries, and use it in KDE, since there is no graphical ftp Client in KDE . Gnome is not updated in Slackware 10.1 and may also be not tested. Pat prefers KDE, but the main reason he does not maintain gnome any more is that it is hard to package, because it's not centralized. I would do the same thing if I were keeping a distro all by myself. In slack 11 there will be no gnome at all, which i think is better, because this will give the opportunity to other people to package and test gnome. Till then use KDE, it's not so bad....
I think most distro's make a choice between gnome and KDE. Anyway in the slack10.1 announcement, there is nothing said about gnome:

Highlights of the 10.1 release include the Linux 2.4.29 kernel (with Linux 2.6.10 as an alternate choice in /testing), X11R6.8.1 from X.Org, Mozilla 1.7.5, KDE 3.3.2, and Xfce 4.2.0. For a complete list of changes since Slackware 10.0, check out the Slackware 10.1

yonatan1 02-17-2005 08:32 AM

Just BTW, I confirmed that the info I found about gstreamer seems to work:

1. removepkg gstreamer
2. download latest gstreamer
3. untar -fx gstreamer...tar (can't remember exact name)
4. ./configure; make; make install

Login to gnome as root now works.

However, I'm still having a problem with getting gnome-volume-control to work. I read somewhere (can't remember where or I would give credit) that it requires kernel 2.6, but that didn't seem to help me (it says that it couldn't find any devices).

I'm thinking that sticking with KDE for Slackware might be the best option right now as well, even though KDE is a bit slow for my PII box. I guess I could always get rid of the KDE eye candy.

Cdzin 02-17-2005 11:03 AM

Not my business, but perhaps you should give Xfce a try? I mean, I have a AMD K6-2 450MHz and I used to use (?) KDE ... But since it was a bit too slow on my system, and I didn`t want to go for a totally basic desktop manager, I tried Xfce (4.0 at that time) and liked it as it`s cute, fast and has some nice features (of course not as much as KDE). I just miss a display manager on it, like Gnome has its GDM and KDE with its KDM. Well, my point is that even if you turn all the KDE`s eye candy off, it won`t be as fast as Xfce. But that`s just my view. :)

LiNuCe 02-17-2005 12:19 PM

Re: Is Gnome broken in Slackware 10.1?

Originally posted by yonatan1
Hey there everybody,

Just wondering if anyone else has experienced problems with Gnome on Slackware 10.1? After a fresh install (on 2 different boxes) I'm getting complaints from Gnome when it tries to load the panel (something to due with sound and the mixer); On the other hand KDE (and sound in general) works without a hitch, and my old installation of Slackware 10.0 didn't have this problem.
Yes, as you can read it, it seems that Linux Slackware 10.1 provides a GNOME desktop where applications accessing the mixer device are broken. But you can try these GNOME 2.8.2 packages for Linux Slackware 10.1. Note that they are build with ALSA support and a 2.4.29 Linux kernel as provided with Linux Slackware 10.1.

ve2mrj 02-17-2005 10:21 PM

For the sound, configure the card with

after, do as root

Try gnome, the mixer adn sound should work.

Another thing that you can try for problems with desktop

update-mime-database /usr/share/mime

update-desktop-database /usr/share/applications

export GCONF_CONFIG_SOURCE="xml::/etc/gconf/gconf.xml.defaults"

gconftool-2 --makefile-install-rule /etc/gconf/schemas/*.schemas

gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules

gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders

pango-querymodules > /etc/pango/pango.modules

This will update some files...

Hope this can help.


jong357 02-20-2005 02:57 AM

Nice thread.... Thanks for all the info and links. I initially removed gstreamer as suggested thru pkgtools and built from source. Didn't work for me. I used the same 3 prefixes as Pat and kept the --disable-docs-build switch because the make would error out on me once it hit the doc section.

Then I tried running gnome-settings-daemon manually and it told me to either remove the plugin that was seg faulting on me or to debug it or some such non-sense. So then I just:


cd /usr/lib/gstreamer-0.8/

and now it works quite nicely. We'll see if I have any ramifications from voiding that plugin...

yonatan1 02-21-2005 12:25 AM

As I mentioned above, I couldn't get gnome-volume-control to work (it could't find any devices). It turns out that there's an interesting thread here about the subject of gnome 2.6 and ALSA:

skedit 02-21-2005 02:50 AM

a gstreamer's module occurs segment fault error. I remove the .so file and that all is ok.

you can run /usr/libexec/gnome-setting-daemon in a term, it will display the error message.

folkenfanel 02-28-2005 01:05 PM

Thanx jong357
Thanx jong357, your method WORKS on a fresh slackware install. After many tries i formatted my hda5, and installed a fresh new slack 10.1. After that i executed gnome-settings-daemon in a xterm, it gave me the segfault msg, and i did what you said:

cd /usr/lib/gstreamer-0.8/

So far i haven't had any problems. I didn't need to install anything new. Didn't either do anything else. It works perfectly.

All times are GMT -5. The time now is 04:19 AM.