-   Slackware (
-   -   Is anyone succesfully running 2.6.32 with the proprietary NVIDIA driver? (

damgar 12-15-2009 08:49 AM

Is anyone succesfully running 2.6.32 with the proprietary NVIDIA driver?
I've been trying to figure out the cause of system hangs with slack 13 for a a week or so. I get random total freezes with the keyboard LED's blinking at me and the only solution is to do a hard-reset. I was using a self-compiled kernel on 32bit Slack with similar results, but thought it had more to do with several bad starts as I got used to Slack's way of doing things... eventually I decided I'd made enough bad starts with that installation and after reading a bit about _current fixing some stability issues added another installation to my machine using Slackware64 and upgrading to _current. It worked great, then I installed the NVIDIA proprietary driver. The system hangs are back.

Sometimes they happen quickly, sometimes they take hours, sometimes while I'm working, sometimes when the machine has been idle for hours. For a couple of days I've been going back and forth between the NVIDIA propreitary and the nv driver. I've run memtest86 for 4.5 hours and not a single error, I'm running this on a new HD, I even upgraded the case fan (the old one was starting to complain!).

I've also installed different versions of the driver 185.x.x, 190.42.x. I've used slackbuilds, I've used "sh" I've said "yes" to everything the installer asked, I've said "no".

So far no hangs with the nv driver. I've been leaving one or the other running at all times and no hangs with the nv driver, but within hours with the proprietary driver.

All that is to say I'm confident the issue is with the NVIDIA proprietary driver, OR something in my kernel options that only shows up when I'm using the NVIDIA driver.

Is anyone else running this successfully?

SLACKWARE64 kernel 2.6.32 (same behavior on 32bit with
compiled kernel with "make oldconfig" then "make localmodconfig" BEFORE the NVIDIA driver was installed.
ext3 filesystem (same behavior with ext4 on previous installation)

~sHyLoCk~ 12-15-2009 08:53 AM

I am using the same as you atm..

Kernel - 2.6.32
Arch - x86_64
FS - Ext3
NVIDIA 190.42
It works fine.
Did you removepkg the slackbuilds driver before installing the driver?
EDIT: Just patched to and works here too.


damgar 12-15-2009 09:11 AM

No since Slackbuilds was the most recent attempt. My method has been to
PHP Code:

sh --uninstall
(or mv) /etc/X11/xorg.conf

after a failed attempt with the driver then scratch my head while googling for a clue.

ponce 12-15-2009 11:43 AM

I think you NEED an xorg.conf (despite youe X version) for nvidia driver, at least these lines

Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"

Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option    "Protocol"      "Auto"
    Option "Device"      "/dev/mouse"
    Option        "ZAxisMapping"      "4 5"

Section "Device"
    Identifier  "NVIDIA"
    Driver      "nvidia"

Section "Monitor"
    Identifier  "My Monitor"
    Option      "DPMS" "true"

Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA"
    Monitor    "My Monitor"
    DefaultDepth 24
    Subsection "Display"
        Depth      8
    Subsection "Display"
        Depth      16
    Subsection "Display"
        Depth      24

Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

sahko 12-15-2009 12:12 PM

Not having a xorg.conf only works with opensource drivers. That means all the xf86-video-*'s

damgar 12-15-2009 05:07 PM


Not having a xorg.conf only works with opensource drivers. That means all the xf86-video-*'s
Understood. When I've installed the driver, I then set an xorg.conf file in order to load the NVIDIA driver. When I getanother system freeze and I realize that I still have not fixed the issue, then I use the above method to do away with whatever NVIDIA driver that I was using so that I can startx with the nv driver since I never know if I'm 2 minutes or 12 hours from a system freeze with the NVIDIA driver.

John VV 12-15-2009 10:08 PM

if you are running Gnome it might be the nvidia/kernel/gnome bug
Running kde fixes that

vbisis 12-16-2009 12:39 AM

Yep I also have kernel 2.6.32 running with Nvidia driver.
Just installed by running the installer. Works great :)

x94qvi 12-16-2009 06:15 AM

I'm not sure if this will help you or not, but I had some weird problems with older versions of the kernel & the proprietary driver - many random freezes (sometimes when I was on, sometimes when I wasn't using the system), and the freezes always happened in X.

I was able to find some relief through a tip or two posted by a rep from NVidia here:

In my case, I took the suggestions about adding pci=nommconf & idle=poll kernel parameters, and that seemed to do the trick for me. (My system is dual core)

I know it's an older post, but it may be worth trying anyhow.

flayzernax 12-16-2009 12:20 PM

I think the NVIDIA-XXXXXX-pkg-run script from their site is good for fixing your xconfig (it will back up the old one), it will also search for and replace /disable the old nvidiafb modules and it also does a very good job at removing any wierd opengl/mesagl libs/dependencies and replacing them with nonconflicting ones.... their installer code is pretty awseome. I do not recommend using a pre-built package of the NVIDIA drivers.

just grab the kernel source and unpack it to /usr/src/linux-kernelversion (or if you install it from a repository/package it will do it for you) then run the nvidia installer from runlevel 3 (X, or Xlogin like KDM not started)

don't have to worry about much configuration then. In like 4 years i never had a problem doing it this way...

also there were some command line arguments to pass to the PKG-run script from NVidia that would unpack that and put a folder with some docs and let you make/compile your own module for your kernel, in those docs is just about everything you can check to see what could be causing your probs...

I'm currently running KDE4 no problems

damgar 12-16-2009 01:04 PM

Thanks for all of the replies. I'm not sure where things stand at the moment as I'm testing again. I'm trying passing kernel options from the post above at the moment. I am fairly sure that my problems arise from 1 of 2 sources: I'm missing something when I configure my own kernels or perhaps the video card is experiencing a slow and at least for me PAINFUL death! LOL

On the bright side I've earned some good experience with compiling/recompiling kernels
setting up dkms
getting around without X
how to pass kernel options at boot
editing grub
editing xorg.conf
AND I haven't had to redo a Slackbuild on this entire installation (hey, it was a slow start with slack LOL)

damgar 12-16-2009 10:46 PM


Originally Posted by ~sHyLoCk~ (Post 3792289)
I am using the same as you atm..

It works fine.
Did you removepkg the slackbuilds driver before installing the driver?
EDIT: Just patched to and works here too.


I have to ask.....what path did you take to your current kernel? Were there intermediate kernels between the stock kernel and current? What make target did you use? I've tried and 2.6.32. and I've tried multiple builds. Most recently I did
PHP Code:

make oldconfig 

from the that doesn't fail and just held enter at the new options.
I've followed alien BOB'S slackware kernel roll to the letter, even a seperate build directory at /kernelbuild. I am just stumped. I have yet to get to hang, and I can't get 2.6.32 to hang when I run without the NVIDIA proprietary driver.

stormtracknole 12-16-2009 11:25 PM

I just compiled and I'm running the latest nvidia drivers with no problems. One thing that I always do when compiling a new kernel, I copy the .config file from the stock Slackware kernel into the new one. For example:

cp /usr/src/linux- /usr/src/linux-
Then, I run:

make oldconfig
Then follow the rest of Alien Bob's tutorial:

make bzImage modules
make modules_install

~sHyLoCk~ 12-17-2009 12:03 AM


I patched 2.6.32 source.


damgar 12-19-2009 09:24 AM

Thanks to PTrenholme at pointing me towards the bios again.
I am running on the latest stable kernel with no crashes for 15 hours now! I feel like I should have caught this 2 weeks ago when I looked in the bios but the setting "pci express frequency = auto" looked innocuous enough, but setting it manually seems to have been the answer all along.

I'm still not sure what changed between and that caused the bios setting to no longer work, any ideas or pointers on figuring that one out are appreciated.

On the bright side I am a much smarter noob today than I was 2 weeks ago with all the things I learned that DIDN'T WORK! LOL


PHP Code:

USER@dtest:~# uname -r 


All times are GMT -5. The time now is 11:07 AM.