LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-11-2019, 09:02 PM   #1
sinbadway
LQ Newbie
 
Registered: Jul 2019
Location: USA
Distribution: Slackware
Posts: 5

Rep: Reputation: Disabled
IPv6 kernel autoconf disabled only on boot with DHCP (dhcpcd)


For reasons, I've configured my Slackware 14.2 stable system (all updates applied as of this writing) to use DHCP rather than NetworkManager. With the router already on, when I start my system it gets assigned an IPv4 address as expected, but attempting to secure a DHCPv6 lease fails. Here is a slightly redacted excerpt from the console noise on boot:
Code:
Polling for DHCP server on interface eth0:
all: IPv6 kernel autoconf disabled
eth0: adding address <<an ipv6 address>>
if_addaddress6: Operation not supported
eth0: waiting for carrier
eth0: carrier acquired
all: IPv6 kernel autoconf disabled
DUID <<a duid>>
eth0: IAID <<an iaid>>
eth0: soliciting a DHCP lease
eth0: offered 192.168.10.xxx from 192.168.10.1
eth0: leased 192.168.10.xxx for 259200 seconds
eth0: adding route to 192.168.10.0/24
eth0: adding default route via 192.168.10.1
forked to background, child pid 1286
But with my system already up, if I restart the router my system gets *both* IPv4 and IPv6 DHCP leases and everything works perfectly. Clearly ipv6 kernel autoconf and any related settings are re-enabled at some point after this boot message.

Excuse me if this question has been already asked: how do I enable ipv6 autoconf during startup so that DHCPv6 leases can be assigned at boot time?
 
Old 07-11-2019, 09:52 PM   #2
tadgy
Member
 
Registered: May 2018
Location: UK
Distribution: Slackware (servers), Ubuntu LXDE (desktop/laptop)
Posts: 32

Rep: Reputation: 43
If you're looking to use IPv6 with Slackware, you might want to check out my updates to rc.inet1 which integrate IPv6. The work is currently hosted in rworkman's 'slacknetsetup' git repo: https://git.rlworkman.net/slacknetsetup/

You will need to clone the repository with git, then 'checkout' the 'ipv6' branch.
Read the README.IPv6 file for info on how to configure IPv6 networking (you can copy the rc.inet1.conf onto your system and adjust to suit as a starting point), and copy rc.inet1 into place over the current /etc/rc.d/rc.inet1 (don't forget to back up the original files!)

A reboot will be necessary to activate it once configured.

If you have any feedback, please let me know here or via a PM
 
Old 07-11-2019, 11:17 PM   #3
sinbadway
LQ Newbie
 
Registered: Jul 2019
Location: USA
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by tadgy View Post
You will need to clone the repository with git, then 'checkout' the 'ipv6' branch.
Read the README.IPv6 file for info on how to configure IPv6 networking (you can copy the rc.inet1.conf onto your system and adjust to suit as a starting point), and copy rc.inet1 into place over the current /etc/rc.d/rc.inet1 (don't forget to back up the original files!)

A reboot will be necessary to activate it once configured.
Thank you for your kind reply! I followed (I believe) all requisite instructions, and found no change in the problem or the output using the new scripts, unfortunately.

But it seems I'm guilty of seriously overthinking this problem. Because I'm running a generic kernel (which I now realise I should have mentioned sooner), the simple reason why ipv6 autoconf is disabled when the attempt to acquire a DHCPv6 lease is made is only because the ipv6 kernel module is not loaded. Adding the line "/sbin/modprobe ipv6" to /etc/rc.d/rc.modules.local fixes the issue, and DHCPv6 is now correctly assigned at boot with both the stock rc.inet1 and your updated version.

Thank you for your help in any case!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set autoconf for IPv6 using ioctl? neel_tailor Linux - Newbie 1 01-29-2016 01:39 PM
DHCP lease only obtainable with dhcpcd; wicd won't grab it for whatever reason. foodown Linux - Networking 3 09-29-2011 01:01 PM
DDclient slack13 dhcpcd.sh vs dhcpcd.eth0.exe question nl1at Slackware 3 10-27-2010 01:51 PM
*** YOU'RE USING autoconf (GNU Autoconf) 2.60. KDE requires autoconf 2.52, 2.53 or 2. arubin Slackware 6 09-24-2008 03:31 AM
dhcpcd wireless problems. dhcpcd wlan0 removes essid entry in iwconfig. Romanus81 Slackware 3 08-25-2008 10:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration