LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-17-2008, 02:03 AM   #1
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Rep: Reputation: Disabled
Invisible fonts in GTK(+2) apps with dejavu in -current.


Hi!

I've encountered the most disturbing issue with linux in my career so far.
So: I'm running -current on both my desktop and my laptop. I've upgraded them both with the new dejavu-fonts-ttf package.

After the upgrade, when I turned on the laptop the following day all my fonts were gone as seen here.
This happens to all GTK+2 apps (don't have any GTK1).

But this only happens on the laptop,the desktop doesn't suffer from any of this.

After about 10+ hours of trying different things (package reinstallation, countless fc-cache updates, removing the new scripts from /etc/fonts/conf.d/, countless reboots) I ended up with reinstalling the whole thing. Updated again this time everything was fine. I rebooted again just to be sure it still was fine, but again the next day the fonts were gone again :/

Any tips?
 
Old 03-17-2008, 04:57 AM   #2
Eternal_Newbie
Member
 
Registered: Jun 2005
Location: The Pudding Isles
Distribution: Slackware
Posts: 573

Rep: Reputation: 59
The dajavu package was renamed. Check the changelog and CHANGES_AND_HINTS.txt for details. It could be a conflict between the old dejavu fonts package and the renamed one. Try removing both and reinstalling the new one. Haven't experienced this, luckily.

Also do you have a line in your ~/.gtkrc-2.0 file like this?

Code:
gtk-font-name="Bitstream Vera Sans 10"

Last edited by Eternal_Newbie; 03-17-2008 at 04:59 AM.
 
Old 03-17-2008, 05:07 AM   #3
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Original Poster
Rep: Reputation: Disabled
Yes i've tried the packaging stuff (about 55 times :P)

I've had "DejaVu Sans:style=Book 8" in my .gtkrc-2.0, needless to say i've tried changing that to all other fonts and they still don't work.
 
Old 03-17-2008, 09:20 AM   #4
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Original Poster
Rep: Reputation: Disabled
Okay seriously...

Another reinstall (i didn't even install the old dejavu this time), more countless reboots during which everything was perfectly fine.

I turned the computer off then on, and the fonts just disappeared again..

What kind of a computer error is this?

Last edited by pdw_hu; 03-17-2008 at 09:26 AM.
 
Old 03-17-2008, 10:58 AM   #5
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Original Poster
Rep: Reputation: Disabled
Quote:
I've downgraded X to 1.3 (with the necessary xorg-intel, xf86-input-keyboard and mouse downgrades), and it seems after turn off/on-s and reboots that it's okay now.

I still don't understand what went wrong, and also why did it only came up for me...
So it now seems solved... Hope it stays
Seriously.... What the f*ck is going on?
I doesn't work again...

Last edited by pdw_hu; 03-18-2008 at 09:58 AM.
 
Old 03-20-2008, 12:42 PM   #6
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Original Poster
Rep: Reputation: Disabled
Quote:
Well I've manually upgraded the fontconfig-2.4.2 package to the latest 2.5.91, and my problem seems to go away (again...) so far.
Nevermind this again, it still isn't okay :/

Last edited by pdw_hu; 03-21-2008 at 01:16 AM.
 
Old 03-25-2008, 11:13 AM   #7
pdw_hu
Member
 
Registered: Nov 2005
Location: Budapest, Hungary
Distribution: Slackware, Gentoo
Posts: 346

Original Poster
Rep: Reputation: Disabled
Okay, so now it seems: intel driver: do not enable FramebufferCompression.
I really hope this was the cause.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Black menu backgrounds in GTK apps after upgrading to -current patrokov Slackware 2 02-20-2006 12:42 AM
GTK 1 apps Fonts problems on KDE tpe SUSE / openSUSE 0 05-11-2005 12:41 PM
Non-readable fonts in GTK apps Clojster Debian 2 12-05-2004 04:11 AM
How to set Gtk fonts apps running on KDE ? nooky59 Mandriva 3 04-09-2004 09:12 AM
GTK apps fonts size too big in Debian hstang Linux - General 0 05-13-2003 10:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration