LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-08-2016, 07:52 AM   #1
maew
LQ Newbie
 
Registered: Feb 2016
Posts: 9

Rep: Reputation: Disabled
Internal Compiler Error trying to compile qt5 and PyQt5


Hello all,

The issue was overheating.

I am experimenting with freeslack on Librem 15,
It's a fresh install, slackpkg upraded-it-all (using freeslack's mirror). Trying to get qutebrowser I went on compiling most of the dependencies from SBo repositories.
I first had a segmentation fault compiling qt5. and went around it using AlienBob's build. Same story with qt5-webkit.
Now I am trying to compile PyQt5 and I got the following:

Code:
In file included from /usr/include/c++/5.3.0/bits/basic_ios.h:37:0,
                 from /usr/include/c++/5.3.0/ios:44,
                 from /usr/include/c++/5.3.0/ostream:38,
                 from /usr/include/c++/5.3.0/iterator:64,
                 from /usr/include/qt5/QtCore/qbytearray.h:53,
                 from /usr/include/qt5/QtCore/qmetatype.h:46,
                 from /usr/include/qt5/QtCore/QMetaType:1,
                 from sipAPIQtLocation.h:30,
                 from sipQtLocationQPlaceIdReply.cpp:24:
/usr/include/c++/5.3.0/bits/locale_facets.h:1587:75: internal compiler error: Illegal instruction
     _S_format_float(const ios_base& __io, char* __fptr, char __mod) throw();
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
Makefile:820: recipe for target 'sipQtLocationQPlaceIdReply.o' failed
make[1]: *** [sipQtLocationQPlaceIdReply.o] Error 1
make[1]: Leaving directory '/tmp/SBo/PyQt5_gpl-5.6/QtLocation'
Makefile:1457: recipe for target 'sub-QtLocation-make_first-ordered' failed
make: *** [sub-QtLocation-make_first-ordered] Error 2
Also I compiled python3-sip from slackbuilds.

I am not sure where the issue could come from.
QMake version 3.0
Using Qt version 5.7.0 in /usr/lib64

Any ideas?

Thank you for your time

Last edited by maew; 11-09-2016 at 06:39 AM.
 
Old 11-08-2016, 08:17 AM   #2
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 873

Rep: Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756
Hello,

According to this thread, this might be an hardware issue.

--
SeB
 
Old 11-08-2016, 08:26 AM   #3
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,316

Rep: Reputation: Disabled
What CPU are you using, is it in a virtual machine?
 
Old 11-08-2016, 08:34 AM   #4
maew
LQ Newbie
 
Registered: Feb 2016
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by phenixia2003
According to this thread, this might be an hardware issue.
So it could be that the hardware is defectuous...

Quote:
Originally Posted by Emerson View Post
What CPU are you using, is it in a virtual machine?
Code:
bash-4.3# lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 61
Model name:            Intel(R) Core(TM) i7-5557U CPU @ 3.10GHz
...
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch ida arat epb pln pts dtherm intel_pt tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid rdseed adx smap xsaveopt
It's not on a virtual machine, it is on a laptop.

Last edited by maew; 11-08-2016 at 08:39 AM.
 
Old 11-08-2016, 08:48 AM   #5
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,316

Rep: Reputation: Disabled
It is a long shot, but do you load CPU microcode at the boot?
 
Old 11-08-2016, 08:51 AM   #6
maew
LQ Newbie
 
Registered: Feb 2016
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Emerson View Post
It is a long shot, but do you load CPU microcode at the boot?
I have no idea how to check that.. :s
 
Old 11-08-2016, 09:00 AM   #7
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,316

Rep: Reputation: Disabled
Never mind then, if you retry the build, do you get the exact same error in exactly same place?
 
Old 11-08-2016, 09:21 AM   #8
maew
LQ Newbie
 
Registered: Feb 2016
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Emerson View Post
Never mind then, if you retry the build, do you get the exact same error in exactly same place?
It's compiling, will tell you when it gets there
 
Old 11-08-2016, 09:25 AM   #9
maew
LQ Newbie
 
Registered: Feb 2016
Posts: 9

Original Poster
Rep: Reputation: Disabled
No. That went faster than expected..
Code:
In file included from /usr/include/c++/5.3.0/random:42:0,
                 from /usr/include/c++/5.3.0/bits/stl_algo.h:66,
                 from /usr/include/c++/5.3.0/algorithm:62,
                 from /usr/include/qt5/QtCore/qglobal.h:94,
                 from /usr/include/qt5/QtCore/qmetatype.h:44,
                 from /usr/include/qt5/QtCore/QMetaType:1,
                 from sipAPIQtCore.h:30,
                 from sipQtCoreQResource.cpp:24:
/usr/include/c++/5.3.0/limits:1734:10: internal compiler error: Segmentation fault
        = round_to_nearest;
          ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
Makefile:2128: recipe for target 'sipQtCoreQResource.o' failed
make[1]: *** [sipQtCoreQResource.o] Error 1
make[1]: Leaving directory '/tmp/SBo/PyQt5_gpl-5.6/QtCore'
Somewhere in the compil output it says : The Python dbus module doesn't seem to be installed.
could that be a reason to fail the compil?

EDIT2:
tried again:
/usr/include/c++/5.3.0/limits:1659:10: internal compiler error: Segmentation fault
= round_to_nearest;
^

Last edited by maew; 11-08-2016 at 09:29 AM.
 
Old 11-08-2016, 09:51 AM   #10
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,316

Rep: Reputation: Disabled
Hardware overheating.
 
Old 11-08-2016, 09:54 AM   #11
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 873

Rep: Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756
Hello,

Quote:
Originally Posted by maew View Post
No. That went faster than expected..
Code:
In file included from /usr/include/c++/5.3.0/random:42:0,
                 from /usr/include/c++/5.3.0/bits/stl_algo.h:66,
                 from /usr/include/c++/5.3.0/algorithm:62,
                 from /usr/include/qt5/QtCore/qglobal.h:94,
                 from /usr/include/qt5/QtCore/qmetatype.h:44,
                 from /usr/include/qt5/QtCore/QMetaType:1,
                 from sipAPIQtCore.h:30,
                 from sipQtCoreQResource.cpp:24:
/usr/include/c++/5.3.0/limits:1734:10: internal compiler error: Segmentation fault
        = round_to_nearest;
          ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
Makefile:2128: recipe for target 'sipQtCoreQResource.o' failed
make[1]: *** [sipQtCoreQResource.o] Error 1
make[1]: Leaving directory '/tmp/SBo/PyQt5_gpl-5.6/QtCore'
I suggest you to check your cpu temperature. In the bios for instance or by running the command below :
Code:
$ sensors
If you get this message :
Code:
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.
as root, run the command modprobe coretemp, then re-run the command sensors

if you get the same message as earlier, then, run, as root, the command sensors-detect and validate default answer to each question. At the end, it will give you a list of command as below :
Code:
#----cut here----
# Chip drivers
modprobe coretemp
modprobe <module-specific-to-your-computer>
/usr/bin/sensors -s
#----cut here----
At this point, run, as root, each of the commands that sensors-detect has returned, and run the command sensors, which should give you something like that :
Code:
$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +35.0C  (high = +85.0C, crit = +105.0C)
Core 0:         +30.0C  (high = +85.0C, crit = +105.0C)
Core 1:         +33.0C  (high = +85.0C, crit = +105.0C)
Core 2:         +30.0C  (high = +85.0C, crit = +105.0C)
Core 3:         +34.0C  (high = +85.0C, crit = +105.0C)
P.S: The best would be to run sensors before and after compilation.

--
SeB
 
Old 11-08-2016, 10:03 AM   #12
maew
LQ Newbie
 
Registered: Feb 2016
Posts: 9

Original Poster
Rep: Reputation: Disabled
I'll let the computer cool a bit and run the sensors test before and after.. from what I have seen, during compilation the temperature oscilates between 72C and 80C
 
Old 11-08-2016, 11:00 AM   #13
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,316

Rep: Reputation: Disabled
CPU is just one part that can overheat. 80 C is rather hot, I do not let my laptop go over 70 C. I switch over to powersave governor to keep the temperature down when needed.
 
Old 11-09-2016, 04:48 AM   #14
maew
LQ Newbie
 
Registered: Feb 2016
Posts: 9

Original Poster
Rep: Reputation: Disabled
I didn't know till now but it already is in governor powersave

Code:
root@slackship:/# cat /sys/devices/system/cpu/cpufreq/policy?/scaling_governor 
powersave
powersave
powersave
powersave
Actually I just tried to compile again and even with the CPU's at 55C I just got
/usr/include/c++/5.3.0/limits:1809:13: internal compiler error: Segmentation fault
round_to_nearest;

EDIT: trying again with an icepack under the laptop...

Last edited by maew; 11-09-2016 at 05:01 AM.
 
Old 11-09-2016, 05:04 AM   #15
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,316

Rep: Reputation: Disabled
It is a little confusing, newer Intel processors are handled differently. Powersave actually acts as ondemand. Check it out with cpupower utility.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
g++ 2.9-gnupro-98r2 ,error: Internal compiler error anums Linux - Newbie 1 08-29-2016 07:47 PM
internal compiler error tadek Linux - Software 4 10-07-2008 05:05 PM
internal compiler error? semaphore Linux - Newbie 3 03-10-2004 12:15 PM
internal compiler error on everything i do tearabite Mandriva 3 02-02-2004 07:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration