-   Slackware (
-   -   Intel video problem in slackware current (

jcamez 08-09-2009 10:00 PM

Intel video problem in slackware current
Hi Guys:
Hope somebody can help me.
I installed slackware current because itīs RC2 and i want to try KDE4,
but after upgrading i canīt start X, the system freezes in the splash
screen of KDE and nothing but the mouse respond, so i have to make a
hard reboot.
I knew about the problems with the new Intel Driver and the new
version of X server that slack current ships but i thought tha because
it was RC2 things had got better.
Anyway i have tried all the versions of the intel driver slackware
current ships but still no joy. Both with an xorg.conf or without it
as indicated on the CHANGES_AND_HINTS file.
Anyone knows how to correct this?? can i use the driver shipped with
slack 12.2?? I really donīt want to go back to 12.2 now that i am on
My card it's an Intel 82865G, and i have to use the VESA driver in
order to start x.
Any hints???

Joel Camez.

willysr 08-09-2009 11:47 PM

how do you upgrade your box?
manually or using slackpkg?
Have you merged the new .conf files?

jcamez 08-10-2009 01:12 AM


thanks for replying.
i downloaded the slackware and extra folders to my hd and yes i have replaced all the *.new files.

Joel Camez

bonaire 08-10-2009 02:02 AM

Would you publish/read the log file (/var/log/Xorg.log) please.
Do you still use a xorg.conf file?


willysr 08-10-2009 03:56 AM

have you upgraded all the packages in x/ directory?
I think you will need latest mesa, libdrm, xorg-server-* and several other packages to use the latest Intel driver

cowyn 08-10-2009 10:49 AM

Make sure hald is running.
Xorg.conf is not necessary any more. But you may keep your specializations there still.

gegechris99 08-10-2009 03:19 PM

Just to make sure,

Did you follow the following instruction from CHANGES_AND_HINTS.TXT ?


Due to the upgrade of kde from 3.5.10 to 4.2.4, you will need to move your
existing $HOME/.kde/ out of the way (either completely remove it or back
it up somewhere else if you think you might need it again for whatever
reason); otherwise, you will almost surely experience odd configuration
problems with kde applications.

jcamez 08-17-2009 03:54 PM

2 Attachment(s)
Hi Guys:
Sorry for responding late but i had to go out...
I have followd the steps indicated in CHANGES_AND_HINTS but still no luck:
Here are the logs for X with and without an xorg.conf. hope somebody can help me because i am totally lost by now.
Thanks in advance.

bonaire 08-18-2009 02:29 AM


first I'd like to say is, that i really don't know what's exactly wrong here, but i have maybe a similar problem. I currently believe, that hal could be the problem.

Please publish your /var/log/kdm.log
While/after the Server crashed, press alt+print+r and then alt+print+e. What happens then?
Try to boot into runlevel 3, login as root and execute init 4. Does this work?


jcamez 08-18-2009 12:04 PM

2 Attachment(s)
Hi bonaire:
I started in telinit 3 and executed init 4, kdm starts ok but accepts no input. i did alt+print+r and alt+print+e and kdm restarts but still accept no inputs.
I attached kdm.log and xorg log
Hope you find something useful.
The only thing i noticed is that when a do telinit 4 hal tries to load i810 driver, and when i try to startx hal tries to load intel driver..

bonaire 08-18-2009 01:47 PM


the messages are slightly different to my problem, but the symptoms are the same, so we can give it a try. In my case the problem was my attached keyboard (Cherry G230).

Is it correct, that your xorg.conf uses the following options?


Section "ServerLayout"
        Identifier        "Slackware"
        Screen        0        "internalscreen"        0 0
        Screen        1        "externalscreen"        0 0
        InputDevice        "Mouse0"                "CorePointer"
        InputDevice        "Keyboard"                "CoreKeyboard"

Section "InputDevice"
        Identifier        "Keyboard"
        Driver                "kbd"
        Option                "XkbModel"        "pc105"
        Option                "XkbLayout"        "de"
        Option                "XkbVariant"        "nodeadkeys"

Section "InputDevice"
        Identifier        "Mouse0"
        Driver                "mouse"
        Option                "Protocol"        "auto"
        Option                "Device"        "/dev/input/mice"
        Option                "ZAxisMapping"        "4 5 6 7"

Section "Files"
        ModulePath  "/usr/lib/xorg/modules"
        FontPath    "/usr/share/fonts/TTF"
        FontPath    "/usr/share/fonts/OTF"
        FontPath    "/usr/share/fonts/Type1"
        FontPath    "/usr/share/fonts/misc"
        FontPath    "/usr/share/fonts/75dpi/:unscaled"
        FontPath    "/usr/share/fonts/100dpi/:unscaled"
        FontPath    "/usr/share/fonts/75dpi"
        FontPath    "/usr/share/fonts/100dpi"
        FontPath    "/usr/share/fonts/cyrillic"

Section "ServerFlags"
        Option        "AllowMouseOpenFail"        "false"
        Option        "BlankTime"                "5"
        Option        "DontVTSwitch"                "false"
        Option        "AIGLX"                        "true"
        Option        "AllowEmptyInput"        "true"
        Option        "AutoAddDevice"                "true"
        Option        "AutoEnableDevices"        "true"

        Option        "UseDefaultFontPath"        "false"

If yes, set

        Option        "AllowEmptyInput"        "false"
        Option        "AutoAddDevice"                "false"
        Option        "AutoEnableDevices"        "false"

and check what happens. Is the startup normal? (In my case, this lead to a normal startup, but keys where remapped. Down key had function of return key and such crazy stuff.)

If it starts up normal, and you have such a problem like me with the key-bindings. You could try to set the Options back to true and copy a modified version of /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi to /etc/hal/fdi/policy/10-keymap.fdi.

I am really not sure, if it helps you, but it worked in my case. If it won't help, I have no idea, what is wrong.

Edit: Of course you need to restart hal, if you copy the keymap.fdi file. Another way to check, if the keyboard is the problem, is disconnecting it, until X is fully startet and then attach it.

Good luck and cu

jcamez 08-19-2009 07:26 PM

Hi bonaire:
Check this.
itīs in this link:

"I hate to say this, but it appears as if the 82865 chipsets are simply not going to work with 13.0 :/ There's nothing we can do about it either, it seems -- there have been numerous reports of it not working, and I can't find any indication of anything we're doing wrong. If someone has the inclination the bring it up on the xorg mailing list, feel free - I'm subscribed there, so I'll participate as needed.
Robby Workman

bonaire 08-19-2009 08:42 PM

What does this mean, you tried my suggestions?

jcamez 08-19-2009 10:53 PM

I tried them all but still no luck. In fact i already had the 3 options set to false in xorg.conf.
With the kde loads but after it loads the desktop it freezes.
Starting in telinit 3 and then telinit 4, kdm starts but accepts no inputs.
I will continue to play with xorg.conf to see if i can make it work...
Have you had some succes???

Thanks for the help...

bonaire 08-19-2009 11:34 PM

I had similiar problems with another intel-chipset, and the steps i suggested helped in my case.

Compositing is disabled in xorg.conf?
I still believe, it is a problem with HAL.

Good luck.

All times are GMT -5. The time now is 09:05 AM.