LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-10-2016, 01:51 PM   #1
porkynator
LQ Newbie
 
Registered: Jun 2016
Location: Belluno, Italy
Posts: 8

Rep: Reputation: Disabled
Intel Audio Driver Problem (Slackware 14.2)


Greetings slackers,
I have installed Slackware 14.2 in dual boot with Ubuntu 14.04 last summer, but only recently I have discovered a little problem regarding audio I/O. The computer is a Gazelle laptop by System76 bought in February 2014, shipping with Ubuntu by default, which didn't have any such problem.

The problem itself only appears every 7/8 reboots on average. It is independent of the WM/DE chosen and it stays until further reboot. When the problem appears, no audio plays from the speakers, though it plays from headphones, if I plug them. Opening pavucontrol (or arecord) shows that the microphone doesn't work either. Everything seems to work fine when te problem is not present (which is the majority of times).
I have tried copying some "/etc/modprobe.d/*.conf" from the Ubuntu installation (though only the ones that seemed related to audio drivers) but nothing changed.
I think both Ubuntu and the vendor (System76) patch the kernel in some way. The company only supports Ubuntu, no other distros.

Output of lspci | grep Audio
Code:
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)
Output of lsmod | grep snd
Code:
snd_hda_codec_hdmi     39395  1
snd_hda_codec_via      13161  1
snd_hda_codec_generic    61189  1 snd_hda_codec_via
snd_hda_intel          29467  10
snd_hda_codec         108205  4 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_codec_generic,snd_hda_intel
snd_seq_dummy           1762  0
snd_hda_core           52370  5 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep               6656  1 snd_hda_codec
snd_pcm_oss            38134  0
snd_mixer_oss          14566  1 snd_pcm_oss
snd_pcm                92802  8 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
snd_seq_oss            29180  0
snd_seq_midi            5645  0
snd_seq_midi_event      6720  2 snd_seq_oss,snd_seq_midi
snd_rawmidi            21571  1 snd_seq_midi
snd_seq                53182  6 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy,snd_seq_midi
snd_seq_device          4417  4 snd_seq,snd_rawmidi,snd_seq_oss,snd_seq_midi
snd_timer              22109  2 snd_pcm,snd_seq
snd                    69051  31 snd_pcm_oss,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_via,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_oss,snd_seq_device,snd_mixer_oss
soundcore               6876  1 snd
Both commands were executed when the problem was present. I may post the output of the same commands from Ubuntu or from when the problem is not present, or anything else you think can be useful.

All .conf files in /etc/modprobe.d (I am not 100% sure, but I think all of them are copied from Ubuntu)
alsa-base.conf
Code:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
blacklist-from-ubuntu.conf
Code:
# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# causes failure to suspend on HP compaq nc6000 (Ubuntu: #10306)
blacklist i2c_i801

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.
blacklist amd76x_edac
blacklist-oss-ubuntu.conf
Code:
blacklist ac97
blacklist ac97_codec
blacklist ac97_plugin_ad1980
blacklist ad1848
blacklist ad1889
blacklist adlib_card
blacklist aedsp16
blacklist ali5455
blacklist btaudio
blacklist cmpci
blacklist cs4232
blacklist cs4281
blacklist cs461x
blacklist cs46xx
blacklist emu10k1
blacklist es1370
blacklist es1371
blacklist esssolo1
blacklist forte
blacklist gus
blacklist i810_audio
blacklist kahlua
blacklist mad16
blacklist maestro
blacklist maestro3
blacklist maui
blacklist mpu401
blacklist nm256_audio
blacklist opl3
blacklist opl3sa
blacklist opl3sa2
blacklist pas2
blacklist pss
blacklist rme96xx
blacklist sb
blacklist sb_lib
blacklist sgalaxy
blacklist sonicvibes
blacklist sound
blacklist sscape
blacklist trident
blacklist trix
blacklist uart401
blacklist uart6850
blacklist via82cxxx_audio
blacklist v_midi
blacklist wavefront
blacklist ymfpci
blacklist ac97_plugin_wm97xx
blacklist ad1816
blacklist audio
blacklist awe_wave
blacklist dmasound_core
blacklist dmasound_pmac
blacklist harmony
blacklist sequencer
blacklist soundcard
blacklist usb-midi
snd-hda-intel.conf
Code:
options snd-hda-intel model=auto
Any help is appreciated. I will try any non-invasive suggestion (e.g. temporary file edits) as soon as I can, but for more invasive things (e.g. update the kernel, install drivers) I may want to wait until I have some more spare time.
 
Old 11-11-2016, 11:04 PM   #2
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,551

Rep: Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498
Do you have any logs or error messages when the problem occurs?
 
Old 11-12-2016, 01:59 PM   #3
porkynator
LQ Newbie
 
Registered: Jun 2016
Location: Belluno, Italy
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
Do you have any logs or error messages when the problem occurs?
I don't see any message, even if I launch audio-related programs (pavucontrol, firefox) from the terminal. Which log files should I look for?
 
Old 11-12-2016, 05:27 PM   #4
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,551

Rep: Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498
Check your dmesg and /var/log/syslog to start.
 
Old 11-13-2016, 12:55 PM   #5
porkynator
LQ Newbie
 
Registered: Jun 2016
Location: Belluno, Italy
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
Check your dmesg and /var/log/syslog to start.
In attachment the full output of dmesg and the last part of /var/log/syslog right after boot. The "_ok" versions are from when the problem is not present.
I see a difference in the dmesg output: dmesg | grep audio gives
Code:
[    6.394568] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    6.396368] snd_hda_codec_via hdaudioC1D0: autoconfig for VT1802: line_outs=1 (0x24/0x0/0x0/0x0/0x0) type:speaker
[    6.396370] snd_hda_codec_via hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    6.396371] snd_hda_codec_via hdaudioC1D0:    hp_outs=1 (0x25/0x0/0x0/0x0/0x0)
[    6.396372] snd_hda_codec_via hdaudioC1D0:    mono: mono_out=0x0
[    6.396373] snd_hda_codec_via hdaudioC1D0:    inputs:
[    6.396374] snd_hda_codec_via hdaudioC1D0:      Mic=0x2b
[    6.396376] snd_hda_codec_via hdaudioC1D0:      Internal Mic=0x29
when there is the problem, while the output is
Code:
[    6.437413] snd_hda_codec_via hdaudioC1D0: autoconfig for VT1802: line_outs=1 (0x24/0x0/0x0/0x0/0x0) type:speaker
[    6.437419] snd_hda_codec_via hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    6.437425] snd_hda_codec_via hdaudioC1D0:    hp_outs=1 (0x25/0x0/0x0/0x0/0x0)
[    6.437429] snd_hda_codec_via hdaudioC1D0:    mono: mono_out=0x0
[    6.437432] snd_hda_codec_via hdaudioC1D0:    inputs:
[    6.437438] snd_hda_codec_via hdaudioC1D0:      Mic=0x2b
[    6.437443] snd_hda_codec_via hdaudioC1D0:      Internal Mic=0x29
[    7.672697] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
when there is no problem. It looks the same, except the first line is at the end. Is it possibly related to the problem?

syslog.txt

syslog_ok.txt

dmesg.txt

dmesg_ok.txt
 
Old 11-13-2016, 03:57 PM   #6
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,551

Rep: Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498
My only thought is maybe the snd_hda_intel driver needs to be loaded before snd_hda_codec_via, but I'm not sure the best way to do that. Maybe try blacklisting them and then loading them manually in your rc.local?
 
Old 11-14-2016, 04:09 AM   #7
porkynator
LQ Newbie
 
Registered: Jun 2016
Location: Belluno, Italy
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
My only thought is maybe the snd_hda_intel driver needs to be loaded before snd_hda_codec_via, but I'm not sure the best way to do that. Maybe try blacklisting them and then loading them manually in your rc.local?
(Maybe you meant the other way round?)

Thanks for your reply. I have tried blacklisting snd_hda_intel and loading it in rc.local with modprobe snd_hda_intel, but after a couple of reboots the problem appeared. I have also tried the other way round (blacklisting snd_hda_codec_via and loading it in rc.local), which if the idea was correct should make the problem appear, but the first time I booted averything was fine. So the order of the modules is not the problem.

Anyways, thanks again for your help.
 
Old 11-14-2016, 08:56 AM   #8
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,551

Rep: Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498
Quote:
Originally Posted by porkynator View Post
(Maybe you meant the other way round?)
No, I did mean it the way I posted. In your post, your log showed that the issue occured on the machine that had the snd_hda_intel driver loaded after the snd_hda_codec_via.

Quote:
Originally Posted by porkynator View Post
Thanks for your reply. I have tried blacklisting snd_hda_intel and loading it in rc.local with modprobe snd_hda_intel, but after a couple of reboots the problem appeared. I have also tried the other way round (blacklisting snd_hda_codec_via and loading it in rc.local), which if the idea was correct should make the problem appear, but the first time I booted averything was fine. So the order of the modules is not the problem.
Maybe don't add the modprobe for snd_hda_codec_via in your rc.local. Then, once you log in, check and see if it was loaded. Even if something is blacklisted, it can still sometimes be loaded. However, if it is loading it while blacklisted, I'm not sure what would need to be done to prevent that.

Did you happen to check your dmesg to see if it stayed the same after your changes?
 
Old 11-15-2016, 08:54 AM   #9
porkynator
LQ Newbie
 
Registered: Jun 2016
Location: Belluno, Italy
Posts: 8

Original Poster
Rep: Reputation: Disabled
Yes, I have checked dmesg and he blacklist + modprobe trick forced the loading order correctly. But it seems the problem is unrelated to the order the modules load.

I have tried blacklisting snd_hda_codec_via without loading it and it seems that snd_hda_codec_generic is loaded instead.
sudo dmesg | grep audio gives:
Code:
[    6.222857] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    6.228130] snd_hda_codec_generic hdaudioC1D0: autoconfig for Generic: line_outs=1 (0x24/0x0/0x0/0x0/0x0) type:speaker
[    6.228131] snd_hda_codec_generic hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    6.228132] snd_hda_codec_generic hdaudioC1D0:    hp_outs=1 (0x25/0x0/0x0/0x0/0x0)
[    6.228132] snd_hda_codec_generic hdaudioC1D0:    mono: mono_out=0x0
[    6.228133] snd_hda_codec_generic hdaudioC1D0:    inputs:
[    6.228134] snd_hda_codec_generic hdaudioC1D0:      Mic=0x2b
[    6.228135] snd_hda_codec_generic hdaudioC1D0:      Internal Mic=0x29
I have tried rebooting a couple of times and the problem doesn't seem to appear (the microphone works, but I cannot check the speakers now - I am in a library). It may still be that I was lucky and the problem didn't show up. I will try again later this afternoon, maybe this is a solution.
 
Old 11-15-2016, 01:11 PM   #10
porkynator
LQ Newbie
 
Registered: Jun 2016
Location: Belluno, Italy
Posts: 8

Original Poster
Rep: Reputation: Disabled
Backlisting snd_hda_codec_via makes microphone and speakers work, but mutes headphones.

Anyways, I think I have solved the problem.
The TL;DR version of the story is: I messed with configuration files long ago, and I forgot to restore them afterwards. Sorry for wasting your time.
The longer story follows.
I have found this post and thought that maybe it was a pulseaudio problem.
I mainly use a window manager (dwm) with a self-made startup file. After installing Slackware, I had some other troubles with audio. I tried adding start-pulseaudio-x11 to the startup file, which didn't solve the problem. Then I solved the problem by copying other config files from Ubuntu (in /etc/modprobe.d) and forgot about adding that line (which didn't cause problems in the majority of cases). Removing that line seems to do the job. When I said that the problem was independent of the window manager used, I was wrong: I have only tried xfce a couple o times after loading dwm, which apparently caused the problem.
I am not still 100% sure the problem was this, but let's say a good 90%.

Now, do I just put [SOLVED] before the title, or should I change it to make it meaningful for other people? After all, the problem isn't related to intel audio drivers.

Thanks again bassmadrigal, sorry for wasting your time.
 
Old 11-15-2016, 01:36 PM   #11
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,551

Rep: Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498
No worries. Anything working you through to solve a problem, whether self-inflicted or otherwise, isn't a waste of time

It's up to you on if you want to try and modify your subject line, but I don't think it's absolutely necessary. And to mark the thread as solved, there should be an option under the Thread Tools button on the top right corner of the thread, or a link above that that allows you to mark it as solved.

However, for any that might come across this post with a Google or forum search, can you post the offending line that you deleted?
 
Old 11-15-2016, 01:36 PM   #12
bassmadrigal
Senior Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 4,551

Rep: Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498Reputation: 2498
Stupid slow work computer... managed to do a double post without clicking twice.
 
Old 11-15-2016, 02:20 PM   #13
porkynator
LQ Newbie
 
Registered: Jun 2016
Location: Belluno, Italy
Posts: 8

Original Poster
Rep: Reputation: Disabled
Bad news: the problem isn't solved. I thought it was since I got everything working for like 12 times in a row (it usually doesn't happen). Now I rebooted and the problem is there again.
So we are at the starting point. I'll do some more research thinking of it as a pulseaudio problem. Any idea on which log files / error messages I should look for?
 
Old 11-15-2016, 02:55 PM   #14
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 777

Rep: Reputation: 592Reputation: 592Reputation: 592Reputation: 592Reputation: 592Reputation: 592
Hello,

Maybe this is not related, but in your dmesg, there's a message about your bios which seems to be broken, and, in /usr/src/linux/Documentation/sound/alsa/HD-Audio.txt there's the section called "codec-probing problem" with the following note :
Code:
On a machine with a broken BIOS, sometimes you need to force the
driver to probe the codec slots the hardware doesn't report for use.
In such a case, turn the bit 8 (0x100) of `probe_mask` option on.
Then the rest 8 bits are passed as the codec slots to probe
unconditionally.  For example, `probe_mask=0x103` will force to probe
the codec slots 0 and 1 no matter what the hardware reports.
Even if the symptoms you have are not the same as those specified in this section (ie. error message azx_get_response), you can try to set 'probe_mask' option to check if that solve your issue.

--
SeB
 
Old 11-15-2016, 03:27 PM   #15
porkynator
LQ Newbie
 
Registered: Jun 2016
Location: Belluno, Italy
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by phenixia2003 View Post
Hello,

Maybe this is not related, but in your dmesg, there's a message about your bios which seems to be broken, and, in /usr/src/linux/Documentation/sound/alsa/HD-Audio.txt there's the section called "codec-probing problem" with the following note :
Code:
On a machine with a broken BIOS, sometimes you need to force the
driver to probe the codec slots the hardware doesn't report for use.
In such a case, turn the bit 8 (0x100) of `probe_mask` option on.
Then the rest 8 bits are passed as the codec slots to probe
unconditionally.  For example, `probe_mask=0x103` will force to probe
the codec slots 0 and 1 no matter what the hardware reports.
Even if the symptoms you have are not the same as those specified in this section (ie. error message azx_get_response), you can try to set 'probe_mask' option to check if that solve your issue.

--
SeB
Thanks for the idea! I have tried adding "options snd_hda_intel probe_mask=1" to snd-hda-intel.conf, but it didn't work. Moreover, Ubuntu gives the same error/warning message about broken BIOS (and everything works).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
choosing an Audio Mixer; also, Loopback Driver for Audio Hardware on Slackware 14.1 zarb Linux - Hardware 2 09-18-2014 11:01 AM
Audio driver for Intel DQ35JO Motherboard rakesh_soni33 Linux - Hardware 2 11-10-2008 06:00 AM
Audio driver for Intel DQ35JO (RHEL5) rakesh_soni33 Linux - Newbie 0 06-10-2008 05:37 AM
no sound with alsa driver: Slackware 10.2, K2.6.16.5, intel AC97 audio drkstr Linux - Software 2 04-15-2006 04:57 PM
Intel Audio driver issue Josh328 Linux - Hardware 3 02-28-2006 06:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration