-   Slackware (
-   -   installpkg: where's the install??? (

synaptical 08-05-2003 11:30 PM

installpkg: where's the install???
i downloaded some precompiled slackware packages to install, cd to directory, su [passwd], did installpkg filename.tgz, output says it's installing the package, package description, executing install script, etc., then...nothing. i can't find a trace of the installed program anywhere. same has happened before with tgz files (tried using pkgtool, btw -- same results), but i was too busy and said screw it and just used source files from then on. but now i'd like to know how to install from tgz. what am i missing or doing wrong?

slakmagik 08-05-2003 11:41 PM

Sounds right to me. If you 'updatedb' and 'locate' and it isn't there, I don't know what's going on. Only thing I could figure was a bad package (and I have gotten one or two of those). Maybe try downloading from somewhere else? Or just get checkinstall and compile from source. I can't figure anything about that that doesn't make it the best of both worlds - your very own Slackware package. :)

Maybe try 'installpkg -warn fooapp' which will display what installpkg *would* do. Maybe you can see something wrong in that.

carboncopy 08-05-2003 11:45 PM

Usually in a "package" especially a slackware specific package, there is a script inside telling where each of the files should go. To know more about where and what has been installed. Run pkgtool in the console, choose View, and choose the specific package which you want to know about.

If you want to run the program which you have installed, checked whether it is in /bin (highly unlikely) /usr/bin, /usr/local/bin, or sbin equivalent. If there is a file copied to one of those path. Then you can invoke (run the prog) by just typing the file (prog name). For example: gs.

synaptical 08-05-2003 11:46 PM

i did updatedb and locate (also whereis, which, find / -name foo ), and came up with nothing. it's always happened with tgz packages. i'll try the -warn option, see what that says, thanks.

could the installpkg tool (or tools) themselves be messed up or something? corrupted or bad from the start, or missing dependencies if that's possible? maybe i should try to make a package and see what happens. ?

slakmagik 08-05-2003 11:50 PM

If it doesn't happen all the time, I wouldn't think anything was wrong with the pkgtools. carboncopy's got it. I must be brain-dead. I was trying to remember how to redirect a stream to tell you what the script was doing when it seemed to be doing nothing - something like 'command 2>&1' or something. Anway - that would still be helpful if installpkg *was* doing something wrong but you can at least see if the package's script is doing something goofy by following carboncopy's post..

synaptical 08-06-2003 12:12 AM

using pkgtool viewer, it seems to be truncating the path to r/bin, r/local/bin, etc. instead of /usr/bin, etc. i don't know if that's just a rendering problem in the console or a problem with the installer. however, there is no evidence of any man files in the given paths, either.

when i tried uninstalling the packages using removepkg, for each file it said:

/r/path/path/ no longer exists. Skipping.

:confused: [edit: or is it supposed to say that?] pkgtool uninstalled them, though, wtf? esp. with the pkgtool viewer output i would think it was a bad package (what is that /r/ ? root?), but like i said it's happened every time with tgz files. wish i could remember the other ones i tried, but it was a couple of weeks ago.

anyway, i've removed all these latest with pkgtool, and tomorrow i'm going to try to find some other tgz files to test. maybe it was just a coincidence with a couple of bad packages, or maybe something with my system is messed up. thx.

carboncopy 08-06-2003 02:29 AM

You can download the dropline installer to try.
A very small package.

synaptical 08-06-2003 09:51 PM

i already had dropline installed, so i tried a couple of other packages instead:

+ wished: it installed into / directory, wouldn't run (found out later it was written in tcl/tk, tho, and i remember i didn't install that w/slack -- maybe that's why)
+ kcoloreditor: installed same place, but wouldn't run -- no binary to be found in directory or anywhere on system
+ cooledit: worked! :D
+ (original pkg was flightgear and the support pkgs, btw)

so the pkgtools are okay, maybe my system just isn't configed properly for some of these programs. i'll keep testing, though now i am on a security learning spree (shutting down all my daemons, rc.inet, etc. :D ) so i'm not going to worry too much about tgz now since w/some packages it does work. thanks for the help and input. :)

All times are GMT -5. The time now is 09:19 AM.