-   Slackware (
-   -   Installpkg question (

BittaBrotha 05-28-2003 12:34 AM

Installpkg question
I'm using Slack 9.0 and tried installing Gaim.tgz using installpkg command. Everything went fine until I tried starting it from the /home/user directory, then I got error message about missing a lib file. I don't have the name now but can get it later.

Anyway, I read someplace that you should start Installpkg command from the root directory, is this true? And if it is true, should the tgz file be in the root directory also.


fsbooks 05-28-2003 12:51 AM

Slackware does not check for dependencies during installation. Given the name of the file/library that is missing however, it is trivial to determine what you need to install. Without the name, well, that is another problem. It wouldn't be that you are missing, would it? That is Question #2 on the FAQ found through the gaim home page ( ).

I have not found it makes a bit of difference where I install the packages from. I usually cp the desired packages to a directory within temp so I only get the choice of the packages I want.

BittaBrotha 05-28-2003 01:05 AM

Thnx for reply. I'm at work now so I can't lookup the missing file name now but it does seem very close to it if thats not it.

Well I've installed Gaim using source with Slack 8.0, Debian 3.0 and neva had any problems with it running. I never used installpkg before and decided to try it out and this is what happen.

I may just get the source and try that out.

fsbooks 05-28-2003 01:57 AM

Gaim is one of those packages I keep updated with cvs and build myself (like abiword, gtk-gnutella, gnumeric, mozilla). It changes so fast that it just makes sense. Of course, some days it doesn't build, but that is a hazard of the development version. Then I drop back to a previous version.

All times are GMT -5. The time now is 05:34 PM.