-   Slackware (
-   -   Installing XP200 scanner (

waddles 06-27-2013 12:33 AM

Installing XP200 scanner
I have downloaded the Epson XP-200 scanner files that go with the printer but not sure of how I should proceed exactly. There is a and .in, a configure and along with, iscan-data.spec, and the install-sh files for the data package which has to be installed first. I am not sure which of the configure files I should run nor the Makefiles. I am not sure after viewing the install file where the spec files fit in.
I am guessing that this is a configure, make, make install setup.
Here is the listing for the data package:

COPYING                  SUPPORTED-DEVICES  device              missing
KNOWN-PROBLEMS          aclocal.m4              epkowa.desc      policy  bootstrap              fs-blacklist          configure              include              scsi      install-sh
NEWS                  debian              iscan-data.spec  usb.xsl

Since this is the file set for non-LSB I wonder why the rpm file?
Any ideas on processing this file set for my Slackware 13.37?

camorri 06-27-2013 08:44 AM

There is a .tar.gz file for your scanner at this link:


I downloaded it, there is a README file and instructions on how to compile in an INSTALL file.

I would not suggest you try to install the .rpm version. Slack does have rpm tools, I suspect you could try to install it with those tools, however, my experience was not so good using this method. Anything you install this way will not be seen by slackpkg.

waddles 06-27-2013 10:24 AM

Thanks Cliff, when I got to that link I discovered the data package was newer that the one I pulled down 2 days ago so thanks for that.

How did U install the scanner files? I know the data package .tar.gz is installed before the core package. Was I correct about doing configure, make, make install? But which configure? there are 2. Likewise for the Makefile in the data .tar.gz.

camorri 06-27-2013 12:22 PM


How did U install the scanner files?
See the instructions in the README file. If you want to use the .rpm file, the README suggest:


# rpm --upgrade iscan-$version-$release.$architecture.rpm
If you look in the INSTALL file, these are the instrucitons.


Basic Installation

Briefly, the shell commands `./configure; make; make install' should
configure, build, and install this package. The following
more-detailed instructions are generic; see the `README' file for
instructions specific to this package.
There is more if you read the files. Hope this helps.

waddles 06-27-2013 05:33 PM

OK I have found the proper configure, make, make install sequence for installing the data then core for the scanner.
When I installed the printer driver I used prefix to keep the driver in /opt/EPSON/PRNTDRVR and then at the end cd'd to /usr/cups/filter and used ln -s /opt/EPSON/PRNTDRVR/lib/cups/filter/epson-* .
That evoked a queries of whether to replace ./epson-escpr and then ./epson-escpr-wrapper to which I answered affirmatively.

Is it necessary to again replace .epson-escpr*'s when installing the scanner (it is saved in /opt/EPSON/SCANDRVR)?? Since this is the scanner I am not sure why I am getting the repeat of the queries for "...escpr..." ??

camorri 06-27-2013 07:38 PM


Is it necessary to again replace .epson-escpr*'s when installing the scanner (it is saved in /opt/EPSON/SCANDRVR)?? Since this is the scanner I am not sure why I am getting the repeat of the queries for "...escpr..." ??
Sorry, I can not help much more. I don't have this scanner. Possibly someone with more experience compiling the driver can help.

ljb643 06-27-2013 07:45 PM

That's odd. The scanner driver includes the CUPS filter, for printing? I realize it is an all-in-one, but that doesn't make sense to me. Maybe I'll download it and take a look. (My own Epson scanner is old enough that it works out-of-the box with sane and Gimp - no need for Epson drivers.)

waddles 06-28-2013 12:33 AM

Installing XP200 scanner
Thanks, appreciate the help, I would look but am not sure which files to look at as U can see from my post above where the data package has several like-named files.
By going to /usr/cups/filter and setting the link I was being mechanical and pedantic and wondered if/why it was even necessary as copying/scanning, I thought, would not be cups related but since there is that copy to printer feature perhaps it might. They do claim it is an all-in-one too.

ljb643 06-28-2013 06:11 PM

The Epson scanner driver download (iscan and iscan-data) definitely does not include any printer driver files. In particular, it does not include the CUPS filter epson-escpr and epson-escpr-wrapper.

By the way, I downloaded and tried to build iscan_2.29.1-5.tar.gz with Slackware 14, and it failed with a linking error:

/libimage-stream.a(libimage_stream_la-pngstream.o): undefined reference to symbol 'png_set_longjmp_fn@@PNG14_0'
and it suggests adding to the linker command line. But I didn't persue it.

waddles 06-29-2013 01:54 AM

Installing XP200 scanner
Great info and many many thanks.
In examining for cups did U just use grep -i cups or did U vi and use "/CUPS". I would like to know which files U viewed so if something like this happens again I can do it myself. Presuming U examined the make/configure files which one did U use?

ljb643 06-29-2013 11:04 AM

I just looked through all the files in the distributed package and didn't see anything related to the printer driver (ESC/P-R).

Were you able to build the scanner program (iscan)? Did you get that error I got from libpng?

waddles 06-30-2013 04:23 AM

Sorry, I was waiting until I could finish installing the printer and setting up CUPS. It is blisteringly HOT here and my system tends to die with overheating in this weather.
Yes, I installed ESC/P-R and the data and core for the scanner without a hitch (that in itself is foreboding). I had these warnings:
make for ESC/P-R:
missing braces around initializer
unused variable
variable may be uninitialized
cupsRasterReadHeader is depricated
make of core had:
depricated conversion from string constant to 'gchar*' or 'char" in one place several times.
These appear at first blush to have been left in as the compile was not being affected by them.
There were NO ERRORS when building either driver/scanner--whew! Did not use the --Prefix option as everything went into /usr/local/lib & share as opposed to /opt/EPSON.
I made a check off list if I have to do this again. Would it be of value to list it here?
Will post after testing.

Noticed in an ascii file I have which claims to be a manual for the printer driver (didn't include a source), that in setting up the printers I might need to have the PPD file. I looked in the file from the expanded tar ball and found the PPD directory and a raft of Epson files for various printers. When I ran "file" on the one which appears to be for the XP-200 it said it was a ppd file. Is that the one needed to describe the ppd file to cups?

ljb643 06-30-2013 05:47 PM

The printer driver includes PPD (Printer Description) files for every Epson printer supported by the driver - which is a lot. When you installed the driver, the PPD files were copied to someplace like /opt/epson/share/cups/model/epson-inkjet-printer-escpr/

After installing the driver, you will need to add the printer in CUPS. You can use the web interface at localhost:631. When adding the printer, you tell CUPS you have a PPD file, then browse to the location where the Epson driver installed them, and pick the file named for your printer. That file contains all the information CUPS needs to support your printer (such as paper sizes, margins, and the name of the filter program which processes the data).

waddles 07-02-2013 09:29 AM

I installed without --prefix and I opened the tar.gz file into a file it created called: epson-inkjet-printer-escpr-1.2.3 and cd'd from there to ppd where I found: Epson-XP-200_Series-epson-escpr-en.ppd
But by going to /usr/local/share/cups/model/epson-inkjet-printer-escpr I found: Epson-XP-200_Series-epson-escpr-en.ppd there too. I presume the later is what will be used by CUPS.

HOWEVER, when I tried to define the printer in CUPS all went well until I got to MODEL. It did not have an XP-200 model in its list.
Will it allow me to enter the model by typing it in directly. Never ran into that before. Any ideas? Call Epson?
It has been too hot till now so have forgotten exactly what I entered but think there was a place to enter the PPD file just prior to the MODEL. Do I enter the /usr/local pathe to that PPD file? It isn't the one under /opt/EPSON... is it?

ljb643 07-02-2013 08:04 PM

Yes, if you build the Epson printer driver without using --prefix, it puts the files under /usr/local, and the PPD files which come with the driver go where you found them. That isn't someplace CUPS will look on its own - you will have to tell it when you set up the printer. (By the way, when you successfully set up the printer, CUPS will make a copy of the PPD file into /etc/cups/ppd.)

You are almost there. When adding the printer in CUPS, you got to the screen where it shows you the Name, Description, Location, and Connection. Then there is a list of Models. Ignore those - those are the ones that ship with CUPS (or an add-on package). What you want is at the bottom: Or Provide a PPD File. Click on the Browse button there, browse over to that directory: /usr/local/share/cups/model/epson... pick your printer's PPD file, then click Add Printer in CUPS.

All times are GMT -5. The time now is 09:43 PM.