-   Slackware (
-   -   Installing SlackWare 13 pkgs onto 12.2 SlackWare (

browser 07-17-2010 03:38 PM

Installing SlackWare 13 pkgs onto 12.2 SlackWare
Could Someone tell me if its possible to install the newer slackware 13 pkgs onto a 12.2 slackware , or if theres a tool for doing this, or do you have to install Slackware 13.
I have KDE3.5 & I dont want to remove it but would like to install some of the newer software if possible.
I find GSlapt gives a pkgtools error if I try to install from a 13 repo etc.
Thanks AnyOne

paulsm4 07-17-2010 05:30 PM

Hi -

Even if you could "force-install" one package or another (and, with enough perseverance, you probably can ;)), I think mixing/matching software for one version that's intended for a different version - along with mixing/matching any associated dependencies - is probably a recipe for disaster.

Two possibilities:
1. Build the packages you'd like to try out from source
<= This way, you can put any package - along with any/all dependencies you want - into their own "sandbox"

2. Install the new version on a VM (VBox, VMWare, etc) and try out whatever you'd like in your own "virtual lab".

'Hope that helps .. PSM

croxen 07-17-2010 06:14 PM

Your primary problem is that your packagetools from 12.2 can't handle the newer package format from 13.0

You need to upgrade to (or install) 4 packages from 13.0:


This will enable your 12.2 system to process .txz packages from 13.0

Be careful with installing newer software versions of apps, etc. into your 12.2 system. After upgrading a particular app (and only do one at a time), run the app from a terminal to see whether it blows up for lack of a particular dependency. The error message will tell you which depency is missing. If this happens, and it will frequently, the package containing the particular dependency will also need upgrading to the 13.0 level.

For upgrading such things, I tend to use either slackpkg, or, if the 13.0 package is from another repo, like, I'll simply download the package and to the upgrade from a terminal with the trusty old "upgradepkg" command.

For example, today I upgraded vlc on my 12.2 system to the version from the 13.0 repo at Upon running it from a terminal, I discovered that I also needed to upgraded glibc. That done, the new version of vlc runs perfectly. The next app may present its own problems.

Good luck!

linus72 07-17-2010 06:30 PM

I can present two options that may address both problems
first you want to keep kde 3.5.10 and 2nd add and/or keep the rest up to date

well; fathom at Slax forum is the maker of slax remix 05/06/07
and they are all current based but with kde 3.5.10

so, he has found a way to do it and he's a nice guy and so maybe you can ask him if any issues

also, I made a thread about how to manually install remix05 to hdd

should also work with 06/07 if interested

I also have a kde-3.5.10 module for my nFluxOS current i686 build

it seems to work OK too

hope that helps

browser 07-18-2010 11:15 AM

I didn't think of pkgtools being the answer for upgrading even though it was where the error was at, I was looking at upgrading SlaptGet or GSlapt as the answer."I think thats whats called blindness".
I have had success installing newer software by using Alien or rpm2tgz etc.. But I would prefer to be able to install from repositories rather than a pkg at a time & then waiting to see the error to see what dependencies are needed .
AlSo I really want to keep kde3 so I really appreciate everyones answers.
I think I will have to try installing from source to get pkgtools installed
srk2pkg is another tool I have tried as well.

browser 07-19-2010 03:08 AM

I found a great answer on this at another forum by accident while googling for pkgtools.
Sounds like I may only need to upgrade "xz"

browser 07-19-2010 07:03 PM

Thanks EveryOne ,Tips Worked a treat, I was able to download TGZ pkgs from "" instead of the hassle of installing from Source.

All times are GMT -5. The time now is 12:04 AM.