-   Slackware (
-   -   Installing Slackware 13.1 on ASUS Eee PC with USB Stick from Win7 (

niklo 11-17-2010 01:21 PM

Installing Slackware 13.1 on ASUS Eee PC with USB Stick from Win7
Hi guys.

I know you must be getting sick of this problem by now so I'm sorry for bringing it up once again.

I have recently bought a Asus Eee PC Seashell 1005PX and it came with Windows 7 Starter Edition, it doesn't have any CD/DVD so I'm gonna/have been trying for some time now to install Slackware 13.1 from my 8GB USB stick. I downloaded the 13.1 ISO file and used Unetbootin to transfer it to my USB stick. I get stuck in the setup in the setup when I am to select the SOURCE DESTINATION. I've tried /dev/sdb1 which is my USB, also i've tried using mount into different directories but i'm new to Linux so that didn't go very well..

Some of you have recommended Alien BOB's guide but I have read the first parts of it. Is it really for people with Windows OS? It's a bunch of Linux CLI code and programs.. ?

And please don't tell me to choose some other "more user friendly" Linux distribution, my mind is set on Slackware :)

linus72 11-17-2010 01:36 PM

hey man
it's really as simple as putting the CD/DVD on the usb

then, when you boot up off usb, after logging in but before starting setup

fdisk -l

to find out usb device name (sdb1)?
after you figure out what name is usb enter

mkdir /source
mkdir /iso
mount /dev/sdb1 /source
mount -o loop /source/slackware.iso /iso

then type in "setup"
when you get to part about where the source media is
say premounted directory and put there

then it should go OK

niklo 11-17-2010 01:44 PM


Originally Posted by linus72 (Post 4162196)
mkdir /source
mkdir /iso
mount /dev/sdb1 /source
mount -o loop /source/slackware.iso /iso

thanks alot man! but what iso file? the USB stick looks like the CD/DVD would do, there is no iso file on it.

mcnalu 11-17-2010 02:13 PM

I see what linus72 is suggesting, but here's a slightly different approach I used to install slackware 13.1 on my eee pc 1000H.

First I read the README on USB here, courtesy of Alien Bob.

I then used an old (128 MB would you believe!) USB stick to place usbboot.img on.

I then boot up my eee pc from that stick (I think I had to disable some of the quick boot options in the bios to get it to work smoothly).

I had a wired ethernet connection and another machine with the slackware packages on it, so used the NFS option in the installer to get the packages.

In your case, you could download the relevant packages into your win7 partition, from here. You don't need them all (I install them all except kdei which I definitely don't need).

You'll then need to mount your win7 partition from slackware installer environment and you can tell the installer where to get the installed packages from. There are quite a few more details that have no doubt disappeared in my memory, but just ask if you get stuck.

Good luck!

linus72 11-17-2010 02:51 PM

I meant the cd or dvd iso(s) you downloaded initially
as I thought maybe you had either cd's 1-3 or the big DVD

anyway, you can do it a number of ways, thats just how I do it
put the iso on usb, put the kernel/initrd on usb and syslinux.cfg
just rename isolinux.cfg to syslinux.cfg
rename isolinux folder to syslinux folder
thats what unetbootin does anyway

Alien Bob 11-17-2010 03:04 PM


Originally Posted by niklo (Post 4162186)
Some of you have recommended Alien BOB's guide but I have read the first parts of it. Is it really for people with Windows OS? It's a bunch of Linux CLI code and programs.. ?

You apparently did not find the Windows-oriented instructions:


niklo 11-17-2010 03:06 PM

Nevermind, I figured it out! :)

I did it like you this.

mkdir /source
mkdir /iso
mkdir /win7
mount /dev/sdb1 /source
mount /dev/sda1 /win7
mount -o loop /win7/linux/slackware64-13.1.iso /iso

/sdb1 = my usb stick
/sda1 is my windows partition, I had the iso stored there just in case :)

I hope someone else will find this helpful to.

Thanks alot Linus!

niklo 11-17-2010 03:10 PM


You apparently did not find the Windows-oriented instructions:
Nope, I somehow missed those instructions..

Thanks everyone for your answers :)

I must say I'm impressed by this forum, alot of mature people that just want to help, now that is what it's for but usually (in my experience) forums get alot of imature people ruining it for everyone.

Now i'm gonna dissapear into the wonderful CLI world for a while! :)

linus72 11-17-2010 03:38 PM

There you go!
Sounds like you'll make for the perfect Slacker!
It's good you like to do things for yourself and explore
Most new people are not that way

Well, you have alot of configuring to do and such...
some helpful hints include getting sbopkg (SlackBuilds), which adds alot more apps that are for Slackware

they are the same thing, sbopkg is the cli package manager part which enables you to search/install all the stuff

what desktop(s) are you going with?

niklo 11-17-2010 11:49 PM


what desktop(s) are you going with?
I don't know yet :) that's the fun part about all this, a whole new world! Any tips?

Now I'm off to school to do some "slacking" :)

brianL 11-18-2010 04:30 AM


Originally Posted by niklo (Post 4162659)
Now I'm off to school to do some "slacking" :)

Don't do too much, or you'll end up like me. :)

mcnalu 11-19-2010 03:55 AM

I can recommend Kde in netbook mode. You can select it easily under system settings.

niklo 11-19-2010 01:01 PM

How do I get to choose what OS to boot? Windows 7 just keeps booting just as it did before I installed Slackware.

I got it with Win 7 Starter edition installed, I only have one disk, split into three partitions.

/dev/sda1 WINDOWS 7
/dev/sda2 LINUX SWAP
/dev/sda3 LINUX

I've read many different posts and guides that is about GRUB and LILO but from what I understand you need to set them up from Linux CLI. Can I use the USB stick with Slackware on that I used to install? And would anyone point me in the direction of a guide, not to complicated :)

I understand if you're thinking "what an idiot, how is he gonna learn how to use Slack if he can't even get it to boot?!" :)

I just need to be able to boot it so that I can use it and learn. Also I'm reading everything about Linux for newbies I can get my hands on, including the slackbook.
(I'm so sick of windows, just wan't to get familiar with Linux and then I will never use it again..)

Maybe I should have posted this somewhere else but here you can see what I have done so far.

kernel-P4N1C 12-07-2010 10:32 AM

Install lilo on the MBR and that's gonna be it.

this is my hdd setup (1005ha)


root@weput-netbook:/home/weput# fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x17b16f74

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1  *          1        3039    24410736    7  HPFS/NTFS
/dev/sda2            3040        5529    20000925  83  Linux
/dev/sda3            5530      19456  111868627+  5  Extended
/dev/sda4          19457      19457        8032+  ef  EFI (FAT-12/16/32)
/dev/sda5            5530        5778    2000061  82  Linux swap
/dev/sda6            5779      19456  109868503+  7  HPFS/NTFS

if you see... I have a shared partition on /dev/sda6 who holds the data and a EFI partition on /dev/sda4 with 8 mb of space.

The EFI partition is to enable the boot booster. Needs to be labeled efi.

All times are GMT -5. The time now is 08:09 PM.