-   Slackware (
-   -   Installing Slackware 10,2 on a SATA disk (

kamransoomro84 09-09-2006 07:59 AM

Installing Slackware 10,2 on a SATA disk
Hi. I just installed Slackware 10.2 on my brand new SATA disk. Everything went smoothly, until I tried to boot into Slackware. During startup, e2fsck says bad superblock or superblock does not contain ext2 filesystem. I'm using ext3. And when I manually run e2fsck /dev/sda9 (my root device) it says the device is clean. Can anyone help me?

drkstr 09-09-2006 12:12 PM

Root device on an extended partition? That can't be good. I'm not positive, but it sounds kind of dicey. I would stick to a primary for your root partition. (maybe someone can back this up, or refute it)

To narrow the problem down a bit, which kernel did you install, and how did you set up your partition table? Did you use the one in the Slackware installer, or a 3rd party utility?


kamransoomro84 09-10-2006 11:55 AM

Well, I set up the Linux partition using cfdisk. Ok, here's a complete picture of my hard disk organisation. I have one hard disk on hdc. My SATA disk is on sda. I have 4 partitions on my SATA disk. On the primary partition, I've installed Windows XP. On the first logical partition of my extended partition, I've installed Linux. What you say strikes true. Would setting the boot flag on my Linux parition solve the problem?

drkstr 09-11-2006 01:37 AM

Well, I don't think that is actually what's causing your problem.

You still didn't say what kernel you're using. Do you have compiled in support for your root file system (ext3 in your case) as well as the hard disk type (SATA disk support)? If not, are you using an initrd to load the modules?


kamransoomro84 09-11-2006 08:25 AM

Sorry, I forgot. I'm using the sata.i kernel supplied with the Slackware CD. It has support for both ext3 and SATA so that's not the problem. Any more suggestions?

sn9ke_eyes 09-11-2006 02:29 PM

did you try the boot flag on the linux partition like you said ?
Where did you choose to install LILO during installation ?
Do you intend for LILO to be your bootloader for windows and linux ?

kamransoomro84 09-12-2006 08:17 AM

Yes, I tried the boot flag, but it doesn't work. I installed LILO with lilo -M /dev/sda. And yes, I intend LILO to be my bootloader for both Windows and Linux.

drkstr 09-12-2006 08:48 AM

can you post the contents of your /etc/fstab please?


kamransoomro84 09-12-2006 09:59 AM

I'm afraid I can't since I deleted my Linux partition to see if reinstalling would do any good. I'll post them if this still doesn't solve the problem. One thing you people should know that might have a bearing on this is that I'm installing Linux on a Logical Partition. I have only one Primary Partition that contains Windows. All of the others are Logical Partitions.

drkstr 09-12-2006 11:29 AM

Yup, that was the very first thing I addressed in my first post. If possible, try putting it on a primary.


kamransoomro84 09-12-2006 12:46 PM

Hmmm. It'd take some work, but ok. I'll try it.

All times are GMT -5. The time now is 01:28 AM.