-   Slackware (
-   -   installing handbrake (

clifford227 08-25-2010 11:49 AM

installing handbrake

I've installed Alienbobs full handbrake package (from, and the dependancies (latest icu4c.4.4.1, libsoup, and webkitgtk), but when I try to run handbrake ('ghb' at the console), it gives me this error:


ghb: error while loading shared libraries: cannot open shared object file: No such file or directory
it looks like an icu4u file, but slocate cant find it on my system. Is there something else I need?

mlangdn 08-25-2010 11:55 AM

Did you run

# ldconfig
Handbrake works just fine for me from Alien's repository on -current.

clifford227 08-25-2010 12:16 PM

mlangdn, yes I have run ldconfig, I just think Im missing the '' file. I have tried the two most recent versions of ICU (4.4 & 4.2), but neither contain the file.

something I forgot about: Im using Alien's 13.0 package on 12.2.

mlangdn 08-25-2010 12:44 PM

In these cases, I try a symlink. Lots of times, it will work the same.

Try this and adjust for your system


ln -s
If it don't work, just delete the symlink.

clifford227 08-25-2010 05:22 PM

mlangdn, the softlinking worked for the ICU librarys, but then I got problems with webkit which I couldnt figure out. No matter, I'll try one of the commandline apps.

Thanks for your help :)

XGizzmo 08-25-2010 07:04 PM

icu4c's latest update breaks binary compatibility. Anything linked to an older version will need a recompile.

All times are GMT -5. The time now is 07:14 AM.