-   Slackware (
-   -   Installed full dvd, LILO failed, Wont boot. (

Pyro123 06-29-2007 08:02 PM

Installed full dvd, LILO failed, Wont boot.
Alright guys, I installed Slackware once and did not install or configure LILO, so i thought that was my reasoning behind it would not boot. So i reinstalled Slackware and attempted to install LILO but it said it failed on the configuration, i have the commands to manually configure it but they wont work when i boot the install dvd and get to the command prompt. So i don't really know what my problem is, I haven't used Linux in about 5 years so I cant remember anything basically. Also, i don't have a floppy but i can boot to USB or cd/dvd if need be, I'm running windows vista at the moment on the same computer and have a separate partition set up for Slackware. If you guys know anything that i can do, i would really appreciate it.


blackhole54 06-29-2007 09:29 PM

Try the following:

Boot from a live CD. (The installation disk might have a rescue mode that would work for this.) Create a mountpoint. (I will assume it is at /mnt/hda1, but you can adjust to suit needs/taste.) Mount your root partition here. Make sure it is not mounted nodev. If you have a separate boot partition, mount it at /mnt/hda1/boot. Edit /mnt/hda1/etc/lilo.conf as required; I'm assuming the directions you have will help you out here. Then run:


chroot /mnt/hda1 lilo
Reboot and remove the live CD. With any luck, your system will successfully boot from the hard drive.

Ilgar 06-29-2007 10:02 PM

You can use the Slackware installation CD for that. Just proceed as if you're making an install, and when you drop to the console, you can do what blackhole54 suggested.

Road_map 06-30-2007 03:11 AM

First please read Slackware-HOWTO and SlackbookBoot from your Slackware DVD. Then boot from DVD and type:

huge26.s root=/dev/hda1 noinitrd ro
change /dev/hda1 with your Slackware root partition. After that you can login as root and run

and choose "expert" option.

Ahmed 06-30-2007 03:34 PM

Alternatively you can ditch lilo completely, and install grub, which I personally prefer. You'll find the package in extra/grub on the DVD.
Boot up your system with the LiveDVD as Road_map described, then mount the DVD and install the package:


(From inside the directory)
# installpkg grub*.tgz

You can then set up grub with "grubconfig". The menu interface is pretty straightforward and should get grub working in no time.


wakeras 06-30-2007 09:50 PM

can we know on what is your partition layout?
whare are your /boot and / partition?
your /boot partition must be on the first 1024 cylinders of your hdd (IDE). Let say you created 3 partitions
1st partition /boot of hda1 (let say 500MB)
2nd partition swap of hda2 (let say the rest of the hdd)
3rd partion / on another disk hdb1 (let say 20GB)

so your lilo should have
boot=/dev/hda <-------------using mbr

this is what I found out when I tried to use multilpe partitions on mutilpe hdds. My system could boot but halted when it could not find the root partition. Slackware always assume the first partition of your first hdd as your root partition eventhough you made (let say) hdd3 or hdc2 as your root partition. So remember where you put your root (/) partition and point to it when the liloconfig wizard as where is the root location located

Pyro123 06-30-2007 11:06 PM

Alright my partitions are as follows i have 1 HD 160gb, HDA7 is EXT3 8.4gb, HDA6 is swap 2gb. Other partitions are 86gb Vista, 4.88gb recovery, 48gb stuff partition (just has random stuff on it. The only partitions that i can use for this are the HDA7 and HDA6 Vista wont let me make any of the other partitions smaller safely. So my basic problem i have with Slackware right now is I've installed it, and every command i throw at it, it will reject, the cd doesn't have a recovery mode that i have seen unless its a special command, do i have to mnt the disk to the drive to get everything to work ? i went through the installer perfectly fine except the Lilo part that failed in simple mode. but i can boot the install dvd and get to the part were it says "boot:" and it says it is were you enter extra parameters, then if you just hit enter it takes me to the "root@slackware:" and looking for either; pcmcia, setup and i think one other command that was just a hardware setup for like a modem or something. and at the "root@slackware:" is were ive been trying to enter the commands i have tried to do the commands at the "boot:" part but they dont work, and yes ive tried the "sata.i root=/dev/sda7 noinitrd ro" but it will load and then hit me with some errors as the following is from the first error of 4 right before it hangs and does nothing past that point.

kmod: failed to exec /sbin/modprobe -s -k block-major-8, errno = 2

vfs: cannot open root device "sda1" or08:01

please append a correct "root=" boot option

kernel panic: vfs: unable to mount root fs on 08:01

and then it hangs right there. I am willing to try basicly anything you guys can throw at me, except if it involves my vista partition lol. Alright guys let me know what you think.


blackhole54 07-01-2007 03:02 AM


Originally Posted by wakeras
your /boot partition must be on the first 1024 cylinders of your hdd (IDE).

This used to be true, but I believe with newer BIOSes and/or versions of LILO that it is no longer required. I am not sure GRUB ever had this requirement.

This is a good thing, because based on his last post, I doubt Pyro123 can meet this requirement. (I haven't done an actual calculation based on his figures, but the early partitions sound rather large for a subsequent partition to be within the first 1024 cyliners.)

blackhole54 07-01-2007 03:10 AM


Originally Posted by Pyro123
then if you just hit enter it takes me to the "root@slackware:" and looking for either; pcmcia, setup and i think one other command that was just a hardware setup for like a modem or something. and at the "root@slackware:" is were ive been trying to enter the commands

This sounds like where you would enter the commands I was talking about, if you want to go that route. I am not sure what you are trying to say about pcmcia, etc.

Pyro123 07-01-2007 04:53 AM

What exactly does the mnt command do ? do i have to do that and my partitions im using are at the end of my 160gb HD.

Ahmed 07-01-2007 07:33 AM

Linux handles everything, even every piece of hardware as a file. Your partitions are all available on your hard drive as files called device nodes. They're inside the /dev directory.
Think of your partition as a floppy disk. If you have one in your hand you can't write anything to it. Once you shove it into a drive, you can write to it via your PC. It's the same with partitions on Linux, you have to "mount" them onto a certain directory so that you can write to them.
And the mount (not mnt btw) command does exactly that. Say you have a partition called /dev/hda3 (Which is the name of the device node by the way). If you want to mount it, open a command line and log in as root:


# mkdir /mnt/hda3  (This creates a directory inside /mnt called 'hda3'. /mnt is where the system usually mounts CD drives and other media)
# mount /dev/hda3 /mnt/hda3
(And in order to unmount the partition, just like as in "Remove hardware" in windows:)
# umount /dev/hda3  (Like "unmount" but without the first n)

If you enter the directory /mnt/hda3, you'll find all your files from the partition there. Luckily enough you rarely have to do this anymore, as Linux automatically mounts almost anything. Sometimes though it can come in very handy..


blackhole54 07-01-2007 10:07 AM


Ahmed just showed you exactly how to do what I was talking about in post #2, except in your case you would be using hda7 (or sda7 -- I am not sure) instead of hda3 as Ahmed showed, or hda1 as I used in post #2. I am sorry I was not more explicit.

Also, if you decide to try what I was talking about, after you mount the partition, use the mount command without any parameters. This will show you all the partitions that are currently mounted and info about them. Look for the one you just mounted and make sure it does not have nodev in the paranthetical list after it. (If it does, we may have to tell you how to mount it w/o that option.)

Pyro123 07-02-2007 02:40 PM

Ok the "huge26.s root=/dev/sda7 noinitrd ro" WORKS....
BUT i get another error that says this...

modprobe: FATAL could not load /lib/modules/ no such file or directory.

/sbin/e2fsck:no such device or addresss while trying to open /dev/sda7 possibly non-exixtan or swap device.

An error occured during the root filesystem check.
You will now be given a chance to log in to the system in single-user mode to fix the problem.
If you are using the ext2 filesystem, running "e2fsck -v -y <partition>" might help.

ok so i dont know why i get this error when im using the ext3 filesystem and im for sure that it is sda7 and sda6 is my swap.

blackhole54 07-02-2007 11:01 PM


Originally Posted by Pyro123
ok so i dont know why i get this error when im using the ext3 filesystem

Ext3 is just ext2 with journaling added. They use a lot of the same tools including e2fsck.

I don't know why you are getting the error. You could try the command it suggested. If you would first rather just see what e2fsck has to say about the partition w/o changing any thing, you can specify -n instead of -y.

All times are GMT -5. The time now is 07:22 AM.