-   Slackware (
-   -   installation problem with framework (

palsar 11-17-2012 03:17 AM

installation problem with framework
There has been an error.
Error running su postgres -c '"/opt/metasploit-4.4.0/postgresql/bin/pg_ctl" start -w' : pg_ctl.bin: could not start server
Examine the log output.
The application will exit now.

at 13.37 release there was no problem...

Alien Bob 11-17-2012 06:28 AM

You are not giving enough information to be able to help. What "framework"? What error messages in log files? Slackware 64-bit or 32-bit? Your "framework" 32-bit or 64-bit? Self-compiled or binaries downloaded from the internet? Bla bla bla etc.


palsar 11-17-2012 06:44 AM witch is binary file.i tried also the slackbuild file.32 bit
i've made the following steps :1)i install postgresql slackbuild i run the command "su postgres -c "initdb -D /var/lib/pgsql/data"..2)edit the file /etc/rc.d/rc.local and local_shutdown in order to start and stop the server.3)when i did vigr the file /etc/group had already a postgres group with gid 1001 and i changed that to 209.3)edit the file /etc/rc.d/rc.local in order to Start Metasploit Framework PostgreSQL bla bla bla....and when i run the binary or the slackbuild i get this message.

All times are GMT -5. The time now is 11:53 PM.