-   Slackware (
-   -   installation on ThinkPad 560 (

superbondbond 01-02-2003 12:42 PM

installation on ThinkPad 560
I'm trying to get Slack 8.1 installed on my ThinkPad 560. I've got an external CD Rom drive that connects via PCMCIA slot, and an external floppy drive. I guess I have two questions:

1) Is it possible to boot from the CDRom drive. I have checked the BIOS and am able to set it to check the PCMCIA slot before the hard drive, but it doesn't seem to find the drive.

2) in the meantime I've been trying to install starting with floppy disks. I have the boot disk, which loads fine, then it prompts for the root disks (there are 5 am I correct?). When I insert the first root disk, it starts to load and then when I get to the second one, it gives me

floppy0: data CRC error: track 55, head 0, sector 8, size 2
end_request: I/O error: dev 02:00 (floppy), sector 1987

It will repeat this message over and over for ten minutes or so, then tell me to insert disk 3, where I get:

floppy0: data CRC error: track 32, head 1, sector 17, size 2
end_request I/O error, dev 02:00 (floppy), sector 1186

I have not gotten past this one yet. Is this some sort of corruption with my root disks? I have tried disk images from a number of the mirror sites, and it's the same every time.

any advice on this would be a great help. Thanks!

jymbo 01-02-2003 02:27 PM

give it a try
Here are some tips that might help:

1.) Try booting off your Slack CD with SmartBootManager. I found this little gem to be an enormous help in installing Slack8.1 on my really old Compaq Armada P233 which (for some odd reason) has a non-bootable CDROM drive. Get SmartBootMGR here:

2.) If your laptop has a PCMCIA NIC (and it is supported by the Slack PCMCIA package) and you've got a desktop Linux box that you can network to, you can install via NFS. Copy the contents of your Slack CD and export it from your NFS server on the Linux box. You'll have to boot your laptop from the 5+ floppies, plus the PCMCIA driver floppy and the NETWORK floppy. I can go into further detail on this if this is the way you want to go.

3.) As for the corrupted floppies, I had the same issue. I resolved it by buying a brand new stack of floppies, then writing the images with rawrite on a Windoze box (yes, I know this is taboo, but it worked).

I've successfully installed Slack 8.1 on the following laptops:

1.) COmpaq Armada 4210T (P233/98MB/3.0GB)
2.) Compaq Armada M700 series (PII400/128MB/10GB)
3.) HP Pavilion N5415 (Duron 900/256MB/10GB)

Hope this helps.

superbondbond 01-02-2003 03:50 PM

Thanks for the help jymbo-

yeah, the floppies had some bad sectors. I discovered that when I tried to reformat them from my Win2K machine and it said they were unusable.

After getting some new floppies for the root discs there was no problem there, so when I tried again to install, I got through all 5 discs and I got this message:

EXT2-fs warning: checktime reached, running e2fsch is recommended
VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 228k freed
EXT2-fs error (device ramdisk (1,0)):
ext2_check_page: bad entry in directory #2: unaligned directory entry - offset=0, inode=4143380214, rec_len=63222, name_len=246
Warning: unable to open initial console.
Kernel panic: no init found. Try passing init= option to kernel

Is this problem related to the kernel not being able to find the CDRom drive? I Have the disk for PCMCIA support the was located with the root disk images. I assumed the system would prompt for that when it needs it, although it seems to me that it would need that before it could ever find the CD drive. I'm stumped.....

I will try the SmartBootManager you mentioned and see what I can do with that.

Thanks again.

jymbo 01-02-2003 05:04 PM

I'm not quite sure about the kernel panic message. It looks like the ramdisk holding the contents of all 5 floppies is corrupt. I would try loading the floppies again.

As for the PCMCIA floppy, once you have all 5 floppies successfully loaded and you are at the command line, you need to invoke:

$ pcmcia

Slack8.1 will prompt you for the PCMCIA driver floppy. Once you have PCMCIA services running and you are back at the command prompt, invoke:

$ network

Slack8.1 will prompt you for the network driver floppy. Probe for you NIC and config your network for the laptop, then you can run setup. At this point, you can now specify your installation source (select NFS).

Yes, try booting off the Slack8.1 CD with SmartBootManager and let me know how it worked for you.

superbondbond 01-02-2003 05:21 PM

I just downloaded the SmartBootManager.

I'll let you know what happens...

Thanks again for the information.:)

Just a thought. Once I get to the prompt and type

$ pcmcia

Since my CDRom is connected through my PCMCIA slot, I should be able to run setup off of the Slackware CD. Am I right in thinking this?

I do have a NIC too, but don't have the dongle to connect to the Cat5. If I can get Slack up an running and like it OK, I might look into a wireless NIC. Just dreaming now....

jymbo 01-02-2003 05:42 PM

To my knowledge, once you load the PCMCIA drivers floppy, it should probe for your external PCMCIA CDROM and load the necessary drivers. Pay attention to what is displayed on your screen when/if the drivers are installed so you have reference as to what device the drive is actually assigned as (ie, hdb, or sda1, or maybe sr0, or some other device). I haven't actually done this, so it's just a guess. Then from the setup menu, you can set your installation source as the CDROM.

I hope you have beter luck with SmartBootManager.

superbondbond 01-02-2003 10:04 PM

still no luck. I seem to be getting the Kernel panic message every time. I am starting to wonder if the problem is somewhere else. possible the memory or something.

Also, I am trying to get it to boot from the CD-Rom with SmartBootManager, and am not having much luck. I don't think it's finding the CD drive.

This is what I'm seeing:

Flags Number Type Name
---------- --- -- None Quit to BIOS
---------- --- -- None Power Off
---------- --- -- None Reboot
---------D FD0 0 None Floppy
---------D HD0 0 None Harddisk
-----A---- HD0 1 FAT16 Primary 1

I'm trying to figure out what the I/O port numbers are for that device so that I can manually input them. That's the only thing I can figure out from the documentation. Any suggestions?

jymbo 01-02-2003 11:38 PM

It looks like we're running out of options here.

Another last-ditch effort you could try is RedHat. The boot-from-floppy procedure only takes 2 floppies (the boot floppy, then the PCMCIA drivers floppy). I haven't tried it on a PCMCIA CDROM, but it's worth a shot.

Good luck!


superbondbond 01-03-2003 12:15 AM

I noticed on the readme file that was on the PCMCIA disk that it says to boot using the bareapm.i boot image (it includes advanced power management support for laptops). I have tried a couple of different boot images, but I can't find that particular one for version 8.1. I am beginning to wonder if that is an issue. perhaps I should back-track a bit and try 8.0 instead. I have seen that boot image for 8.0.

I think we're getting warmer.....

All times are GMT -5. The time now is 02:42 PM.