-   Slackware (
-   -   install can't find source media - ide cdrom (

tunedLow 12-26-2002 03:23 AM

Install can't find source media - ide cdrom
While trying to install Slack 8.1 I can't get it to find the source media. I am using a cdrom I made from an image I got from one of their mirrors.

I have a plextor CDW, which I assumed to be IDE, but have to add the following kernel argument to lilo: append="hdc=ide-scsi"

I have installed redhat and lfs without this problem on this exact same system.

Is it that this drive needs scsi emmulation (whatever that is exactly...) and these modules aren't loaded? Could I then get a different iso somehow?

Here is a copy of my dmesg. I've tried added different versions of the append deal - append="ide-scsi=hdd" etc.

While googling the problem someone mentioned that they solved a similar situation my first mounting the drive and then running setup. However, I have yet to be able to mount the drive - can mount floppies, but not the cdrom, not on and /dev - scd, scd0, hdd, hdc etc.

I've also tried buring another copy of the iso - the first was 8.0, and then again with 8.1, same results.

If I can add anything else to the problem description just let me know :)


Linux version 2.4.18 (root@midas) (gcc version 2.95.3 20010315 (release)) #12 Fri May 31 01:40:49 PDT 2002
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000000ffec000 (usable)
 BIOS-e820: 000000000ffec000 - 000000000ffef000 (ACPI data)
 BIOS-e820: 000000000ffef000 - 000000000ffff000 (reserved)
 BIOS-e820: 000000000ffff000 - 0000000010000000 (ACPI NVS)
 BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
On node 0 totalpages: 65516
zone(0): 4096 pages.
zone(1): 61420 pages.
zone(2): 0 pages.
Kernel command line: initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=6464 rw root=/dev/ram SLACK_KERNEL=scsi.s BOOT_IMAGE=/kernels append="ide-scsi=hdd"
Initializing CPU#0
Detected 1102.506 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 2202.00 BogoMIPS
Memory: 252340k/262064k available (1743k kernel code, 9336k reserved, 628k data, 264k init, 0k highmem)
Dentry-cache hash table entries: 32768 (order: 6, 262144 bytes)
Inode-cache hash table entries: 16384 (order: 5, 131072 bytes)
Mount-cache hash table entries: 4096 (order: 3, 32768 bytes)
Buffer-cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
CPU: Before vendor init, caps: 0183fbff c1c7fbff 00000000, vendor = 2
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
CPU: After vendor init, caps: 0183fbff c1c7fbff 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU:    After generic, caps: 0183fbff c1c7fbff 00000000 00000000
CPU:            Common caps: 0183fbff c1c7fbff 00000000 00000000
CPU: AMD Athlon(tm) Processor stepping 02
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (
mtrr: detected mtrr type: Intel
PCI: PCI BIOS revision 2.10 entry at 0xf1a70, last bus=2
PCI: Using configuration type 1
PCI: Probing PCI hardware
Unknown bridge resource 2: assuming transparent
PCI: Using IRQ router default [10de/01b2] at 00:01.0
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Diskquotas version dquot_6.4.0 initialized
Journalled Block Device driver loaded
pty: 512 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
Real Time Clock Driver v1.10e
block: 128 slots per queue, batch=32
RAMDISK driver initialized: 16 RAM disks of 6464K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PCI_IDE: unknown IDE controller on PCI bus 00 device 48, VID=10de, DID=01bc
PCI_IDE: chipset revision 195
PCI_IDE: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc:DMA, hdd:pio
hda: IBM-DTLA-307045, ATA DISK drive
hdb: Maxtor 32049H2, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 90069840 sectors (46116 MB) w/1916KiB Cache, CHS=5606/255/63
hdb: 40021632 sectors (20491 MB) w/2048KiB Cache, CHS=2491/255/63
hdc: ATAPI 32X CD-ROM CD-R/RW drive, 2048kB Cache, DMA
Uniform CD-ROM driver Revision: 3.12
ide-floppy driver
Partition check:
 hda: hda1 hda2 < hda5 hda6 hda7 hda8 >
 hdb: hdb1
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
loop: loaded (max 8 devices)
ide-floppy driver
SCSI subsystem driver Revision: 1.00
NCR53c406a: no available ports found
request_module[scsi_hostadapter]: Root fs not mounted
request_module[scsi_hostadapter]: Root fs not mounted
request_module[scsi_hostadapter]: Root fs not mounted
md: linear personality registered as nr 1
md: raid0 personality registered as nr 2
md: raid1 personality registered as nr 3
md: raid5 personality registered as nr 4
raid5: measuring checksumming speed
  8regs    :  1157.600 MB/sec
  32regs    :  1247.600 MB/sec
  pII_mmx  :  2591.200 MB/sec
  p5_mmx    :  3106.400 MB/sec
raid5: using function: p5_mmx (3106.400 MB/sec)
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
LVM version 1.0.1-rc4(ish)(03/10/2001)
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 16384)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 2286k freed
EXT2-fs warning: checktime reached, running e2fsck is recommended
VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 264k freed

Excalibur 12-26-2002 06:43 AM

You shouldn't need any append statement for the CDRW during the install. The proper statement would be append="hdc=ide-scsi" in the lilo.conf after the install is complete. And that is only if you desire to burn CD's under Slack. For just mounting and reading CD's the kernel messages indicate the drive is at hdc. If I understand the report correctly, you should also just use the standard bare.i kernel default.

The CD is obviously being read because it appears to be booting the kernel and loading the ramdisk image. There are many problems of course that result in an unusable CD but it appears that at least this part should be OK. To mount the CD manually, after a simple default boot from the CD, and see what errors might be reported use:

mount -t iso9660 /dev/hdc /cdrom

Post back what error message you receive. If none, then attempt to run setup and see if it will install from the CD.

neo_nirvane 12-26-2002 08:55 AM

Hey! I'm facing exactly the same problem. My 1 is a plain ide asus 52X cdrom, which is also located in /dev/hdc. Yes it did boot from the cd but when it came to selecting source it turned out that it can't find the cdrom! Weird....

I also did mount it manually but then it said "Mount: Not a directory". I'm frustrated as well..... sigh

Hope someone can come in and give a hand! ;)

Excalibur 12-26-2002 10:16 AM


Can you be more specific as to what reported the error? Was it when you attempted to mount the cd manually or during the setup program?

The /cdrom is not a real directory, it should be a sym link to another. Unfortunately, I can't remember what the real path is. But it should be a part of the ram disk image that was loaded. Use the "dmesg" command to see any error messages reported after attempting to manually mount the CD. The normal reply to the console is a single line of text stating that the CD is mounted read-only.

If the CD mounts OK, then you can validate the slackware install packages with the following:

cd /cdrom/slackware
md5sum --check CHECKSUMS.md5

That is provided the md5sum command is available under the install root disk image. I do not know if it is or not. If the program isn't available, then it would have to be from another installation.

If you are able to validate the files then the setup install script shouldn't have any problems with the packages. If not, then CD is probably corrupted. Slack 8.1 iso requires a 700 MByte CD. It will not fit on a 650 MByte CD.

Perhaps the info has helped.

tunedLow 12-26-2002 01:24 PM

Thanks alot for the reply and the clarification on passing that parameter.

I boot using bare.i, and still not seeing the cdrom, I try to mount as suggested. Starts out:
"root@slackware:/# mount -t iso9660 /dev/hdc /cdrom"
and then replies
"mount: block device /dev/hdc is write-protected, mounting read-only"
...great, then
"mount: not a directory"

So the cdrom under / is a symlink to /var/log/mount (I think it was), and obviously nothing was mounted there.

Here is the dmesg output. Note where is says file size not equal to 0, then defective cdrom.

Could this really just be a defective cdrom. If so, how could it be reading in the first place. Note that this is also I've tried 2 different disks now with the same results. I'll gladly burn another if that's all there is too it!

Thanks again.


VFS: Disk change detected on device ide1(22,0)
ISO 9660 Extensions: Microsoft Joliet Level 3
Interleaved files not (yet) supported.
File unit size != 0 for ISO file (59392).
Warning: defective CD-ROM (volume sequence number 20047). Enabling "cruft" mount option.
ISOFS: changing to secondary root
hdc: status error: status=0x58 { DriveReady SeekComplete DataRequest }
hdc: drive not ready for command
hdc: status timeout: status=0xd0 { Busy }
hdc: DMA disabled
hdc: drive not ready for command
hdc: ATAPI reset complete
hdc: irq timeout: status=0x80 { Busy }
hdc: ATAPI reset complete
hdc: irq timeout: status=0x80 { Busy }
end_request: I/O error, dev 16:00 (hdc), sector 500
ISOFS: unable to read i-node block
hdc: status timeout: status=0x80 { Busy }
hdc: drive not ready for command
hdc: ATAPI reset complete
hdc: irq timeout: status=0x80 { Busy }
hdc: ATAPI reset complete
hdc: irq timeout: status=0x80 { Busy }
end_request: I/O error, dev 16:00 (hdc), sector 0

Excalibur 12-26-2002 01:53 PM


The output would tend to indicate a corrupt CD. When I mounted my Slack 8.1 install CD the only thing the kernel reports through dmesg is:

ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A

The reported console output message is:

mount: block device /dev/cdrom3 is write-protected, mounting read-only

In regard to your cd burn. How did you burn it and how was it downloaded?

There are many Windows programs that are known to corrupt iso images or they do not understand Rockridge extensions, etc. Also, many Windows browsers also tend to corrupt ftp transfers.

In addition the Slack 8.1 iso is well over 650 MByte. The CDR must be a 700 MByte CDR unless you recreate it to fit on a 650MByte.

If you have a linux system available with the ISO image, you could attempt to mount the image under loopback:

mount -t iso9660 -o loop /path/to/iso/image.iso /mount/point

Substitute actual names in the above as required. But that would allow you to mount the file system and test the integrity. In the slackware directory you can the check the md5sums for all the packages.

cd /mount/point/slackware
md5sum --check CHECKSUMS.md5

Any errors reported probably indicate a corrupted iso image. Perhaps try a different mirror. Validate your burned CD against the original ISO image after the burn if possible. I use the cmp command under Linux. Something like:

cmp -l /dev/hdc isoimage.iso

should report any differences in the files. Or you could use the dd command to rip the image first to hard disk and then compare the two files. Either command would force the CD to be read, and you can view the dmesg output to see if there are any error messages reported.

Hope it helps to identify the problem.

tunedLow 12-26-2002 02:54 PM

Thanks again.

I burned this iso under linux with a 700mb disk.

I under my current linux box I mounted the disk, ran the checksums and got all kinds of errors. Should have done that first!

I'll try another mirror and post back if there's any change.


neo_nirvane 12-26-2002 08:58 PM

Hey wait! I found the solution! In my case, which is similar with tunedlow, is not caused by cd corruption... Yes i mounted the device during installation by giving command like "mount .... iso 9660...etc etc."

But it's not the case, then a person came up last night and told me an approach. ( thanks to that guy )

u just type ide=nodma as a parameter to the boot.
eg: Boot: bare.i ide=nodma

i tried it and it works perfectly.... hope this piece of information helps...

anyway, thanks also to those who have been trying to help in this forum..

tunedLow 12-26-2002 10:27 PM

Yes! That worked for me too. Made a new disk from a different mirror but still same problem. Adding that line let me find the disk right away. Now I'll have to read a bit and see why that worked! Thank you both very much.

lordciriuz 03-07-2006 11:17 AM

Wow... I had the same problem with an old PC today. It works for me too!

Thank you!
Lord Ciriuz

All times are GMT -5. The time now is 11:35 PM.