-   Slackware (
-   -   Input/Output errors on files (

Poetics 08-25-2003 05:15 PM

Input/Output errors on files
I turned on my Slack 9 box this morning after being away from home for three months (was performing Shakespeare). I connect to the box via SSH (using PuTTY from an XP machine). I tried to "ls" one of my mp3 directories and I received many files with the following: "/bin/ls: File.mp3: Input/output error" These files, I assume, are the problem behind me not being able to access that directory via Samba (using Explorer to transfer files), while all the other directories work fine.

I have tried to rm the offending files, but to no avail; I get the same i/o error, and it drops me back to the prompt. A search here at LQ didn't yield anything regarding individual files (mainly CD-ROM mounting), but I'm hoping someone out there knows the answer!

TIA everyone

trickykid 08-25-2003 05:20 PM

Have you checked your /var/log/messages or any other log files to see what could have happened?

Are these in their own partition, like /home? If so, you can umount it and attempt to fsck it possibly, etc.

Poetics 08-25-2003 05:24 PM

I wish they were in their own partition; I had set up the filesystem as a dry run last year as a venture into linux. Now I deffinately realize I should have put this directory (and other similar directories) on their own partition. I'll check /var/log/messages right now

Edit: Maybe I was smarter than I thought; I have several partitions set up ... checking fstab

Edit2: var/log/messages is pretty much a mystery to me; I'll see if I can copy the info into a text file I'll host somewhere. As for /home, okay, it's set up as hda5 -- I unmount it then run fsck on it?

Poetics 08-25-2003 05:38 PM

Edit: That's what linux is all about, finding answers ;)

Trying the fsck now

Edit: Hardware errors abound. At blocks 1802244, 2424836, 2424837, 2490372; lots of files leaving traces in inode blocks, a whole lotta stuff going into lost+found

Poetics 08-25-2003 05:57 PM

Okay -- weeeeell, the fsck ended up deleting whole directories. Didn't want that to happen.

I'm assuming there's no way to get all of the information back? It was about 10 files out of 2000 that were having problems, but now they're all gone.

All times are GMT -5. The time now is 09:44 AM.