-   Slackware (
-   -   Input and reboot problems while installing slackware (

blart 08-01-2003 07:29 AM

Input and reboot problems while installing slackware

I'm pretty new at slackware (actually I'm generally a semi-newbie at linux administration), and i got into some problems while trying to configure my new slackware installation. (I am trying to install it on my weaker p3-350Mhz)

1. First problem is this :
I cannot configure the mouse. I do not know exactly what type of mouse I have over there although i'm guessing it's a PS/2.
The thing is that when i tried to configure with other mouse configurations (like serial and ms) , the box just hung after gpm loads.
When i'm using the PS/2 setup then it hangs only after starting X
(It loads KDE and all, and then after everything loads, including the "tip" window, everything just hangs)

2. Second problem I have is with the LILO. After installing it, when the computer boots I get something like :
"L 01 01 01"
and it just keeps writing 01's from time to time.

I am not sure if it has anything to do with it, but i have some suspicion in the fact that the HD is a "primary slave" while the CD is the master (I know, wierd-o hardware configuration. Thats how i got the computer and i dont wanna mess with that as I know it worked with windows).
So susequentially the linux system is on /dev/hdb1 and not as the default.

Anyway, I'm a bit puzzled here... Please rescue me from fleeing into RH's arms ;))

Thanks in advance

Azmeen 08-01-2003 11:45 AM

Welcome to LQ.

First of all, you got to know the kind of mouse you're using. Nowadays, I reckon it'll be either PS/2 or USB. PS/2 is the round end, while USB is somewhat flat.

Well, anyway, try setting your mouse protocol to IMPS/2.

As for your LILO problem, the strange thing is, how did you manage to get into your "hung" KDE when your LILO is not working? Well anyway, your problem is most likely you didn't set your Slack partition as bootable. That is the meaning of your 10 10 thingy.

Hope this helps :)

blart 08-01-2003 12:10 PM

Hi and 10x.

Well, I think i've tried IMPS/2 (I think that what it gave me when i tried a "microsoft" mouse). I know how a usb looks like, its not it.
The thing is that i have a connector there that is like a Serial mouse, but ontop i've got something that converts it to PS/2 - hence the confusion :). I'll retry anyway.

About how i got into slack without lilo: I just used the install cd for booting into it ("bare.i root=/dev/hdb1 noinitrd ro").

I've rechecked, and the main partition (meaning the one other than the swap) is set to be bootable... :((

any other ideas? :confused:

Skyline 08-01-2003 12:56 PM

Hi blart

Which port is your mouse connected to?

If your OS hangs when starting X - how have you got into KDE?

The LILO errors probably indicate a harware configuration problem - maybe LILO doesnt or can't recognise your current setup?

Is there any way you can get hold of your Lilo.conf file to post it here?

blart 08-01-2003 03:16 PM

1. I guess my mouse is connected to one of the com's. Problem is I dunno which... There's no way of detecting this in an automatical manner?

2. I've made my hd as "master or single" and reinstalled, and it still doesnt work (although the 01's are printed alot faster now....).

A brief look at the site you gave me says that the first part of lilo runs , but the second can't load. They say usually its a media error (which is not in this case, since i can boot from cd into the hd) or a geometry mismatch (which i'm not 100% sure what it is).

It'll be quite difficult to put the lilo.conf here since the only opetion is carrying the other computer and connect them by LAN, but i cannot simply do that because that would take booting into slackware..... So its messy. Anyhow the lilo.conf should be totally standard..

I'll dive into the site, maybe i'll get a better clue at what a "01" error is.

blart 08-01-2003 03:18 PM

Oh yea - i forgot to say something about the hanging after X loads :

It only hangs when i use IMPS/2, and after EVERYTHING loads (including KDE, including the "tips" window of KDE) from X. If for example I choose PNP (plug and play) then I just dont have a mouse, but the X is working fine (with a keyboard that is :)).

blart 08-01-2003 03:32 PM

YES! Booting problem SOLVED! :cool:

Thanks alot for giving me that site!

It wasnt booting because I installed LILO with "Root" method, but the partition was over 1024 cylinders. So what i did essentially is to put the LILO on the MBR (which is, ofcourse, the first sector on the HD) and it worked like a charm...

Now all that's left is the mouse &$^% :)

Skyline 08-01-2003 03:59 PM

Nice one Blart.

blart 08-02-2003 08:59 AM


Just wanted to say that I messed around with the serial ports in the computer's setup and then on linux, and now it finally works :))

Thanks alot for all your help.
I have another question but I guess that should be in another thread :)

All times are GMT -5. The time now is 10:51 AM.