-   Slackware (
-   -   Inkscape compilation error: *** [extension/internal/pdfinput/pdf-parser.o] Error 1 (

w1k0 10-23-2008 05:48 PM

Inkscape compilation error: *** [extension/internal/pdfinput/pdf-parser.o] Error 1
*** Problem solved by astrogeek (see: below) ***

I'm trying to install Inkscape from SlackBuilds in Slackware 12.1.

At the beginning I installed a few packages taken from SlackBuilds: PyXML, libwpg, loudmouth, libsigc++, glibmm, cairomm, gtkmm, and gc. I installed also libboost-dev 1.33.1 package -- because I couldn't find its Slackware's version I grabbed .deb package and converted it to .tgz package.

Then I tried to compile inkscape package taken from SlackBuilds. The compilation stopped with the error message:


extension/internal/pdfinput/pdf-parser.cpp: In member function 'void PdfParser::opEndImage(Object*, int)':
extension/internal/pdfinput/pdf-parser.cpp:2943: warning: deprecated conversion from string constant to 'char*'
make[2]: *** [extension/internal/pdfinput/pdf-parser.o] Error 1
make[2]: Leaving directory `/tmp/SBo/inkscape-0.46/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/inkscape-0.46'
make: *** [all] Error 2

Somebody posted that error as bug in Gentoo Bugzilla. Someone else published it in The latter received the answer: ``I think this is because you're using Poppler 0.8.3, but the Inkscape code is designed for Poppler 0.8.2''.

There is no any Poppler in Slackware 12.1.

What can I do now to compile Inkscape in my system?

Have a nice day...

astrogeek 10-23-2008 06:13 PM

Just built inkscape - had some problem - solved

I just built Inkscape 0.46 using the slack build script from

After building all the dependencies I got the exact same error when running the inkscape.SlackBuild script.

I found that I had to comment out the patch line and it worked perfectly. The patch was provided to solve this compile error so maybe someone changed something else that fixed it and made the patch generate the error... anyway, in inkscape.SlackBuild just comment out:

#patch -p1 < $CWD/inkscape-0.46-poppler-0.8.3.patch

w1k0 10-23-2008 06:56 PM

Thank you very much for that tip, astrogeek. It works.

Where did you find libboost-dev package or how did you manage to compile Inkscape without it?

sleekslack 10-23-2008 07:27 PM

Actually there's a slackbuild script for the boost library.
Just type in 'boost' in the search box.

w1k0 10-23-2008 08:11 PM

Thank you, sleekslack. Earlier I sought it using the wrong name. Now I found it.

astrogeek 10-23-2008 09:19 PM

Boost and Inkscape bug to be aware of
Sorry to be so long responding.

Yes, just build the current 'boost' package (I think used 1.36 - different box). Thanks sleekslack.

After running it I found that it did not handle font selection from the toolbar widget correctly. I thought I missed something in the build but it turns out to be a problem with Inkscape itself - workaround is to use the menu based text tool for font selection, works painlessly. Look at the inkscape site and forums for more on that one.

Glad you got it going.

w1k0 10-24-2008 07:08 AM

I'm not sure what font selection tool you mean. I see two fonts oriented tools and one menu position:

* Create and edit text objects (F8) -- on the left vertical toolbar.
* View and select font family -- on the top horizontal toolbar.
* Text | Text and font... Shift+Ctrl+T -- in the main menu.

All these work well in my Inkscape.

If one of them don't work for you it's maybe boost package issue. As I mentioned above I used Debian package instead of SlackBuilds package. Or maybe you omitted to install some package. I mentioned all the packages I installed in the first post.

astrogeek 10-24-2008 11:38 AM


Originally Posted by w1k0 (Post 3320718)
I'm not sure what font selection tool you mean...

* View and select font family -- on the top horizontal toolbar.

It is the one in the toolbar. From what I read, if the default font is not on your system when it is first started it corrupts the user config file or something like that, then the drop list won't close.


Originally Posted by w1k0 (Post 3320718)
All these work well in my Inkscape.

Maybe we have different fonts installed, I have changed mine since slack was installed.

I did not install boost from a package, I built it with a SlackBuild, so there may be some difference there too.

Thanks for the info, maybe I'll have another look at it - but it has not interfered with my use of Inkscape so I haven't thought much about it.

w1k0 10-24-2008 12:53 PM

I updated TTF font directory after Slackware installation. First I installed Microsoft fonts: Arial, Courier New, Georgia, Symbol, Times New Roman, Trebuchet, Verdana, Webdings, and Windings. I don't suppose Inkscape depends on Microsoft fonts.

Because I wasn't satisfied with these fonts I installed three FreeFonts: FreeMono, FreeSans, and FreeSerif (see: directory freefont-ttf-20080912.tar.gz file). I strongly recommend these fonts. They look beautiful and contain a lot of useful characters and symbols. You can read about them here:

Until now I had the version of FreeFonts made in 2005. Current version is much better than that older one -- first of all it has corrected default line spacing. I wonder why Patrick didn't include FreeFonts in Slackware. Default Liberation fonts look ugly in comparison to FreeFonts and contain only basic set of characters.

If you suspect that because of lacking of some fonts at startup of Inkscape config file was corrupted just remove ~/.inkscape directory, install those fonts, and run Inkscape once again.

Probably I'll install boost package from SlackBuilds soon. If it'll corrupt my Inkscape I'll report it here.

w1k0 10-24-2008 07:51 PM

I just removed Debian libboost-dev package and installed SlackBuilds boost package. ``View and select font family'' button in Inskscape still works. Maybe your problem is a font issue as you suggested above.

astrogeek 10-24-2008 11:15 PM

Thanks w1k0 - I'll have another looks at it
I'll have a look at the fonts you linked - I have never actually paid much attention to what fonts I had on my systems before. I always seemed to have what I needed but I work mostly through one terminal window or another so as long as I have a decent terminal font I don't pay much attention.

But I am working up a transition to Slack 12.1 for multiple systems, some used by other people, so I have tweaked the fonts mostly to learn how that part of the box works - and one thing I think I need to do is trim down the list I am working with now! Too many! I need to come up with my own list of 'good' fonts and clean up some others.

I would also be glad to have Inkscape working at 100%, although the font selector thing is mostly a minor nuisance - once I saw that it was not just my installation I didn't think much more of it either - but if it can be fixed by my font selection then I will.

Thanks again.

w1k0 10-25-2008 09:06 AM

There are a lot of fonts in Internet. If you look for some set of basic fonts I recommend These fonts are delivered by Free Software Foundation. For last ten years I limited myself to Microsoft fonts for compatibility with Windows users. A few days ago I compared those fonts with Freefont set. Freefonts have the same width and height as Microsoft fonts. It means if you prepare some document using FreeSerif, FreeSans and FreeMono it'll look the same on machine with Times New Roman, Arial, and Courier New (three standard Microsoft fonts).

w1k0 10-25-2008 09:53 AM

I just looked at the directory mentioned above. The best set of fonts delivered there is my favorite GNU Freefont: It's good for everyday usage as well as for different special purposes. It contains all basic western characters including Latin Extended A and B, IPA characters (phonetic alphabet), Greek, Cyrillic, Hebrew, Arabic, and some exotic characters (for example: Devangari, Bengali, Tamil, Thai, and Ethiopic), a lot of Latin Extended Additionals, General punctuation, Currency Symbols, Letterlike Symbols (mostly used in mathematics), big set of Mathematical Operators, Miscellaneous Symbols, Dingbats, and much more. I recommend it strongly.

All times are GMT -5. The time now is 01:09 PM.