-   Slackware (
-   -   Init 4: Logging out of KDE causes black screen, freeze with GDM, KDM and XDM (

DaneM 01-30-2005 06:53 AM

Init 4: Logging out of KDE causes black screen, freeze with GDM, KDM and XDM
Hello everybody.

I've got a problem: Whenever I try to "end current session" with KDE with KDM login manager, it boots me back to tty1, but doesn't let me type anything. ttys 2-5 don't work either, while I'm in KDE, or after logging-out. tty6 will allow me to shut down smoothly. With GDM I get a black screen and freeze while trying to log in (don't know what would happen logging out, obviously), and XDM will show the login screen after ending the session, but the colors are inversed and I can't type anything or switch to another tty.

I recently made some changes to get even one tty to work (with KDM). In /opt/kde/share/config/Xservers, I've changed the line:


:0 local@tty1 /usr/X11R6/bin/X


:0 local /usr/X11R6/bin/X vt7 -terminate -nolisten tcp
For XDM, in order to get even a frozen and inversed image (as opposed to frozen and a blank screen) I changed the following line in /etc/X11/xdm/Xservers:


:0 local /usr/X11R6/bin/X


:0 local /usr/X11R6/bin/X vt7 -terminate -nolisten tcp
The web site that directed me to do this is here. I modified the lines slightly because the ones they gave me didn't work at all.

To boot into init 4 instead of 3, I changed line in /etc/inittab from




Can anybody help me fix this? I appreciate your help.


carboncopy 01-30-2005 07:03 AM

1. Are you using nvidia driver?

2. Did you custom compiled your kernel?

3. Which kernel version are you running?

DaneM 01-30-2005 07:16 AM

Thanks for posting, carboncopy.

1. I am using the latest (last I checked) ATI Radeon driver for Xorg 6.8.1, which I compiled myself.

2. I custom-compiled my kernel.

3. 2.6.7-ck6 (2.6.7 with Con Kolivas patch).

carboncopy 01-30-2005 08:25 AM

Do you have frame buffer compiled with the kernel? If yes, recompile your kernel without frame buffer.

DaneM 01-30-2005 02:32 PM

OK, I'll try that. I must say, though, that I'm concerned that I'll have the "blank-screen-while-in-terminal" problem; also bootsplash (I believe) requires a framebuffer.

I'll give it a shot and report back.


DaneM 01-31-2005 04:38 PM


I followed your suggestion and recompiled the kernel without the frame buffer. The result was a blank screen while starting up and a nasty green one while logging out/shutting down.

Any more suggestions?

Thanks for your help.


DaneM 02-02-2005 03:08 PM


egag 02-02-2005 03:24 PM

edit your lilo.conf and put in " vga=normal "
then rerun lilo and reboot.


DaneM 02-02-2005 05:10 PM

Hi, egag.

I tried what you told me, but to no avail. Upon logout I still got kicked back to an unusable tty1. Any more suggestions?

Thanks for your help.


egag 02-02-2005 05:23 PM

well...rereading your first post i have.
a little time ago there was also a thread about unusable tty, and IIRC correct,
you should add an option in the graph " server " section of xorg.conf.

smth like : option <see next post>
( this is probably not correct )

if i can find it on this forum i'll post it ( if still needed )


egag 02-02-2005 06:00 PM could try this :

# Nick 24/07/2004 - attempt to stop corruption exiting X
Option "ConnectedMonitor" "CRT"
Option "IgnoreDisplayDevices" "TV"


DaneM 02-02-2005 07:48 PM


I tried what you suggested and added those lines to my /etc/X11/xorg.conf, but it didn't change anything other than the text resolution in the ttys. I'm beginning to think that it might be a problem with the configuration files, such as inittab or the rc.x files, or perhaps xorg.conf. What really puzzles me is:

1) Why are there only two ttys active: tty1 and tty6 (and tty7 if you count the GUI)? I found something in inittab mentioning this problem, but I can't really make heads or tails of it.

2) Why is it kicking me out to tty1 at all, when I would expect it just to stay in tty7?

Your suggestions are always appreciated.


carboncopy 02-02-2005 09:13 PM

Hi DaneM,

Sorry for not warning you about the vga=normal thing. Slipped my mine. And was a way from my comp for couple of days.

Are you starting up in runlevel 3 or 4? By default, if you are using runlevel 4, there is only tty1 and tty6. But if you are using runlevel 3, you should have tty1 to 6 or more (not sure).

DaneM 02-02-2005 09:24 PM

Welcome back, carboncopy!

I normally boot into init 3, but recently, in order to find ways to make Slackware easier for non-Linux people, I've been experimenting with init 4 so that I can have a graphical login.

Pretty much what I want to is

1) Have a pretty GUI login so people won't freak out at having to type "startx".

2) Have tty1-6 working in case something goes wrong. (Not essential, but definately nice,)

I figure that if Mandrake can do it, I should be able to do it with Slackware, right?

We're getting closer, I think...


DaneM 02-03-2005 07:38 PM


I went into /etc/inittab and changed these lines:


# These are the standard console login getties in multiuser mode:
    52 c1:1235:respawn:/sbin/agetty 38400 tty1 linux
    53 c2:1235:respawn:/sbin/agetty 38400 tty2 linux
    54 c3:1235:respawn:/sbin/agetty 38400 tty3 linux
    55 c4:1235:respawn:/sbin/agetty 38400 tty4 linux
    56 c5:1235:respawn:/sbin/agetty 38400 tty5 linux
    57 c6:12345:respawn:/sbin/agetty 38400 tty6 linux

to this:


# These are the standard console login getties in multiuser mode:
    52 c1:12345:respawn:/sbin/agetty 38400 tty1 linux
    53 c2:12345:respawn:/sbin/agetty 38400 tty2 linux
    54 c3:12345:respawn:/sbin/agetty 38400 tty3 linux
    55 c4:12345:respawn:/sbin/agetty 38400 tty4 linux
    56 c5:12345:respawn:/sbin/agetty 38400 tty5 linux
    57 c6:12345:respawn:/sbin/agetty 38400 tty6 linux

All the ttys work now, and when I logout, instead of getting an unusable prompt, I get a usable one. Still not what I'm going for, but I think it's a step in the right direction.


All times are GMT -5. The time now is 06:37 AM.