-   Slackware (
-   -   In console mode can change tty's cannot from KDE or GRM (

rsol4747 06-08-2005 06:24 AM

In console mode can change tty's cannot from KDE or GRM
Good da :-)

I'm new to Linux I installed slack 10.1 everything was ok until I started Xvideo ( startx). If I try to switch to terminal mode or log out , everything turn black. in console mode I can switch btwn tty1 thru tty6 no problem.

Compaq EVO with Intel 82845/GL graphics.
Sound works ok. Everything seems ok.

Changed file inittab mode from 3 to 4 and back no difference. when you Logout the screen turns black. Thanks for any help. I only have access to the box from 11:00pm to 7:00am so please be patience for my return answer. Thanks again

Franklin 06-08-2005 06:34 AM

Look for this section in inittab:


# These are the standard console login getties in multiuser mode:
c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux

Make sure that 4 is listed after the c1-c6 segment on each line. The default install leaves runlevel 4 without access to all tty's.


Ipolit 06-08-2005 04:30 PM

in the console mode u can switch between ttys using alt+Fn key, but in X u have to use control+alt+Fn. Of course this is not all. Some times it's impossible to switch to console from X unless u add next line in your /etc/X11/xorg.conf file
in the Section Server Flags u must add this

Option "HandleSpecialKeys" "always"

rsol4747 06-10-2005 04:44 AM

Sorry nether of the changes worked.
I have fixed it temporarily, I ran live suse 9.2 and looked at the xwindow config file. It also uses xorg.conf but @xorg.conf (XF86Config) . So I mounted slack (hda6) to tmp on suse. copied the files changed (mouse) and I can now switch btn Xwindow (KDE) and tty1-tt6. The problem is the xorg.conf. I will run the xorgconfig / xorgsetup and post the results to see if it fixes the problem.
Again thanks.

rsol4747 06-15-2005 03:56 AM

Good da
I ran the xorgconfig / xorgsetup and now I can go from xwindow to console and back with no black screen.
Thanks again

All times are GMT -5. The time now is 10:16 AM.