LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-08-2007, 04:13 PM   #1
Atreo
LQ Newbie
 
Registered: Jun 2006
Posts: 22

Rep: Reputation: 15
Question IBM 390E doesn't switch off


Hi people!!

I have a problem, my laptop IBM 390E doesn't switch off with Slackware 10.

By the way, is there any way to startx before than logging, I mean logging through KDE?

thanks a lot!!
 
Old 01-08-2007, 09:22 PM   #2
mr.v.
Member
 
Registered: Jun 2006
Distribution: Slackware 11
Posts: 59

Rep: Reputation: 15
atreo--

I always have that problem with Slackware. The problem is for some reason or another ACPI support (ACPI controls that sort of thing) isn't compiled into the generic kernel (from the A) package.

To circumvent this problem, I'm afraid you're going to have to recompile the kernel. (or try to find one to install that's compiled with ACPI support). Anyway, compiling it is an interesting adventure and any Linux power-users going to want to learn how to do it, so you may as well learn now.

There are two options...you can go fancy and get a 2.6.X kernel (i think the latest as of my post date is 2.6.19.1 obtained from kernel.org).or you can go not so fancy and stick with the kernel source for the kernel you've already got.

If you did a full slackware install, the source will be in /usr/src/linux (which is actually a symbolic link to /usr/src/linux.2.4.X) [x being whatever version you have]

you go into that directory and type
make mrproper
(which basically runs a script that ensures all necessary files are in their correct states)
then type:
make menuconfig
this will make a menu based program that you go through selecting various things to enable in the kernel. It's somewhat daunting so you may want to frequently push the help button or read through documentation in the /usr/src/linux/Documentation directory.

Plan on messing up a few times and getting kernels that don't quite work with your PC (or forgot to enable certain file system support/framebuffering/ACPI =) /etc).

Part of the planning is ensuring that you can boot with, say, the slackware CD in case your kernel is unbootable. Be sure to save the original kernel by copying /vmlinuz to /vmlinuz.bak or some other such routine. Also save the original /boot/System.map

Once you're done configuring options in the menuconfig
if you've got a 2.4.X kernel then you have to type:
make dep which makes dependencies
if you have a 2.6.X kernel you can skip it.
Then type:
make bzImage which will compile the kernel.

you'll notice a million weird statements will all sorts of crazy -Flags set in the 2.4.X series but in the 2.6.X series the kernel compilation is quite simple. Either way it takes a LONG time depending on the machine.

When that's done type:
make modules to make modules
and then install them with
make modules_install (PS. I have no idea whether the _ is necessary but that's the way I initially learned and I haven't tested it out

Now you've got to copy the bzImage (stored in /usr/src/linux/arch/i386/boot/bzImage) don't ask me why... to the /boot/ as well as the System.map stored in /usr/src/linux ). Now update the /etc/lilo.conf to make sure that the image= line points to /boot/bzImage

FINALLY AND MOST IMPORTANT...EVERYTIME NO MATTER WHAT YOU DO YOU HAVE TO RUN /sbin/lilo
Even if you just compile one little teency weency thing or change. If you forget you're likely to encounter a machine that doesn't boot with a message "out of input" or something to that end. So don't forget to run it. If you do forget it, life goes on if you've got a handy boot disk so that you can get into your drive and type /sbin/lilo with the /etc/lilo.conf stored on your harddrive.

Hope this helps. I'm still figuring out a lot of things too so if you need help someone else may be of more service. But this power off thing I've finally worked out...

Last edited by mr.v.; 01-08-2007 at 09:23 PM.
 
Old 01-08-2007, 09:53 PM   #3
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291
How exactly doesn't it swich off, it doesn't power down ? Did you try:

Code:
halt -p
 
Old 01-09-2007, 09:43 AM   #4
Atreo
LQ Newbie
 
Registered: Jun 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Thumbs up

Hi there!

I'm going to try first the second suggestion and if it doesn't work I'll try the first one.
Although I should think in update from kernel 2.4 to 2.6, don't you think so?

Thank you so much for your attention and help dudes!!

I'll give you feedback.
 
Old 01-09-2007, 07:05 PM   #5
mr.v.
Member
 
Registered: Jun 2006
Distribution: Slackware 11
Posts: 59

Rep: Reputation: 15
I forgot to mention...

look in /proc
and see if you have a directory called "acpi"

if you don't then you're going to need to add support for acpi. If you do, something else is amiss.

try doing the following
run
Code:
ps -A | grep acpid
to look for a program running called "acpid" which is what monitors acpi events from the kernel.

if nothing is returned try running the program
Code:
/usr/sbin/acpid
and see if it loads. If it does, then try
Code:
shutdown -h now
or
Code:
poweroff
 
Old 01-10-2007, 01:40 AM   #6
Atreo
LQ Newbie
 
Registered: Jun 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Thanks, I'll try today.
 
Old 01-10-2007, 12:26 PM   #7
diskoe
Member
 
Registered: Nov 2006
Posts: 36

Rep: Reputation: 16
Atreo - if you are using Slack 10 with the 2.4 kernels, you have load the apm kernel module.

I had the same problem you had, but I edited /etc/rc.d/rc.modules to load apm on bootup. With 2.4 kernel and apm module loaded, an "init 0" will shutdown the OS and power off the computer.

But now that I'm using Slack 11 with the stock 2.6.18 kernel (from /testing), it's compiled with acpi and acpid starts from bootup.

Last edited by diskoe; 01-10-2007 at 01:18 PM.
 
Old 01-12-2007, 06:08 AM   #8
Atreo
LQ Newbie
 
Registered: Jun 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Hi all!!
I tried mr.v. suggestions and I think I don't have acmp installed.
I'm trying to install acpm package.
I'm using KPackage for installing ospmd-20021122.tar.gz .

The thing is that something is not working properly. I have these two problems when I press 'install':

Problem 1:
installpkg //root/descargas/ospmd-20021122.tar.gz ;echo RESULT=$?
Cannot install //root/descargas/ospmd-20021122.tar.gz: package does not end in .tgz
RESULT=0

Problem 2 (if I press install again):
Cannot install //root/descargas/ospmd-20021122.tar.gz: package does not end in .tgz
RESULT=3

How can I solve these problems for being able to install the package?

PD: same problem with lirc-0.8.1.tar.gz
 
Old 01-12-2007, 07:03 AM   #9
koloth
Member
 
Registered: Jun 2004
Location: Athens, Greece
Distribution: Slack@Home - RHEL@Work
Posts: 141

Rep: Reputation: 25
A quick idea, try
'modprobe apm'
and then
'halt'
the first will load the Advanced Power management module which is present in the default kernel. Your computer should shutdown succesfully.
 
Old 01-12-2007, 08:21 AM   #10
/y0shi
Member
 
Registered: Jan 2006
Location: berlin, germany
Distribution: slackware 12.0
Posts: 58

Rep: Reputation: 17
@Atreo:

if you want to install a slackwarepackage on slackware you do this with the command installpkg that is true.
but not every archive is a slackwarepackage! archives with the ending .tar.gz or .tar.bz2 are never slackwarepackages!
slackwarepackages have allways the ending .tgz
so what you have there (i.e. lirc-0.8.1.tar.gz) is probably source.
you have to compile this in order to get your program.

so to start the whole thing again maybe tell us what you use.
do you use slackware 10.2? what kind of kernel do you use (you can find that out with the command uname -a you get some thing like "Linux darkstar 2.6.18 [...]")
i think to get your probs solved you do not have to install anything, you just have to configure your system ...
 
Old 01-12-2007, 08:36 AM   #11
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
Hey,
I have the same problem . My comp doesn't halt.
Right now I have to do shutdown now -r and then poweroff manually when the comp has just restarted.

shutdown now -h , doesn't halt the system. It only shows "power down" and then hangs there.
I have 2.6.18 kernel , with acpi enabled. acpid is running.
My lilo is :
Quote:
image = /boot/vmlinuz-custom-2.6
root = /dev/hdb2
label = LinuxNew
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
append ="apm=off acpi=on acpi=power-off"
I had an earlier thread on this topic, but didn't quite manage it there. So trying again over here!
The append part above is from the earlier thread.
 
Old 01-12-2007, 11:48 AM   #12
mr.v.
Member
 
Registered: Jun 2006
Distribution: Slackware 11
Posts: 59

Rep: Reputation: 15
Quote:
Originally Posted by Atreo
I tried mr.v. suggestions and I think I don't have acmp installed.
I'm trying to install acpm package.
Atreo...are you sure you searched for acpi and not acmp. ACPI stands for Advanced Configuration and Power Interface (but make sure you search for the lower case "acpi"). "acmp" stands for...???

Both Atreo and duryodhan, can you run the following commands exactly and post the output for each one here in the forum.

The first command is:
Code:
ls /proc | grep acpi
The second is:
Code:
ls /proc/acpi/
The third is:
Code:
ps -A | grep acpid

Last edited by mr.v.; 01-12-2007 at 11:49 AM.
 
Old 01-12-2007, 09:48 PM   #13
duryodhan
Senior Member
 
Registered: Oct 2006
Distribution: Slackware 12 Kernel 2.6.24 - probably upgraded by now
Posts: 1,054

Rep: Reputation: 46
Here goes the output :

Quote:
bash-3.1$ ls /proc | grep acpi
acpi/
bash-3.1$ ls /proc/acpi
alarm dsdt embedded_controller/ event fadt info power_resource/ wakeup
bash-3.1$ ps -A | grep acpid
9 ? 00:00:00 kacpid
2606 ? 00:00:00 acpid
 
Old 01-15-2007, 01:49 AM   #14
Atreo
LQ Newbie
 
Registered: Jun 2006
Posts: 22

Original Poster
Rep: Reputation: 15
Thank you all!!

I'll try tonight.
 
Old 01-15-2007, 11:17 AM   #15
mr.v.
Member
 
Registered: Jun 2006
Distribution: Slackware 11
Posts: 59

Rep: Reputation: 15
duryodhan--

First obvious question is, will another 2.6.X linux distribution allow you to turn off your computer. Try, say, an Ubuntu or Knoppix live-cd's to see if the shutdown powers the computer off.

Second, I noticed in your OP that you put
Code:
"append ="apm=off acpi=on acpi=power-off"
All I know is that I do not append these lines and my computer turns off so they aren't strictly necessary. Try removing that line from your /etc/lilo.conf and then update it using /sbin/lilo

Also be sure to look at the /var/log/dmesg to make sure that append line hasn't caused any errors. But still, I don't think you'll need it. You may, however, have to recompile the kernel. Did you enable all the options like Button, Processor, Thermal Zone, etc when you built the kernel? And if so, did you compile them as modules or statically?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB, IBM thinkpad 390E conor.anderson Linux - Laptop and Netbook 2 10-02-2005 04:49 PM
set up DSL thru SWITCH - winXp connected to SWITCH too husz Linux - Newbie 5 04-22-2004 12:08 AM
Linux 6.2 for IBM Thinkpad 390E EFGM Linux - General 1 09-01-2003 12:10 PM
Corrupted Harddrive RH 7.2 & IBM TP 390E alanlq Linux - Hardware 6 08-30-2002 05:05 PM
Sound on a 390E IBM Thinkpad Casper Linux - General 6 12-27-2001 01:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration