-   Slackware (
-   -   i think i broke my libtool (

xushi 03-15-2005 01:20 PM

i think i broke my libtool
Damn it,

All i want is some bloody visualizations...

I've tried adding '/usr/lib' to /etc/ , typed ldconfig, and the viz didnt work, untill i noticed i had to install another package.

Now everytime i want to compile anything, i get this error in make,


lv_error.lo lv_ui.lo lv_thread.lo lv_object.lo lv_transform.lo  -lm -ldl  -L. -L/usr/lib
libtool: link: cannot find the library `'
make[2]: *** [] Error 1
make[2]: Leaving directory `/home/d/Download/amarok viz/libvisual-0.2.0/libvisual'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/d/Download/amarok viz/libvisual-0.2.0'
make: *** [all] Error 2

I've removed /usr/lib from /etc/, reinstalled pkgconfig, reinstalled libtool, rebooted, but still i keep getting this error when i try to compile anything on my machine...

Sorry, after the reboot, only libvisual has the problem (tried compiling nano, and make worked this time).

I guess one of the moderators can close this thread so i can start a similar one in software (for libvisual), unless someone knows a solution for it :)

EDIT::::: Solved
Nevermind.. Turns out it didn't like having a space in the name 'amarok viz' ... But what a way to find out.

Erm, if any moderator wishes to remove this thread i have no objections..

Matir 03-15-2005 01:42 PM

That sounds like a configuration script bug: perhaps not quoting things correctly. :)

xushi 03-15-2005 01:51 PM

So you think its something worth mentioning to the developers?

keefaz 03-15-2005 01:55 PM

Do not remove this thread, it can be useful for someone who has the same prob

All times are GMT -5. The time now is 10:28 AM.