LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-20-2018, 07:09 PM   #16
The Sego Sago Kid
Member
 
Registered: Feb 2015
Location: PA USA
Distribution: Slackware
Posts: 39

Original Poster
Rep: Reputation: Disabled

Huh. I was just messing around in alsamixer and I noticed the headphone jack was muted. Makes sense as no headphones were plugged in. Then I thought of this again:

Quote:
Originally Posted by abga View Post
If you have sound through the jack output but not through the internal laptop speaker, then you might want to try:
Code:
options snd-hda-intel model=headset-mic
Although that didn't resolve the issue, I figured it might be a thing. So I unmuted the headphones, and bam: sound starts coming out of the speakers. No idea why alsactl init would fix that.

Since I can run amixer as a regular chump user, I can add this to the XFCE startup items and get sound working on reboot without human intervention:

Code:
sleep 5
amixer -c 1 set Headphone 100% unmute
Good enough. I'll mark as solved. Thanks for all the help!
 
1 members found this post helpful.
Old 12-20-2018, 07:11 PM   #17
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 945

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Quote:
Originally Posted by The Sego Sago Kid View Post
Here's the result pre init:
Code:
0      alsa_output.pci-0000_0_1b.0.analog-stereo      module-alsa-card.c      s16le 2ch 44100Hz      SUSPENDED
...and post init:
Code:
0      alsa_output.pci-0000_0_1b.0.analog-stereo      module-alsa-card.c      s16le 2ch 44100Hz      IDLE
That's weird, pulseaudio gets your card even before "alsactl init".

Now, all the following hints are to be tried without issuing your workaround - alsactl init!

The IDLE/SUSPENDED state is controlled from /etc/pulse/default.pa in the section:
Code:
### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle
and as far as I understand it, it suspends the sink if IDLE for too long and that could get you some artifacts (pops/clicks) when activating it again - that's starting to play some sound, or, it could take some time to reactivate the sink(output). Just to rule out the last scenario, you can try commenting that line in /etc/pulse/default.pa and bounce pulseaudio:
Code:
/usr/bin/pulseaudio -k
/usr/bin/pulseaudio -D
Given that you experience the reported issue on a laptop I'd suggest to investigate the PM state of the sound card. Some lecture:
https://www.kernel.org/doc/html/v4.1...powersave.html
https://01.org/linuxgraphics/gfx-doc...dio/notes.html
https://wiki.gentoo.org/wiki/Power_management/Soundcard
Try loading the snd-hda-intel driver with:
Code:
options snd-hda-intel power_save=0
in /etc/modprobe.d/snd-hda-intel.conf

One last hint, I just stumbled upon this Ubuntu HowTo related to the snd-hda-intel driver:
https://help.ubuntu.com/community/HdaIntelSoundHowto
and I'd suggest to read the "Manually Specify Module Parameters" chapter and try loading the driver with:
Code:
options snd-hda-intel model=basic
instead of auto, like in the "Example" section, or, go on and play with the probe_mask.
There's also an option to specify the exact model of your card/hardware, but your Panasonic laptop is apparently not in the list:
https://ubuntuforums.org/showthread.php?t=1043568
Well, you could try all of them...just kidding

I wish I could help more but since I don't own your HW, I'm limited to speculation.
 
2 members found this post helpful.
Old 12-20-2018, 07:13 PM   #18
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 945

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Well, happy to hear you sorted it out while I was composing the rather boring post above ...
 
Old 12-20-2018, 07:27 PM   #19
The Sego Sago Kid
Member
 
Registered: Feb 2015
Location: PA USA
Distribution: Slackware
Posts: 39

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by abga View Post
Well, happy to hear you sorted it out while I was composing the rather boring post above ...
Ahhh! Might try some of that stuff anyway. At the very least, it could help some wayward googler in the future.
 
1 members found this post helpful.
Old 12-21-2018, 08:16 AM   #20
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,137

Rep: Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817Reputation: 1817
Quote:
@allend
As Didier mentioned, the snd-hda-intel can be a PITA, if you google after it, you'll learn that there are a lot of issues with it.
@abga
No manure Mycroft. Some fwit tried to write a howto

PS - I am happy that the OP got to a satisfactory conclusion.

Last edited by allend; 12-21-2018 at 08:18 AM.
 
1 members found this post helpful.
Old 12-22-2018, 06:01 AM   #21
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 945

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
@The Sego Sago Kid
Quote:
Ahhh! Might try some of that stuff anyway. At the very least, it could help some wayward googler in the future.
In this respect, it might be useful to edit your original post and add these keywords to the title:
"snd-hda-intel HDA-Intel Realtek ALC269VB sound muted"

I don't know why your sound output starts muted, but maybe it's a BIOS init / PM thing - you have hardware Keys to control the volume on your laptop. Alternatively, you should still try to play with the proper (for your particular HW) snd-hda-intel driver initialization as per post #17, might get the mixer initialization right.
Here, some additional info about the HDA Intel troubleshooting/standard:
https://www.alsa-project.org/main/in...ebug_Intel_HDA
https://en.wikipedia.org/wiki/Intel_...finition_Audio

I usually disable the onboard audio and don't bother with it, just because of the "horrifying" bad quality of the audio output of these chips. I'm kind of an audiophile "amateur" and I'm always using a few Creative xi-fi USB sound cards that I collected over time. They have decent DACs and I regard them as a poor man's-audiophile solution.

@allend
I was replying to your statement:
Quote:
A web search for your hardware and snd-hda-intel did not produce much, suggesting that this is not a problem faced by others.
and I wasn't aware of a Slackware HowTo related to the snd-hda-intel until later in the thread (got it as a google result). Neither was I aware that you were the author, sorry. I'm not reading the Slackware documentation because I started using Slackware long time ago and learned it with the help of colleagues/friends, with the help of man & --help and generic/standard Linux documentation. Moreover, by design Slackware is as pure as Linux can get, that's also why I love it, so I never had to look for distribution specific docs and always went for the upstream docs instead.
I do however discourage this approach and I'm highly appreciative for the effort contributors put in the documentation.

So, dear Slackers, read the Slackware docs first!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Slackware 14: Always need to run alsactl init manually in order to bring live Audio? RJwen Slackware 15 04-12-2013 02:31 AM
Need to run 'alsaconf' at every boot, even with 'alsactl store'. wtn2die Linux - Hardware 7 03-12-2010 01:48 AM
alsactl store settings gone after reboot or X restart mlangdn Slackware 2 07-10-2009 07:49 AM
no sound after alsaconf, reboot- *"alsactl restore" failed... mkoco Linux - Hardware 3 03-01-2008 06:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration