LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-12-2013, 07:24 PM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,933

Rep: Reputation: 45
I have no way to switch between windows in the DE nor to move them. The mouse cursor


I have installed slackware 14.0 a few days ago. Now, suddenly, when starting X, the windows have no upper bar to move them, I cannot switch between windows (tasks) and the mouse cursor is a cross when on the desktop. Don't find anything peculiar in /var/log/Xorg.0.log. Any idea about this behavior? May it be a hardware problem? The machine is brand new.
 
Old 01-12-2013, 07:46 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 6,903

Rep: Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284
I understand that things were working and then broke. What were you doing when it broke? That might shed some light on this.

Which desktop/window manager are you using?

For testing purposes, I have three suggestions:

Look in /var/log/Xorg.?.log for any hints.

Log out of the DE back to the terminal window and run xwmconfig from the command line and trying one or more of the other desktops/window managers to see if the problem is system wide.

As root, create a new user and log in as new user to see whether the problem is related to a particular user name. Use Slackware's "adduser" command to do that.

Include the results in your next post. The more information we have, the easier it will be to help.
 
Old 01-12-2013, 08:06 PM   #3
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,933

Original Poster
Rep: Reputation: 45
At the console where I ran startx I could see:
Code:
xfce4-panel: No window manager registered on screen 0. To start the panel without this check, run with --disable-wm-check.
xfsettingsd: No window manager registered on screen 0.
I started X as another user (I already had to do this some days ago) and all was well.

In Xorg.0.log I could not find lines marked EE.

The DE is Seamonkey, the window manager I really never new. If you tell me how, I'll tell you.

I think the messages on the console (see above) could be explicit enough, are they? If not, I'll foloow your advice to test another DE/WMs. Thank you very much.
 
Old 01-12-2013, 08:08 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo, Slackware
Posts: 14,896
Blog Entries: 2

Rep: Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810
That sounds that the desktop environment was not able to start the window manager, a behavior that I know from when I was fiddling with using XFCE with different WMs. Which DE are you using (I also wonder why I have to ask for such essential information from a long time member with more than 2000 posts)?

Edit: Now I see you use XFCE (Seamonkey is a browser, not a DE), open a terminal and start the WM manually with xfwm4, this should fix the issue.

Last edited by TobiSGD; 01-12-2013 at 08:12 PM.
 
Old 01-12-2013, 08:23 PM   #5
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 6,903

Rep: Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284Reputation: 1284
It looks like the DE is xfce.

It could be that one of the hidden configuration files/directories for xfce in your home directory has gotten corrupt. I'm not able to load up XFCE on a Slackware computer right now, but this link describes where they are located.

If you want to dig into the cause, you can compare the ones in your regular home directory with the ones in the home folder for the test user that you created. You would likely have to do this as root to have access to both users' files. A good tool for this would be diff, which is included with Slackware.

Alternatively, you could delete the XFCE configuration files in your home directory and then startx. They ought to be recreated in their default states.
 
Old 01-12-2013, 08:25 PM   #6
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,933

Original Poster
Rep: Reputation: 45
Code:
$ xfwm4
(xfwm4:4022) Gtk-WARNING **: Cannot open display:
$
That's what I get. Of course, I quit X in the other console first.
 
Old 01-12-2013, 08:42 PM   #7
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,933

Original Poster
Rep: Reputation: 45
Do excuse me. The DE really is xfce4 (xfce 4.10). Please bear in mind that this happens all the time. Deleting directories/files each time it happens would not be a solution. $XFCE4HOME is empty and there is no ~/.xfce4/. There is, instead, a ~/.kde/ directory.

Last edited by stf92; 01-12-2013 at 09:03 PM.
 
Old 01-12-2013, 09:27 PM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo, Slackware
Posts: 14,896
Blog Entries: 2

Rep: Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810Reputation: 3810
The XFCE configuration files are in ~/.config/xfce4
To fix the issue do not stop X. Use the menu or the quicklaunch paunel in XFCE to start a terminal and launch xfwm4 in that. This will start the WM and should automatically re-add it with the right settings in the session manager.
 
Old 01-12-2013, 11:02 PM   #9
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,933

Original Poster
Rep: Reputation: 45
Imposible to run xfwm4 either from a terminal or with Menu>Run. The window opens but does not get the focus. Or it does, because in a terminal I can access the menues in the menu bar. But I cant type. What if I install another DE like KDE?
 
Old 01-12-2013, 11:26 PM   #10
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
Did Xfce previously work? If so, what changes have you made to your system between when it was working to when it stopped working?

Do you have all of the packages relevant to Xfce installed? (Everything within the slackware(64)/xfce directory of the install DVD/CD or mirror.) For example, you aren't missing the xfwm4 package, are you?

You can delete everything within ~/.cache/sessions to see if you can get back to a sane environment, but you will have to reconfigure everything (if you had anything configured in the first place). Stop X, run "rm -rf ~/.cache/sessions/*" , restart X, hope for the best. But beware, as I said this will wipe out any changes you may have made to the default Xfce environment.
 
Old 01-12-2013, 11:40 PM   #11
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,933

Original Poster
Rep: Reputation: 45
I removed some of the hidden directories and finally went back to normal. I deleted ~/.config but didn't help. Then deleted the authority dirs and still didn't help. Then ~/.cache, ~/.dbus and ~/.xfwm_do_not_know, and then 'startx' got a screen asking if I wanted to change the settings for the panel. That is, at last back to normal. I'm thinking of installing the xfce4 package(s) again or updating to xfce5.

Sorry for the new post. Further, I did not see Mike_M.
 
Old 01-12-2013, 11:44 PM   #12
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 2,933

Original Poster
Rep: Reputation: 45
Quote:
Originally Posted by Mike_M View Post
Did Xfce previously work? If so, what changes have you made to your system between when it was working to when it stopped working?

Do you have all of the packages relevant to Xfce installed? (Everything within the slackware(64)/xfce directory of the install DVD/CD or mirror.) For example, you aren't missing the xfwm4 package, are you?

You can delete everything within ~/.cache/sessions to see if you can get back to a sane environment, but you will have to reconfigure everything (if you had anything configured in the first place). Stop X, run "rm -rf ~/.cache/sessions/*" , restart X, hope for the best. But beware, as I said this will wipe out any changes you may have made to the default Xfce environment.
Thank you, Mike. When I installed slackware 14.0 a few days ago, I chose all of the COMPLETE series, except that of international support. In the machines I have, 12.0 and, according to what I am seeing, 14.0, never have run without producing certain errors, very specially the GUI. When starting X, I've have always got some error messages on the console, when starting it, when X applications were launched and when exiting X!

Last edited by stf92; 01-12-2013 at 11:48 PM.
 
Old 01-13-2013, 01:14 PM   #13
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 598

Rep: Reputation: 210Reputation: 210Reputation: 210
2 Thoughts

Quote:
Originally Posted by stf92 View Post
Thank you, Mike. When I installed slackware 14.0 a few days ago, I chose all of the COMPLETE series, except that of international support. In the machines I have, 12.0 and, according to what I am seeing, 14.0, never have run without producing certain errors, very specially the GUI. When starting X, I've have always got some error messages on the console, when starting it, when X applications were launched and when exiting X!
Greetz
First of all it seems you have a display problem, likely related to ~home/.Xauthority. This can happen when root and user get mixed up on the display side of things. That can happen easily in XFCE if you run a graphic kde app as root without specifically using "kdesu", as one example. I think if you look to your display assignments/permissions you can solve the problem of the missing top bar.

If you use "kdm" it may be easier to load different DEs (or users)and narrow the field.
Best Wishes
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I want to move my mouse cursor with my program. Dogs Programming 2 02-20-2011 01:33 PM
Mouse cursor move sluggish, slow and erratically foojoy Linux - Hardware 4 03-25-2008 06:50 PM
i'm using xandros 3.0.2, my mouse(logitech) is not being sensed(cursor doesnt move) rocky_sk0c Linux - Hardware 0 09-13-2005 10:51 AM
startx on Debian gives grey background - cannot move mouse cursor or type fdac Linux - Newbie 7 05-04-2005 03:11 PM
mouse cursor doesn't move in X/Debian LovelyJunna Linux - Newbie 7 03-26-2004 05:12 PM


All times are GMT -5. The time now is 08:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration