-   Slackware (
-   -   I got fglrx driver to install, but what do I do with fglrx module? (

mack_the_knife 07-11-2009 10:23 PM

I got fglrx driver to install, but what do I do with fglrx module?
I did the SlackBuilds thing with fglrx-driver and all seemed to go well, but I can't get fglrx-module to do anything. If I knew what I was doing, I'd be a lot farther along, but I'm a serious noob..

Using Slackware 12.2, it's a fresh install on an Acer 5100 laptop.

Bruce Hill 07-11-2009 10:26 PM

Welcome to LQ!

Was there a README file with that SlackBuild?

mack_the_knife 07-11-2009 10:39 PM

Wow, what a fast response- thank you kindly Bruce.

Yes, there's a readme but the only useful information seems to be:

Add the following to /etc/rc.d/rc.modules or an equivalent file:
# Load fglrx modules
modprobe fglrx

I'm reluctant to do that before anything else, it seems that there must be more to it than just editing that file because there is a lot more to the module script- or am I trying too hard to not do something wrong?

Thanks again,


Bruce Hill 07-11-2009 10:48 PM

As root in a terminal issue "modprobe fglrx" without the quotes,
then issue "lsmod grep | fglrx" and if you see it, then the module
(driver) is loaded. You will probably need to logout of X and then
login again for it to work.

Editing that file is what how the author intends for the module to
be loaded every time you boot. Might not be needed. Reboot and see.

mack_the_knife 07-11-2009 10:59 PM

bash-3.1# modprobe fglrx
FATAL: Module fglrx not found.
bash-3.1# lsmod grep | fglrx
bash: fglrx: command not found
Usage: lsmod

So I guess I've not yet got it.

I do notice that both Slackbuilds pages (the one for fglrx-driver and fglrx-module) both show the same source file: "" and the same checksum. Should I have different source for the module?

Thanks again,


Bruce Hill 07-12-2009 02:05 AM

How about posting a link to the Slackbuilds page please?

mack_the_knife 07-12-2009 03:19 AM

Bruce Hill 07-12-2009 03:48 AM

You are running Slackware-12.2, and that package is for Slackware-12.1.
Do you know that it works with 12.2 also?

Did you follow verbatim these instructions?

README.SBo for fglrx-driver

Once you install this package, you should execute as root
    fglrx-switch -fglrx

You need to add this line to /etc/fstab if it's not already there:
    tmpfs            /dev/shm        tmpfs      defaults        0  0
and then mount /dev/shm as root.

Finally, you need to edit /etc/X11/xorg.conf to make use of this driver.
It's a good idea to read also "Configuring the X server", in the section
"Setting up the 'fglrx' driver" at

Also, if you upgrade this package(and fglrx-module) remember to unload
the fglrx module(# modprobe -r fglrx) and load it again(# modprobe fglrx).

If you are in an X session as a normal user or in some other desktop/wm than
KDE or GNOME, you can do the following to run the ATI Catalyst Control Center:
    user@darkstart:~$ su
    root@darkstart:/home/user# xauth merge /home/user/.Xauthority
    root@darkstart:/home/user# export DISPLAY=:0.0
    root@darkstart:/home/user# amdcccle &
    user@darkstart:~$ xhost LOCAL:
    user@darkstart:~$ su
    root@darkstart:/home/user# export DISPLAY=:0.0
    root@darkstart:/home/user# amdcccle &

Before you uninstall or upgrade this package, you should execute as root
    fglrx-switch -mesa

You were to download the source, plus the SlackBuild, plus all those individual
files into one directory. Then run fglrx-driver.SlackBuild as root.

I personally don't use scripts, so could you look and see if you
have any entries such as this in your /tmp/ directory?

mingdao@silas64:~$ ls -1 /tmp/*mutt*

where the names will be fglrx-driver.* and/or fglrx-module.*

I've only been running Slackware since 2003, but for that entire time it has
always been reported that ATI drivers are a pain to get running ... IF you
can even get them running decently.

If you can't get it going with the package, I would suggest
you read these two links:
A Guide: Enabling 3D Acceleration in X11 <- at the top of this forum

All times are GMT -5. The time now is 02:43 AM.