LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-10-2019, 02:24 AM   #1
argeloos
LQ Newbie
 
Registered: Aug 2013
Location: Nederland
Distribution: slackware
Posts: 14

Rep: Reputation: Disabled
I can't add to (X)Compose, the file does not load


I try to add this line to the Compose file

Code:
    <Multi_key> <e> <h>              	: "ɛ"   U025B
In fact, I'm unable to load a modified Compose file at all.

I tried creating
Code:
~/.XCompose
, modifying
Code:
/usr/share/X11/locale/en_US.UTF-8/Compose
(my $LANG is en_US.utf8).

With a modification in place, I've opened a new terminal, tried with su - myloginname, restarting X and completely logging in from the console. The modified Compose never loads, nor does ~/.XCompose block existing lines when I don't add anything or modify an existing line without loading the default one.

I don't know how to proceed. :-(

(Slackware 14.2, openbox)
 
Old 09-11-2019, 04:47 AM   #2
GazL
LQ Guru
 
Registered: May 2008
Posts: 5,156
Blog Entries: 18

Rep: Reputation: 2849Reputation: 2849Reputation: 2849Reputation: 2849Reputation: 2849Reputation: 2849Reputation: 2849Reputation: 2849Reputation: 2849Reputation: 2849Reputation: 2849
Works here. Are you sure you're pressing the correct compose key?

On mine, using a uk keyboard and 'gb' keymap, the compose key defaults to shift-altgr, but your Xorg.conf or desktop environment settings (if you're using one) may change it to something else.

alt-gr on it's own is usually configured to <ISO_Level3_shift> rather than <Multi_key>. In operation, it can look like it's doing Compose because some of the mappings will map to 'dead' accent keys, giving a similar effect with certain sequences.

Also, be aware that GTK apps don't tend to use XCompose(XIM), they have their own input methods. I'm not sure what it is currently as I haven't paid much attention to it in a while, but it used to default to SCIM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
compose key does not work with xfce parviz Linux - Newbie 2 08-31-2013 09:43 AM
How can I compose a multipage *.tiff ? dr_sad Linux - Software 6 05-04-2007 06:44 PM
compose keys don't automatically load, also profile-based john riemann soong Linux - General 0 07-27-2006 02:53 PM
xmodmap å, ä, ö, and ø - or how to add Compose to X BroX Slackware 3 10-31-2005 08:34 AM
evolution 2.0 can't compose moschi Linux - Software 2 10-21-2004 01:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration