-   Slackware (
-   -   I broke some things with kernel 2.6.10 (

Ricochet 01-06-2005 05:15 PM

I broke some things with kernel 2.6.10(Update: Check page 2)
So I successfully compiled the 2.6.10 kernel last night according to the sticky here. However, I seem to have broke some things in the process.

1) Firefox won't install on 2.6.10. I get a "Fatal error[-618]: Couldn't open xpistub library". I could find hardly any documentation on the firefox site for the linux version, strangely enough, and I couldn't really find any relavent information on here. So, I really don't know what to do. It installed fine before, when I installed it on the 2.4.x kernel.

2) Mozilla doesn't work for anyone but root. I don't know what's wrong since I don't recieve any sort of error message, but it just never runs when I click the shortcut. This wouldn't be a problem if I could use Firefox, but for now I'm stuck with Epiphany.

3) My Intellimouse Explorer buttons don't work anymore. all of my settings in xorg.conf are still the same, and I still have my xmodmap command in my .xinitrc file. Nothing changed on this end.

I'm sure there's probably more that I haven't noticed. Another thing, how do I check to see how many CPUs the kernel recognizes? I enabled SMP in my .config, and set max CPUs to 4 since I have dual Xeons w/ HT. I just want to make sure that they're all going.

I still have to install my Nvidia drivers, and setup Alsa, so I'll see how that goes. Anyway, thanks for your help all. This is my first time posting, but I've learned a lot previously reading. :)

leonscape 01-06-2005 05:20 PM

I dont think your firefox problems are related see this thread.

For processor info look in /sys/devices/system/cpu and how many cpu's are listed.

Ricochet 01-06-2005 06:16 PM

Thanks for the reply. I guess I was searching for the wrong thing regarding firefox. I found my fix in that other thread. :)

Thanks for the bit about the CPUs as well. It did indeed detect the 4 of them.

Ricochet 01-06-2005 08:12 PM

Okay, new problem... I can only start X as root. Otherwise, it crashes during loading, before it starts loading KDE. This is the error I receive, and is the final line of the Xorg.0.log file:

Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!

I don't know what this error means. I checked the directory, and it's there and the permissions on it are just the same as the rest of the font directories. I don't even know if this is my problem. Any ideas? I installed my Nvidia drivers as root. Maybe that was a mistake?

BajaNick 01-06-2005 10:43 PM

I had that same exact error but I dont remember how I fixed it but I remember it had something to do with KDE or xorg.conf . Have you tried starting up another window manager other than KDE, like fluxbox or gnome?

Ricochet 01-07-2005 01:11 AM

I was using Gnome , but I really didn't like it so I switched back to KDE. I don't recall if I logged in with my user acct since then... Hmmm, I'll give that a shot. That fixed it. All I did was switch to Fluxbox on my user account then switch back to KDE and all is well. :)

Ricochet 01-13-2005 10:51 PM

I've got everything running smoothly now with the exception of a few things. I need to figure out how to output my sound through the 7/8 channels on my card, as those use the high quality Wolfsen DAC. I have this setup easily through the drivers in windows, but can't figure it out in linux. I donno if reading this has a Chaintech AV-710 or another Envy24 based card setup this way, but if so any help is appreciated. I found an asound.state file that a guy from the forums uploaded, but i get an error when I try to restore it.

Also, I still can't get my mouse working right. I didn't change anything in xorg.conf, but the buttons don't work anymore. Any ideas?

kersten78 01-13-2005 11:16 PM

What is it that isn't working with your mouse? And could you post your mouse section of xorg.conf? As for the audio thing, I have no idea...sorry. Anyone else?

Ricochet 01-13-2005 11:33 PM

Sorry, my bad. I guess I forgot to post that part again. The scroll wheel and the side buttons don't work. They worked fine before the recompile. Here's that section from my xorg.conf file: I also have xmodmap -e "pointer = 1 2 3 6 7 4 5" in my .xinitrc fille.


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse1"
    Driver      "mouse"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

#    Option    "Protocol"      "Auto"

# The available mouse protocols types that you can set below are:
#    Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
#    Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
#    MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
#    ThinkingMouse ThinkingMousePS/2 Xqueue
    Option "Protocol"    "ExplorerPS/2"

# The mouse device.  The device is normally set to /dev/mouse,
# which is usually a symbolic link to the real device.

    Option "Device"      "/dev/mouse"
#  Option "Device"      "/dev/psaux"
#  Option "Device"      "/dev/ttyS0"
#  Option "Device"      "/dev/ttyS1"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

#    Option "Protocol"  "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

#    Option "BaudRate"          "9600"
#    Option "SampleRate"        "150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"

    Option "Buttons" "7"
    Option "ZAxisMapping" "6 7"


I didn't take all the commented lines out, because I thought it might be nice to look back on them to see what stuff does sometime.

kersten78 01-14-2005 12:03 AM

Hm...that all looks right. Wierd. Sorry again man--no help. Anyone else?

WMD 01-14-2005 12:23 AM

2.6.10 is still breaking stuff?

*Raises hand in disgust of the new development model*

2.4.27 for me. And 2.4.29 when it comes out.

Ricochet 01-19-2005 09:49 PM

Bump... Does anyone have kernel 2.6.10 working with a 7 button mouse? I've been not using linux for the past few days because the problem is so annoying. I've been considering going back to 2.4.x, but it doesn't have native support for my SATA controller....

WMD 01-19-2005 11:38 PM


I've been considering going back to 2.4.x, but it doesn't have native support for my SATA controller....
2.4.28 does, I bet.

leonscape 01-20-2005 12:45 PM

I'm compiling 2.6.10 at the moment myself, So I'll let you know if the mouse works for me.. It does with 2.6.9

edit: Mouse works for me, I also have the similar options

Section "InputDevice"
 Identifier "Intellimouse Explorer"
 Driver  "mouse"
 Option  "CorePointer"
 Option  "Device"  "/dev/input/mice"
 Option  "Protocol"  "ExplorerPS/2"
 Option  "Buttons"  "7"
 Option  "ZAxisMapping"  "6 7"

xushi 01-21-2005 12:26 PM

for some very odd reason, i had the same problem, and it even crashed my laptop big time with a blank screen everytime i startx ...

After reading /var/log/Xorg.0.log i noticed that it can't find /dev/mouse anymore
after searching through /dev , i noticed /dev/mouse doesn't exist anymore
checkout under /dev/input, its there, and it worked for me.
so just change your
Option "Device" "/dev/mouse"
Option "Device" "/dev/input/mouse0"

As for /dev/input/mice, i haven't tried that one yet, will do soon..

All times are GMT -5. The time now is 03:20 PM.