LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-11-2007, 07:40 AM   #1
daziplqa
Member
 
Registered: May 2006
Location: Egypt
Distribution: RedHat 9.0, Ubuntu 6.06 and Slackware 11
Posts: 54

Rep: Reputation: 15
I am new to slack having some troubles: lang, screen, etc


Hi all,
I am new to slackware, coming from ubuntu cause i wanna be linux guru
I have a somewhat old pc, so running kde makes my machine not function well, so i used xfce or whatever it called.

Some troubles faced me like:
1- the language, i want to write into arabic letter, so i have modified /etc/X11/xorg.conf so it becomes :

PHP Code:
Section "InputDevice"

    
Identifier    "Keyboard1"
    
Driver    "kbd"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

#    Option     "Protocol"      "Xqueue"

# Set the keyboard auto repeat parameters.  Not all platforms implement
# this.

#    Option     "AutoRepeat"    "500 5"

# Specifiy which keyboard LEDs can be user-controlled (eg, with xset(1)).

#    Option     "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.

#    Option     "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a European
# keyboard, you will probably want to use one of:
#
#    Option     "XkbModel"      "pc102"
#    Option     "XkbModel"      "pc105"
#
# If you have a Microsoft Natural keyboard, you can use:
#
#    Option     "XkbModel"      "microsoft"
#
# If you have a US "windows" keyboard you will want:
#
    
Option     "XkbModel"      "pc104"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#
#    Option     "XkbLayout"     "de"
#
# or:
#
     
Option     "XkbLayout"     "en,ar"
#    Option     "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#
    
Option     "XkbOptions"    "grp:alt_shift_toggle,grp_led:scroll"


# These are the default XKB settings for X.Org
#
#    Option     "XkbRules"      "xorg"
#    Option     "XkbModel"      "pc101"
#    Option     "XkbLayout"     "us"
#    Option     "XkbVariant"    ""
#    Option     "XkbOptions"    ""

EndSection 
but nothing happens ,

Second : The screen ,
the screen is showing things very well but when i try to scroll any thing ( such as this page that i am now writting in ) i find that the page is move up/down hardly , the painting process of the characters on screen have a great delay ( this happens both on kde and xfce )

Third : my mouse & keyboard:
After i have installed the slackware and when he prompt me to enter username & pass, my keyboard just dead, after many trings after my GOD, ALLAH, helped me, it began to work well alone, but the scroll in the mouse don't work, how can i make it work ?
my mouse is sony & keyboard is LG

thanx for you patient
 
Old 07-11-2007, 08:04 AM   #2
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,170
Blog Entries: 29

Rep: Reputation: 132Reputation: 132
Quote:
Originally Posted by daziplqa

Third : my mouse & keyboard:
After i have installed the slackware and when he prompt me to enter username & pass, my keyboard just dead, after many trings after my GOD, ALLAH, helped me, it began to work well alone, but the scroll in the mouse don't work, how can i make it work ?
my mouse is sony & keyboard is LG

thanx for you patient
Hi! I can't help with your first two problems, but this is how I fixed my mouse wheel:

Quote:
Get Your X Server Working
4) run xf86config. This is where you set up your X server. This can be frustrating. Read a lot. I like to make sure X is working here before I go any further. If you are new to Linux, it sure is helpful to have X up and running right off the bat. One tip, if you have a scroll wheel mouse and it isn't scrolling properly, edit your xf86config file to read something like this:
Section "InputDevice"

# Identifier and driver

Code:
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
That last line is the important one you may have to add
This information is from a great thread on this forum that you can find here: This is how I do it all.

Regards,

-Drew
 
Old 07-11-2007, 08:26 AM   #3
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,827

Rep: Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866
1.
If you want to switch languages you should uncomment (remove the # in the front) the following line in your xorg.conf
Code:
Option     "XkbRules"      "xorg"
2.
I guess this is due to your hardware in general and more likely to your vga card and cpu/memory. You can try to use a lower resolution, or less colors to see if it gets better.
3.
Already answered by Lufbery

Regards
 
Old 07-11-2007, 06:07 PM   #4
daziplqa
Member
 
Registered: May 2006
Location: Egypt
Distribution: RedHat 9.0, Ubuntu 6.06 and Slackware 11
Posts: 54

Original Poster
Rep: Reputation: 15
Thanks to ALLAH, then to you, thank you very very much

After reducing the screen depth to 16 , it worked fine.
and the mouse get scrolled.

but the language, i made what you told me but the i can not switch to arabic language using the keyboard ( although i can write in ). + the files in arabic doesn't appear with its nature name, it appeared at first as ?????? then after following some steps that i was following since redhat9.0, it convereted to non-arabic non-readable characters,
 
Old 07-11-2007, 08:12 PM   #5
randomsel
Member
 
Registered: Oct 2006
Location: Wilmington, DE
Distribution: Slackware 11
Posts: 201

Rep: Reputation: 30
Maybe changing the locale could help?

And KDE has nice localization.
 
Old 07-11-2007, 09:44 PM   #6
daziplqa
Member
 
Registered: May 2006
Location: Egypt
Distribution: RedHat 9.0, Ubuntu 6.06 and Slackware 11
Posts: 54

Original Poster
Rep: Reputation: 15
Thank to much ,

Another question

What about slapt-get ???
I heared about it and it just like apt-get of debian, so why not use it instead of suffering with many dependency problems that i may face ?
 
Old 07-12-2007, 02:02 AM   #7
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,827

Rep: Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866Reputation: 1866
Quote:
Option "XkbLayout" "en,ar"
Change the above line to
Code:
Option     "XkbLayout"     "us,ar"
slapt-get is a good tool to help you install/upgrade your software taking care of dependencies. You can also use swaret that does the same job.

Regards
 
Old 07-13-2007, 04:45 AM   #8
daziplqa
Member
 
Registered: May 2006
Location: Egypt
Distribution: RedHat 9.0, Ubuntu 6.06 and Slackware 11
Posts: 54

Original Poster
Rep: Reputation: 15
is slapt-get reliable like apt-get ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What is the use of lang in <head lang=''> tooparam Programming 2 02-01-2006 05:55 PM
Getting slack up and running - a few troubles. theMonkeY Slackware 6 09-04-2004 01:09 PM
Where is the LANG attribute setted in slack 10 jml75 Slackware 2 08-08-2004 10:24 PM
2.6.6 and Slack troubles dsedov Slackware 13 05-13-2004 04:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration