LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   I am new to slack having some troubles: lang, screen, etc (https://www.linuxquestions.org/questions/slackware-14/i-am-new-to-slack-having-some-troubles-lang-screen-etc-568392/)

daziplqa 07-11-2007 07:40 AM

I am new to slack having some troubles: lang, screen, etc
 
Hi all,
I am new to slackware, coming from ubuntu cause i wanna be linux guru :D
I have a somewhat old pc, so running kde makes my machine not function well, so i used xfce or whatever it called.

Some troubles faced me like:
1- the language, i want to write into arabic letter, so i have modified /etc/X11/xorg.conf so it becomes :

PHP Code:

Section "InputDevice"

    
Identifier    "Keyboard1"
    
Driver    "kbd"

# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

#    Option     "Protocol"      "Xqueue"

# Set the keyboard auto repeat parameters.  Not all platforms implement
# this.

#    Option     "AutoRepeat"    "500 5"

# Specifiy which keyboard LEDs can be user-controlled (eg, with xset(1)).

#    Option     "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.

#    Option     "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a European
# keyboard, you will probably want to use one of:
#
#    Option     "XkbModel"      "pc102"
#    Option     "XkbModel"      "pc105"
#
# If you have a Microsoft Natural keyboard, you can use:
#
#    Option     "XkbModel"      "microsoft"
#
# If you have a US "windows" keyboard you will want:
#
    
Option     "XkbModel"      "pc104"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#
#    Option     "XkbLayout"     "de"
#
# or:
#
     
Option     "XkbLayout"     "en,ar"
#    Option     "XkbVariant"    "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#
    
Option     "XkbOptions"    "grp:alt_shift_toggle,grp_led:scroll"


# These are the default XKB settings for X.Org
#
#    Option     "XkbRules"      "xorg"
#    Option     "XkbModel"      "pc101"
#    Option     "XkbLayout"     "us"
#    Option     "XkbVariant"    ""
#    Option     "XkbOptions"    ""

EndSection 

but nothing happens ,

Second : The screen ,
the screen is showing things very well but when i try to scroll any thing ( such as this page that i am now writting in ) i find that the page is move up/down hardly , the painting process of the characters on screen have a great delay ( this happens both on kde and xfce )

Third : my mouse & keyboard:
After i have installed the slackware and when he prompt me to enter username & pass, my keyboard just dead, after many trings after my GOD, ALLAH, helped me, it began to work well alone, but the scroll in the mouse don't work, how can i make it work ?
my mouse is sony & keyboard is LG

thanx for you patient
:D :D

Lufbery 07-11-2007 08:04 AM

Quote:

Originally Posted by daziplqa

Third : my mouse & keyboard:
After i have installed the slackware and when he prompt me to enter username & pass, my keyboard just dead, after many trings after my GOD, ALLAH, helped me, it began to work well alone, but the scroll in the mouse don't work, how can i make it work ?
my mouse is sony & keyboard is LG

thanx for you patient
:D :D

Hi! I can't help with your first two problems, but this is how I fixed my mouse wheel:

Quote:

Get Your X Server Working
4) run xf86config. This is where you set up your X server. This can be frustrating. Read a lot. I like to make sure X is working here before I go any further. If you are new to Linux, it sure is helpful to have X up and running right off the bat. One tip, if you have a scroll wheel mouse and it isn't scrolling properly, edit your xf86config file to read something like this:
Section "InputDevice"

# Identifier and driver

Code:

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"

That last line is the important one you may have to add
This information is from a great thread on this forum that you can find here: This is how I do it all.

Regards,

-Drew

bathory 07-11-2007 08:26 AM

1.
If you want to switch languages you should uncomment (remove the # in the front) the following line in your xorg.conf
Code:

Option    "XkbRules"      "xorg"
2.
I guess this is due to your hardware in general and more likely to your vga card and cpu/memory. You can try to use a lower resolution, or less colors to see if it gets better.
3.
Already answered by Lufbery

Regards

daziplqa 07-11-2007 06:07 PM

Thanks to ALLAH, then to you, thank you very very much :D

After reducing the screen depth to 16 , it worked fine.
and the mouse get scrolled.

but the language, i made what you told me but the i can not switch to arabic language using the keyboard ( although i can write in ). + the files in arabic doesn't appear with its nature name, it appeared at first as ?????? then after following some steps that i was following since redhat9.0, it convereted to non-arabic non-readable characters,

randomsel 07-11-2007 08:12 PM

Maybe changing the locale could help?

And KDE has nice localization.

daziplqa 07-11-2007 09:44 PM

Thank to much ,

Another question :D

What about slapt-get ???
I heared about it and it just like apt-get of debian, so why not use it instead of suffering with many dependency problems that i may face ?

bathory 07-12-2007 02:02 AM

Quote:

Option "XkbLayout" "en,ar"
Change the above line to
Code:

Option    "XkbLayout"    "us,ar"
slapt-get is a good tool to help you install/upgrade your software taking care of dependencies. You can also use swaret that does the same job.

Regards

daziplqa 07-13-2007 04:45 AM

is slapt-get reliable like apt-get ?


All times are GMT -5. The time now is 03:01 AM.