LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-05-2014, 07:18 PM   #1
Xerxeslins
LQ Newbie
 
Registered: Feb 2009
Posts: 16

Rep: Reputation: 0
Question I am getting error when trying to install FREshplayerplugin (yes, FRESH)


I'm using Slackware 14.1 with multilib.

As you may know, there is a "freshplugin" that lets you use the flash pepper Google Chrome on Firefox. So you can use the latest version of Flash Plugin in Firefox. This story because all those Google Chrome no longer use the NPAPI and instead use the PPAPI.

Well, the freshplayer is available at:

https://github.com/i-rinat/freshplayerplugin

I follow the instructions to install. What I do is the following:

$ git clone https://github.com/i-rinat/freshplayerplugin
$ cd freshplayerplugin
$ mkdir build
$ cd build

Now, the next two commands should be:

$ cmake ..
$ make

However, after running the first of these I get the following message in the terminal:

-- checking for modules 'alsa;glib-2.0;x11;xinerama;egl;glesv2;liburiparser;libconfig;libevent;libevent_pthreads;cairo;pango;pangocairo ;pangoft2;freetype2;gtk+-2.0'

-- package 'glesv2' not found
-- package 'liburiparser' not found

CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message):
A required package was not found
Call Stack (most recent call first):
/usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal)
CMakeLists.txt:22 (pkg_check_modules)


-- Configuring incomplete, errors occurred!
See also "/home/xerxeslins/freshplayerplugin/build/CMakeFiles/CMakeOutput.log".


Apparently missing two dependencies: glesv2 and liburiparser.

Is that really what's happening?
You can solve this problem in Slackware?
Perhaps freshplugin has been designed just for Ubuntu?
Anyone have any idea?



Thank you very much!
 
Old 07-05-2014, 07:22 PM   #2
ReaperX7
LQ Guru
 
Registered: Jul 2011
Location: California
Distribution: Slackware64-Current
Posts: 6,449
Blog Entries: 15

Rep: Reputation: 2020Reputation: 2020Reputation: 2020Reputation: 2020Reputation: 2020Reputation: 2020Reputation: 2020Reputation: 2020Reputation: 2020Reputation: 2020Reputation: 2020
Glesv2 can be added via MesaLib. Just add the appropriate flags to the configuration and rebuild the SlackBuild, and reinstall the package. Get the sources and run ./configure --help for more info.

Liburiparser will have to be downloaded and installed from here:

http://uriparser.sourceforge.net/

Src2pkg can help if a SlackBuild doesn't exist.

Last edited by ReaperX7; 07-05-2014 at 07:23 PM.
 
Old 07-05-2014, 07:33 PM   #3
Xerxeslins
LQ Newbie
 
Registered: Feb 2009
Posts: 16

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ReaperX7 View Post
Glesv2 can be added via MesaLib. Just add the appropriate flags to the configuration and rebuild the SlackBuild, and reinstall the package. Get the sources and run ./configure --help for more info.

Liburiparser will have to be downloaded and installed from here:

http://uriparser.sourceforge.net/

Src2pkg can help if a SlackBuild doesn't exist.
Thank you! I'll try later and I'll post the result.
 
Old 07-05-2014, 08:27 PM   #4
schmatzler
Member
 
Registered: Jan 2011
Location: Germany
Distribution: Slackware64 -current + Multilib
Posts: 405

Rep: Reputation: 178Reputation: 178
liburiparser can be built with:

Code:
src2pkg uriparser-0.8.0.tar.bz2 -e='--disable-test --disable-doc'
libconfig is also needed, we have a SlackBuild for that: http://slackbuilds.org/repository/14...ries/libconfig

Mesa has to be rebuilt with the configure flag "--enable-gles2".

After that, I put the generated libfreshwrapper-pepperflash.so into ~/.mozilla/plugins.

And - it crashes all the time. The latest trunk does not work at all. So I loaded version 0.1.0 from github:

https://github.com/i-rinat/freshplay...ses/tag/v0.1.0

According to the README one should create ~/.config/freshwrapper.conf with the content:

Code:
plugin_path = "/usr/lib64/PepperFlash/libpepflashplayer.so"
BUT: Version 0.1.0 does not recognize this, I don't know why. I had to edit the file src/np_entry.c like this:

Code:
#define PPFP_PATH "/usr/lib64/PepperFlash/libpepflashplayer.so"
That was messy. But now it works like a charme!

Last edited by schmatzler; 07-31-2015 at 12:03 PM.
 
Old 07-05-2014, 10:11 PM   #5
Xerxeslins
LQ Newbie
 
Registered: Feb 2009
Posts: 16

Original Poster
Rep: Reputation: 0
Smile

Thank you very much! Everything working here thanks for your help!
Attached Thumbnails
Click image for larger version

Name:	freshplugin.png
Views:	51
Size:	178.4 KB
ID:	15849  
 
Old 07-06-2014, 09:58 AM   #6
schmatzler
Member
 
Registered: Jan 2011
Location: Germany
Distribution: Slackware64 -current + Multilib
Posts: 405

Rep: Reputation: 178Reputation: 178
The developer just made fixes for Slackware, the latest trunk works now, too.

You get two plugins now, the freshwrapper plugin and a NaCl plugin - I copied both of them into the plugins directory and deleted the old one - done. Works very smooth and doesn't spam the log anymore.

(The paths don't have to be edited anymore, too.)

Last edited by schmatzler; 07-06-2014 at 10:01 AM.
 
Old 07-06-2014, 10:21 AM   #7
Xerxeslins
LQ Newbie
 
Registered: Feb 2009
Posts: 16

Original Poster
Rep: Reputation: 0
Cool

Quote:
Originally Posted by schmatzler View Post
The developer just made fixes for Slackware, the latest trunk works now, too.

You get two plugins now, the freshwrapper plugin and a NaCl plugin - I copied both of them into the plugins directory and deleted the old one - done. Works very smooth and doesn't spam the log anymore.

(The paths don't have to be edited anymore, too.)
This is very good. Thank you. I just installed.

However, after some benchmark tests on:

http://www.snailsanimation.com/benchmark08_play.php

It was clear that this Freshplayer has a low performance compared to Flash Pipelight. Available in:

http://www.slackware.com/~alien/slackbuilds/pipelight/

I found it strange since the Freshplayer uses the native Linux plugin, while Pipelight uses Windows plugin. But it's true.
 
Old 07-11-2014, 03:20 PM   #8
1337_powerslacker
Member
 
Registered: Nov 2009
Distribution: Slackware64-current
Posts: 736
Blog Entries: 2

Rep: Reputation: 478Reputation: 478Reputation: 478Reputation: 478Reputation: 478
I got this error when trying to compile uriparser:

Code:
checking for dot... missing
configure: error: Please install Graphviz first.
Please tell me this is a mistake on the part of the developer. Graphviz is a package I should not have to compile to get uriparser to compile.
 
Old 07-11-2014, 03:51 PM   #9
55020
Senior Member
 
Registered: Sep 2009
Location: Yorks. W.R. 167397
Distribution: Slackware
Posts: 1,307
Blog Entries: 4

Rep: Reputation: Disabled
Quote:
Originally Posted by mattallmill View Post
I got this error when trying to compile uriparser:

Code:
checking for dot... missing
configure: error: Please install Graphviz first.
Please tell me this is a mistake on the part of the developer. Graphviz is a package I should not have to compile to get uriparser to compile.
No, it's not a mistake on the part of the developer. Lots of packages *optionally* need doxygen, dot from graphviz, etc etc, to generate documentation, and lots of SlackBuilds disable all that. If you had run './configure --help' before trying to compile it, then you would have seen the '--disable-doc' option in the configure options.
 
Old 07-11-2014, 04:09 PM   #10
1337_powerslacker
Member
 
Registered: Nov 2009
Distribution: Slackware64-current
Posts: 736
Blog Entries: 2

Rep: Reputation: 478Reputation: 478Reputation: 478Reputation: 478Reputation: 478
Quote:
Originally Posted by 55020 View Post
No, it's not a mistake on the part of the developer. Lots of packages *optionally* need doxygen, dot from graphviz, etc etc, to generate documentation, and lots of SlackBuilds disable all that. If you had run './configure --help' before trying to compile it, then you would have seen the '--disable-doc' option in the configure options.
Thanks. It compiled successfully this time, using that option.
 
  


Reply

Tags
flash, fresh, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LiVES - Error on fresh install Barclay Linux - Software 2 04-02-2012 08:59 PM
consistant boot error after fresh install Dknife9 Slackware 2 04-14-2007 09:22 PM
Xserver error after fresh install eviltama Debian 2 03-05-2006 03:40 AM
Gentoo Grub Error (Fresh Install) dkaplowitz Linux - Distributions 6 11-21-2003 02:55 PM
compiler error after fresh install of slack 8.1 fern Linux - General 3 03-06-2003 06:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration